summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-11-08 14:15:09 +0000
committerJeroen Roovers <jer@gentoo.org>2013-11-08 14:15:09 +0000
commit55034b1df1095527b82dcc60c4e6600e29323266 (patch)
treeaa90c926c2484e1bd5684cdaa095bd1f4a0d84fc /www-client/firefox
parentversion bump, fix #490469 (diff)
downloadgentoo-2-55034b1df1095527b82dcc60c4e6600e29323266.tar.gz
gentoo-2-55034b1df1095527b82dcc60c4e6600e29323266.tar.bz2
gentoo-2-55034b1df1095527b82dcc60c4e6600e29323266.zip
Fix systems where the stack grows up (bug #490746).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/ChangeLog6
-rw-r--r--www-client/firefox/files/firefox-25.0-stack-grows-up.patch11
-rw-r--r--www-client/firefox/firefox-25.0-r1.ebuild5
3 files changed, 20 insertions, 2 deletions
diff --git a/www-client/firefox/ChangeLog b/www-client/firefox/ChangeLog
index e57158db017b..f1a2d9921463 100644
--- a/www-client/firefox/ChangeLog
+++ b/www-client/firefox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/firefox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.281 2013/11/04 13:46:39 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.282 2013/11/08 14:15:09 jer Exp $
+
+ 08 Nov 2013; Jeroen Roovers <jer@gentoo.org> firefox-25.0-r1.ebuild,
+ +files/firefox-25.0-stack-grows-up.patch:
+ Fix systems where the stack grows up (bug #490746).
*firefox-24.1.0-r1 (04 Nov 2013)
*firefox-25.0-r1 (04 Nov 2013)
diff --git a/www-client/firefox/files/firefox-25.0-stack-grows-up.patch b/www-client/firefox/files/firefox-25.0-stack-grows-up.patch
new file mode 100644
index 000000000000..87c255434723
--- /dev/null
+++ b/www-client/firefox/files/firefox-25.0-stack-grows-up.patch
@@ -0,0 +1,11 @@
+--- a/mozilla-release/js/src/vm/Runtime.cpp
++++ b/mozilla-release/js/src/vm/Runtime.cpp
+@@ -283,7 +283,7 @@
+ PodZero(&atomState);
+
+ #if JS_STACK_GROWTH_DIRECTION > 0
+- nativeStackLimit = UINTPTR_MAX;
++ mainThread.nativeStackLimit = UINTPTR_MAX;
+ #endif
+ }
+
diff --git a/www-client/firefox/firefox-25.0-r1.ebuild b/www-client/firefox/firefox-25.0-r1.ebuild
index 3e3c9cb6f6f8..771298a9f453 100644
--- a/www-client/firefox/firefox-25.0-r1.ebuild
+++ b/www-client/firefox/firefox-25.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-25.0-r1.ebuild,v 1.1 2013/11/04 13:46:39 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-25.0-r1.ebuild,v 1.2 2013/11/08 14:15:09 jer Exp $
EAPI="3"
VIRTUALX_REQUIRED="pgo"
@@ -148,6 +148,9 @@ src_prepare() {
EPATCH_FORCE="yes" \
epatch "${WORKDIR}/firefox"
+ # Fix systems where the stack grows up (bug #490746)
+ epatch "${FILESDIR}"/${P}-stack-grows-up.patch
+
# Allow user to apply any additional patches without modifing ebuild
epatch_user