summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-05-25 19:07:04 +0000
committerBen de Groot <yngwin@gentoo.org>2009-05-25 19:07:04 +0000
commit36ae3fc1a93596dc842322d2fd59f21d2733d259 (patch)
tree23d5172549d231e68fc48ac89d9de09b160b10d7 /www-client/arora
parentMarking audacious-themes-0.0.4 ppc64 for bug 260692 (diff)
downloadgentoo-2-36ae3fc1a93596dc842322d2fd59f21d2733d259.tar.gz
gentoo-2-36ae3fc1a93596dc842322d2fd59f21d2733d259.tar.bz2
gentoo-2-36ae3fc1a93596dc842322d2fd59f21d2733d259.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-client/arora')
-rw-r--r--www-client/arora/ChangeLog7
-rw-r--r--www-client/arora/arora-0.7.0.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/www-client/arora/ChangeLog b/www-client/arora/ChangeLog
index c72fe3fe23de..844846b4f91c 100644
--- a/www-client/arora/ChangeLog
+++ b/www-client/arora/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/arora
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.14 2009/05/10 14:40:09 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.15 2009/05/25 19:07:04 yngwin Exp $
+
+*arora-0.7.0 (25 May 2009)
+
+ 25 May 2009; Ben de Groot <yngwin@gentoo.org> +arora-0.7.0.ebuild:
+ Version bump
10 May 2009; Ben de Groot <yngwin@gentoo.org> -arora-0.5.ebuild,
-arora-0.6-r1.ebuild, arora-0.6.1.ebuild:
diff --git a/www-client/arora/arora-0.7.0.ebuild b/www-client/arora/arora-0.7.0.ebuild
new file mode 100644
index 000000000000..926cfcd92f30
--- /dev/null
+++ b/www-client/arora/arora-0.7.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.7.0.ebuild,v 1.1 2009/05/25 19:07:04 yngwin Exp $
+
+EAPI=2
+inherit eutils qt4
+
+DESCRIPTION="A cross-platform Qt4 WebKit browser"
+HOMEPAGE="http://arora.googlecode.com/"
+SRC_URI="http://arora.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/qt-gui
+ x11-libs/qt-sql
+ x11-libs/qt-webkit"
+DEPEND="$RDEPEND"
+
+ARORA_LANGS="es es_CR et_EE fr_CA gl ms nb_NO uk zh_CN"
+ARORA_NOLONGLANGS="cs_CZ da_DK de_DE fr_FR he_IL hu_HU it_IT ja_JP nl_NL pl_PL
+ ru_RU sk_SK tr_TR"
+
+for L in $ARORA_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $ARORA_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ # process linguas
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $ARORA_LANGS; then
+ langs="$langs ${lingua}.ts"
+ else
+ for a in $ARORA_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs ${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove all translations, then add only the ones we want
+ sed -i '/ts/d' src/locale/locale.pri || die 'sed failed'
+ sed -i "/^TRANSLATIONS/s:\\\:${langs}:" src/locale/locale.pri \
+ || die 'sed failed'
+}
+
+src_configure() {
+ eqmake4 arora.pro PREFIX=/usr
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # don't pre-strip
+ sed -i "/strip/d" src/Makefile || die 'sed failed'
+}
+
+src_install() {
+ emake -j1 INSTALL_ROOT="${D}" install || die 'make install failed'
+ dodoc AUTHORS ChangeLog README
+}