summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2011-07-14 16:25:43 +0000
committerLance Albertson <ramereth@gentoo.org>2011-07-14 16:25:43 +0000
commitcb1ce0e5a82a46e00bafd9dc862f7ae30b5a50fd (patch)
tree19ec1c7e63e45f6edc5c587e4b10e1cfdee42428 /www-apps
parentAnother parallel build fix (bug #375121). (diff)
downloadgentoo-2-cb1ce0e5a82a46e00bafd9dc862f7ae30b5a50fd.tar.gz
gentoo-2-cb1ce0e5a82a46e00bafd9dc862f7ae30b5a50fd.tar.bz2
gentoo-2-cb1ce0e5a82a46e00bafd9dc862f7ae30b5a50fd.zip
Version bump (resolves #372283), ebuild cleanup
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/dokuwiki/ChangeLog9
-rw-r--r--www-apps/dokuwiki/dokuwiki-20091225c.ebuild71
-rw-r--r--www-apps/dokuwiki/dokuwiki-20110525a.ebuild (renamed from www-apps/dokuwiki/dokuwiki-20101107.ebuild)31
3 files changed, 20 insertions, 91 deletions
diff --git a/www-apps/dokuwiki/ChangeLog b/www-apps/dokuwiki/ChangeLog
index 7be117dbd9b6..ccceb6b37742 100644
--- a/www-apps/dokuwiki/ChangeLog
+++ b/www-apps/dokuwiki/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/dokuwiki
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.53 2011/05/28 16:43:37 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.54 2011/07/14 16:25:43 ramereth Exp $
+
+*dokuwiki-20110525a (14 Jul 2011)
+
+ 14 Jul 2011; Lance Albertson <ramereth@gentoo.org>
+ -dokuwiki-20091225c.ebuild, -dokuwiki-20101107.ebuild,
+ +dokuwiki-20110525a.ebuild:
+ Version bump (resolves #372283), ebuild cleanup
*dokuwiki-20110525 (28 May 2011)
diff --git a/www-apps/dokuwiki/dokuwiki-20091225c.ebuild b/www-apps/dokuwiki/dokuwiki-20091225c.ebuild
deleted file mode 100644
index 973cc3d8681e..000000000000
--- a/www-apps/dokuwiki/dokuwiki-20091225c.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20091225c.ebuild,v 1.5 2010/03/14 19:23:40 armin76 Exp $
-
-inherit webapp depend.php
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PV="${MY_BASE_PV}${PV:8:1}"
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
-HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
-SRC_URI="http://www.splitbrain.org/_media/projects/${PN}/${PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-need_httpd_cgi
-need_php_httpd
-
-S="${WORKDIR}/${PN}-${MY_BASE_PV}"
-
-pkg_setup() {
- webapp_pkg_setup
- has_php
- if [[ ${PHP_VERSION} == "4" ]] ; then
- require_php_with_use cli expat
- else
- require_php_with_use cli xml
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # create initial changes file
- touch data/changes.log
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc README
- rm -f README COPYING VERSION
-
- docinto scripts
- dodoc bin/*
- rm -rf bin
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- for x in $(find data/ -not -name '.htaccess'); do
- webapp_serverowned "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
- webapp_configfile "${MY_HTDOCSDIR}"/conf
-
- for x in $(find conf/ -not -name 'msg'); do
- webapp_configfile "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}
diff --git a/www-apps/dokuwiki/dokuwiki-20101107.ebuild b/www-apps/dokuwiki/dokuwiki-20110525a.ebuild
index 06acbe43f894..197512a89f37 100644
--- a/www-apps/dokuwiki/dokuwiki-20101107.ebuild
+++ b/www-apps/dokuwiki/dokuwiki-20110525a.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20101107.ebuild,v 1.2 2011/05/26 18:17:59 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20110525a.ebuild,v 1.1 2011/07/14 16:25:43 ramereth Exp $
+
+EAPI="4"
inherit webapp depend.php
@@ -13,31 +15,22 @@ HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
SRC_URI="http://www.splitbrain.org/_media/projects/${PN}/${PN}-${MY_PV}.tgz"
LICENSE="GPL-2"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gd"
DEPEND=""
-RDEPEND=""
+RDEPEND="
+ || ( <dev-lang/php-5.3[xml,spl] >=dev-lang/php-5.3[xml] )
+ gd? ( || ( dev-lang/php[gd]
+ media-gfx/imagemagick )
+ )"
need_httpd_cgi
need_php_httpd
-S="${WORKDIR}/${PN}-${MY_BASE_PV}"
-
-pkg_setup() {
- webapp_pkg_setup
- has_php
- if [[ ${PHP_VERSION} == "4" ]] ; then
- require_php_with_use cli expat
- else
- require_php_with_use cli xml
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+src_prepare() {
# create initial changes file
touch data/changes.log
}