summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-08-02 18:43:39 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-08-02 18:43:39 +0000
commitc4ede18061bb16bb349f99294ee2ec9b57f0f5c5 (patch)
treedafc188f174ae942b8c63fa798d1c8a90afa4c1b /www-apps
parentstable/grizzly for nova too (diff)
downloadgentoo-2-c4ede18061bb16bb349f99294ee2ec9b57f0f5c5.tar.gz
gentoo-2-c4ede18061bb16bb349f99294ee2ec9b57f0f5c5.tar.bz2
gentoo-2-c4ede18061bb16bb349f99294ee2ec9b57f0f5c5.zip
stable/grizzly for everyone's favorite bastard child, grizzly :D
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/horizon/ChangeLog8
-rw-r--r--www-apps/horizon/horizon-2013.1.9999.ebuild37
-rw-r--r--www-apps/horizon/horizon-9999.ebuild3
3 files changed, 46 insertions, 2 deletions
diff --git a/www-apps/horizon/ChangeLog b/www-apps/horizon/ChangeLog
index a3843f2915c9..e6b350995d8d 100644
--- a/www-apps/horizon/ChangeLog
+++ b/www-apps/horizon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/horizon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/ChangeLog,v 1.5 2013/06/09 02:42:19 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/ChangeLog,v 1.6 2013/08/02 18:43:39 prometheanfire Exp $
+
+*horizon-2013.1.9999 (02 Aug 2013)
+
+ 02 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +horizon-2013.1.9999.ebuild, horizon-9999.ebuild:
+ stable/grizzly for everyone's favorite bastard child, grizzly :D
09 Jun 2013; Zac Medico <zmedico@gentoo.org> horizon-9999.ebuild:
Remove stray line.
diff --git a/www-apps/horizon/horizon-2013.1.9999.ebuild b/www-apps/horizon/horizon-2013.1.9999.ebuild
new file mode 100644
index 000000000000..225564d154bc
--- /dev/null
+++ b/www-apps/horizon/horizon-2013.1.9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-2013.1.9999.ebuild,v 1.1 2013/08/02 18:43:39 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Horizon is a Django-based project aimed at providing a complete
+OpenStack Dashboard."
+HOMEPAGE="https://launchpad.net/horizon"
+EGIT_REPO_URI="https://github.com/openstack/horizon.git"
+EGIT_BRANCH="stable/grizzly"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/django-1.4[${PYTHON_USEDEP}]
+ <dev-python/django-1.5[${PYTHON_USEDEP}]
+ dev-python/django-compressor
+ >=dev-python/django-openstack-auth-1.0.7[${PYTHON_USEDEP}]
+ dev-python/netaddr
+ >=dev-python/python-cinderclient-1.0.2[${PYTHON_USEDEP}]
+ <dev-python/python-cinderclient-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/python-glanceclient-2[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-2.12.0[${PYTHON_USEDEP}]
+ <dev-python/python-novaclient-3[${PYTHON_USEDEP}]
+ >=dev-python/python-quantumclient-2.2.0[${PYTHON_USEDEP}]
+ <dev-python/python-quantumclient-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-1.1[${PYTHON_USEDEP}]
+ <dev-python/python-swiftclient-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/lockfile"
diff --git a/www-apps/horizon/horizon-9999.ebuild b/www-apps/horizon/horizon-9999.ebuild
index 4a5a59fb9db0..f0ad3e94da69 100644
--- a/www-apps/horizon/horizon-9999.ebuild
+++ b/www-apps/horizon/horizon-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-9999.ebuild,v 1.3 2013/06/09 02:42:19 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-9999.ebuild,v 1.4 2013/08/02 18:43:39 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -11,6 +11,7 @@ DESCRIPTION="Horizon is a Django-based project aimed at providing a complete
OpenStack Dashboard."
HOMEPAGE="https://launchpad.net/horizon"
EGIT_REPO_URI="https://github.com/openstack/horizon.git"
+EGIT_BRANCH="master"
LICENSE="Apache-2.0"
SLOT="0"