summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-01-25 08:49:04 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-01-25 08:49:04 +0000
commitc0654b5dc4f04e8596ca79f04fc098f419e7d882 (patch)
treeab90bebd2653052771ead041448721ee31e5b973 /www-apps
parentmask games-fps/quake3-wop (diff)
downloadgentoo-2-c0654b5dc4f04e8596ca79f04fc098f419e7d882.tar.gz
gentoo-2-c0654b5dc4f04e8596ca79f04fc098f419e7d882.tar.bz2
gentoo-2-c0654b5dc4f04e8596ca79f04fc098f419e7d882.zip
Added roundup-1.4.1 (#204644). This also fixes #204308.
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/roundup/ChangeLog9
-rw-r--r--www-apps/roundup/files/digest-roundup-1.4.13
-rw-r--r--www-apps/roundup/roundup-1.4.1.ebuild50
3 files changed, 60 insertions, 2 deletions
diff --git a/www-apps/roundup/ChangeLog b/www-apps/roundup/ChangeLog
index 3ad507b2ac08..45eb0a07c138 100644
--- a/www-apps/roundup/ChangeLog
+++ b/www-apps/roundup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/roundup
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.12 2007/10/22 14:41:53 wrobel Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.13 2008/01/25 08:49:03 wrobel Exp $
+
+*roundup-1.4.1 (25 Jan 2008)
+
+ 25 Jan 2008; Gunnar Wrobel <wrobel@gentoo.org> +roundup-1.4.1.ebuild:
+ Added roundup-1.4.1 (#204644). This also fixes #204308.
*roundup-1.3.3 (22 Oct 2007)
diff --git a/www-apps/roundup/files/digest-roundup-1.4.1 b/www-apps/roundup/files/digest-roundup-1.4.1
new file mode 100644
index 000000000000..ebd946f73d1b
--- /dev/null
+++ b/www-apps/roundup/files/digest-roundup-1.4.1
@@ -0,0 +1,3 @@
+MD5 ea6571051ab9a5de7f22749dd4bcc1ce roundup-1.4.1.tar.gz 1355288
+RMD160 0c3492320e00d2bb5bd9a5883e23377ef8eff0df roundup-1.4.1.tar.gz 1355288
+SHA256 d770204c9e00b20c2eb30e437e04a47de0958b2852bb2093edcb9f988d4cc305 roundup-1.4.1.tar.gz 1355288
diff --git a/www-apps/roundup/roundup-1.4.1.ebuild b/www-apps/roundup/roundup-1.4.1.ebuild
new file mode 100644
index 000000000000..380a0d0f0395
--- /dev/null
+++ b/www-apps/roundup/roundup-1.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/roundup-1.4.1.ebuild,v 1.1 2008/01/25 08:49:03 wrobel Exp $
+
+inherit eutils
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces."
+SRC_URI="http://cheeseshop.python.org/packages/source/r/${PN}/${P}.tar.gz"
+HOMEPAGE="http://roundup.sourceforge.net"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=sys-libs/db-3.2.9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to fix the location for man pages (#204308)
+ sed -i -e 's#man/man1#share/man/man1#' setup.py
+}
+
+src_compile() {
+ python setup.py build || die
+}
+
+src_install() {
+ python setup.py install --root="${D}" --prefix=/usr || die
+ dodoc CHANGES.txt PKG-INFO README.txt doc/*.txt
+ dohtml doc/*.html
+ dobin "${FILESDIR}"/roundup
+}
+
+pkg_postnst() {
+ ewarn
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.py file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your \
+tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}