summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-06-11 10:21:46 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-06-11 10:21:46 +0000
commitb3ba189204d671a474edeef7a75a6f41c924e338 (patch)
tree8b1a12ac9ddaa2b1971f62a72e04130b0d435481 /www-apps
parentStable for amd64, wrt bug #418617 (diff)
downloadgentoo-2-b3ba189204d671a474edeef7a75a6f41c924e338.tar.gz
gentoo-2-b3ba189204d671a474edeef7a75a6f41c924e338.tar.bz2
gentoo-2-b3ba189204d671a474edeef7a75a6f41c924e338.zip
Make bash scripts in htdocs +x
(Portage version: 2.1.10.64/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rutorrent/ChangeLog7
-rw-r--r--www-apps/rutorrent/rutorrent-3.4-r1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/www-apps/rutorrent/ChangeLog b/www-apps/rutorrent/ChangeLog
index 17bbb30f6c1f..d945331f92e2 100644
--- a/www-apps/rutorrent/ChangeLog
+++ b/www-apps/rutorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/rutorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rutorrent/ChangeLog,v 1.4 2012/05/24 16:57:52 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rutorrent/ChangeLog,v 1.5 2012/06/11 10:21:46 maksbotan Exp $
+
+*rutorrent-3.4-r1 (11 Jun 2012)
+
+ 11 Jun 2012; Maxim Koltsov <maksbotan@gentoo.org> +rutorrent-3.4-r1.ebuild:
+ Make bash scripts in htdocs +x
*rutorrent-3.4 (24 May 2012)
diff --git a/www-apps/rutorrent/rutorrent-3.4-r1.ebuild b/www-apps/rutorrent/rutorrent-3.4-r1.ebuild
new file mode 100644
index 000000000000..23db103dd9c1
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-3.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rutorrent/rutorrent-3.4-r1.ebuild,v 1.1 2012/06/11 10:21:46 maksbotan Exp $
+
+EAPI="4"
+
+inherit webapp eutils depend.php
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="http://code.google.com/p/rutorrent/"
+SRC_URI="
+ http://rutorrent.googlecode.com/files/${P}.tar.gz
+ http://rutorrent.googlecode.com/files/plugins-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+DEPEND="
+ || ( dev-lang/php[xml,gd] dev-lang/php[xml,gd-external] )
+"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ mv plugins rutorrent
+ cd rutorrent
+ doins -r .
+
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "$ED${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/share
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/settings
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/torrents
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/users
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}