summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-09 21:30:45 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-09 21:30:45 +0000
commitb1ee2551b42b7ab762b659a4f1fc1a79f7171a4b (patch)
treeaf9c5ae0017831f87cec77add65282d985fb7397 /www-apps
parentFix libsoup-gnome dependencies wrt #340293 by Pacho Ramos. (diff)
downloadgentoo-2-b1ee2551b42b7ab762b659a4f1fc1a79f7171a4b.tar.gz
gentoo-2-b1ee2551b42b7ab762b659a4f1fc1a79f7171a4b.tar.bz2
gentoo-2-b1ee2551b42b7ab762b659a4f1fc1a79f7171a4b.zip
Version bump to the latest stable release (fixes bug #332745, thanks to Tobias Margitan for reporting and William Cooke for patches). Add sqlite3 USE flag, replace remaining pkg_setup use flag check with use dependencies, and add new postupgrade instructions since a few variables are set in LocalSettings.php instead of using AdminSettings.php.
(Portage version: 2.2_rc90/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mediawiki/ChangeLog12
-rw-r--r--www-apps/mediawiki/files/postupgrade-1.16-en.txt44
-rw-r--r--www-apps/mediawiki/mediawiki-1.16.0.ebuild126
3 files changed, 181 insertions, 1 deletions
diff --git a/www-apps/mediawiki/ChangeLog b/www-apps/mediawiki/ChangeLog
index 4bcf4fec0a3e..9cdb937cb101 100644
--- a/www-apps/mediawiki/ChangeLog
+++ b/www-apps/mediawiki/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-apps/mediawiki
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/ChangeLog,v 1.139 2010/10/09 21:05:44 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/ChangeLog,v 1.140 2010/10/09 21:30:45 radhermit Exp $
+
+*mediawiki-1.16.0 (09 Oct 2010)
+
+ 09 Oct 2010; Tim Harder <radhermit@gentoo.org> +mediawiki-1.16.0.ebuild,
+ +files/postupgrade-1.16-en.txt:
+ Version bump to the latest stable release (fixes bug #332745, thanks to
+ Tobias Margitan for reporting and William Cooke for patches). Add sqlite3
+ USE flag, replace remaining pkg_setup use flag check with use
+ dependencies, and add new postupgrade instructions since a few variables
+ are set in LocalSettings.php instead of using AdminSettings.php.
09 Oct 2010; Tim Harder <radhermit@gentoo.org> mediawiki-1.15.5.ebuild:
Call webapp_pkg_setup first in pkg_setup.
diff --git a/www-apps/mediawiki/files/postupgrade-1.16-en.txt b/www-apps/mediawiki/files/postupgrade-1.16-en.txt
new file mode 100644
index 000000000000..ebf6f713ea97
--- /dev/null
+++ b/www-apps/mediawiki/files/postupgrade-1.16-en.txt
@@ -0,0 +1,44 @@
+These instructions help you to upgrade your mediawiki installation.
+
+Please NOTE: at this point it is supposed that you've already read
+RELEASE-NOTES and done full wiki backup, as described here:
+http://www.mediawiki.org/wiki/Manual:Backing_up_a_wiki
+
+
+Run the update script
+=====================
+
+Note: Make sure $wgDBadminusr and $wgDBadminpassword is set in your
+LocalSettings.php file in your wiki root. The user needs full permissions
+(shell access) on the database.
+
+The preferred method of performing the update is using the command-line
+maintenance script, although it is also possible to re-run the web-based
+installer. To run command-line maintenance script, change to the maintenance
+directory and execute the update script:
+
+$ cd ${MY_INSTALLDIR}/maintenance
+$ php update.php
+
+MediaWiki will inspect the existing schema and update it to work with the new
+code, adding tables and columns as needed.
+
+For alternative ways to upgrade your wiki, please, take a look at:
+http://www.mediawiki.org/wiki/Manual:Upgrading
+
+
+Upgrade extensions
+==================
+
+Certain extensions have been updated in order to work with MediaWiki 1.13. Be
+sure to upgrade to the latest versions of such extensions. You might need to
+perform manual updates to custom extensions.
+
+
+Test the update
+===============
+
+Once the upgrade has completed, browse to the wiki and check basics such as
+viewing and editing pages to ensure things still work as expected.
+
+Visit Special:Version and check that the version shown is correct.
diff --git a/www-apps/mediawiki/mediawiki-1.16.0.ebuild b/www-apps/mediawiki/mediawiki-1.16.0.ebuild
new file mode 100644
index 000000000000..84aa7f7181c9
--- /dev/null
+++ b/www-apps/mediawiki/mediawiki-1.16.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.16.0.ebuild,v 1.1 2010/10/09 21:30:45 radhermit Exp $
+
+EAPI="3"
+inherit webapp depend.php versionator eutils
+
+MY_BRANCH=$(get_version_component_range 1-2)
+
+DESCRIPTION="The MediaWiki wiki web application (as used on wikipedia.org)"
+HOMEPAGE="http://www.mediawiki.org"
+SRC_URI="http://download.wikimedia.org/mediawiki/${MY_BRANCH}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="imagemagick math mysql postgres +ocamlopt sqlite3"
+
+DEPEND="math? ( >=dev-lang/ocaml-3.0.6[ocamlopt?] )"
+RDEPEND="${DEPEND}
+ math? (
+ app-text/dvipng
+ virtual/tex-base
+ app-text/ghostscript-gpl
+ media-gfx/imagemagick
+ )
+ imagemagick? ( media-gfx/imagemagick )
+ || ( <dev-lang/php-5.3[mysql?,pcre,postgres?,session,spl,xml]
+ >=dev-lang/php-5.3[mysql?,postgres?,session,xml] )
+ || ( dev-lang/php[gd] dev-lang/php[gd-external] )
+ sqlite3? ( >=dev-db/sqlite-3.6[fts3] )"
+
+RESTRICT="test"
+
+need_httpd_cgi
+need_php_httpd
+
+src_compile() {
+ if use math; then
+ einfo "Compiling math support"
+ cd math || die
+ if ! use ocamlopt; then
+ sed -e "s/ocamlopt/ocamlc/" \
+ -e "s/cmxa/cma/" \
+ -e "s/cmx/cmo/g" -i Makefile || die
+ fi
+ emake || die
+ else
+ einfo "Math support not enabled. Skipping."
+ fi
+
+ # TODO: 1. think about includes/zhtable/ support
+ # 2. generate docs (?): echo '0' | php mwdocgen.php
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # First we install math, docs and then copy everything left into htdocs dir
+ # to avoid bugs like #236411.
+
+ # If we've enabled math USE-flag, install math support.
+ # We ensure the directories are prepared for writing. The post-
+ # install instructions guide the user to enable the feature.
+ if use math; then
+ einfo "Installing math support"
+ exeinto "${MY_HTDOCSDIR}"/math
+ doexe math/texvc || die "Failed to create math support executable."
+
+ docinto math
+ dodoc math/{README,TODO}
+ docinto ""
+
+ # Working directories. Server writeable.
+ dodir "${MY_HTDOCSDIR}"/images/math
+ webapp_serverowned "${MY_HTDOCSDIR}"/images/math
+ dodir "${MY_HTDOCSDIR}"/images/tmp
+ webapp_serverowned "${MY_HTDOCSDIR}"/images/tmp
+ fi
+
+ local DOCS="FAQ HISTORY INSTALL README RELEASE-NOTES UPGRADE"
+ dodoc ${DOCS} docs/*.txt
+ docinto php-memcached
+ dodoc docs/php-memcached/*
+
+ # Clean everything not used at the site...
+ rm -rf ${DOCS} COPYING tests math t docs
+ find . -name Makefile -delete
+ # and install
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # If imagemagick is enabled then setup for image upload.
+ # We ensure the directory is prepared for writing.
+ if use imagemagick; then
+ webapp_serverowned "${MY_HTDOCSDIR}"/images
+ fi
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-1.13-en.txt"
+ webapp_postupgrade_txt en "${FILESDIR}/postupgrade-1.16-en.txt"
+ webapp_src_install
+}
+
+pkg_preinst() {
+ prev_instal="false"
+ if has_version ${CATEGORY}/${PN}; then
+ prev_instal="true"
+ fi
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ if ${prev_instal}; then
+ einfo
+ elog "=== Consult the release notes ==="
+ elog "Before doing anything, stop and consult the release notes"
+ elog "/usr/share/doc/${PF}/RELEASE-NOTES.bz2"
+ elog
+ elog "These detail bug fixes, new features and functionality, and any"
+ elog "particular points that may need to be noted during the upgrade procedure."
+ einfo
+ ewarn "Back up existing files and the database before upgrade."
+ ewarn "http://www.mediawiki.org/wiki/Manual:Backing_up_a_wiki"
+ ewarn "provides an overview of the backup process."
+ einfo
+ fi
+}