summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-20 13:04:17 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-20 13:04:17 +0000
commit8f0b746599fb14fda933996cd48182f5aff6a974 (patch)
tree7bbfa5451cbf51c74711fc31474e0691e52aa354 /www-apps
parentuse ecvs_clean; fix quoting (diff)
downloadgentoo-2-8f0b746599fb14fda933996cd48182f5aff6a974.tar.gz
gentoo-2-8f0b746599fb14fda933996cd48182f5aff6a974.tar.bz2
gentoo-2-8f0b746599fb14fda933996cd48182f5aff6a974.zip
webappify viewvc, #182093
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/viewvc/ChangeLog10
-rw-r--r--www-apps/viewvc/metadata.xml2
-rw-r--r--www-apps/viewvc/viewvc-1.0.3.ebuild105
-rw-r--r--www-apps/viewvc/viewvc-1.0.4-r1.ebuild113
-rw-r--r--www-apps/viewvc/viewvc-1.0.4.ebuild6
5 files changed, 125 insertions, 111 deletions
diff --git a/www-apps/viewvc/ChangeLog b/www-apps/viewvc/ChangeLog
index d6317432f564..c83e83b1bbbc 100644
--- a/www-apps/viewvc/ChangeLog
+++ b/www-apps/viewvc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/viewvc
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.15 2007/10/26 16:13:20 wrobel Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.16 2008/02/20 13:04:17 hollow Exp $
+
+*viewvc-1.0.4-r1 (20 Feb 2008)
+
+ 20 Feb 2008; Benedikt Böhm <hollow@gentoo.org> metadata.xml,
+ -viewvc-1.0.3.ebuild, viewvc-1.0.4.ebuild, +viewvc-1.0.4-r1.ebuild:
+ webappify viewvc, #182093
26 Oct 2007; wrobel@gentoo.org viewvc-1.0.4.ebuild:
Fixed message on installing the ebuild (see #179612).
diff --git a/www-apps/viewvc/metadata.xml b/www-apps/viewvc/metadata.xml
index 95c06f0095bb..6632069b5aff 100644
--- a/www-apps/viewvc/metadata.xml
+++ b/www-apps/viewvc/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>web-apps</herd>
+ <herd>web-apps</herd>
</pkgmetadata>
diff --git a/www-apps/viewvc/viewvc-1.0.3.ebuild b/www-apps/viewvc/viewvc-1.0.3.ebuild
deleted file mode 100644
index a044034e6318..000000000000
--- a/www-apps/viewvc/viewvc-1.0.3.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.0.3.ebuild,v 1.9 2007/09/08 01:21:56 beandog Exp $
-
-inherit python eutils
-
-SLOT="0"
-
-DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
-HOMEPAGE="http://viewvc.org/"
-SRC_URI="http://viewvc.tigris.org/files/documents/3330/34803/${P}.tar.gz"
-
-LICENSE="viewcvs"
-KEYWORDS="~amd64 ppc ~sparc x86"
-IUSE="cvs cvsgraph enscript highlight mod_python mysql subversion"
-
-RDEPEND="
- cvs? (
- >=dev-lang/python-1.5.2
- app-text/rcs
- )
-
- subversion? (
- >=dev-lang/python-2.0
- >=dev-util/subversion-1.2.0
- )
-
- cvsgraph? ( >=dev-util/cvsgraph-1.5.0 )
- enscript? ( app-text/enscript )
- highlight? ( >=app-text/highlight-2.2.10 )
- mod_python? ( www-apache/mod_python )
- mysql? (
- >=dev-python/mysql-python-0.9.0
- )
-"
-
-pkg_setup() {
- if use subversion && ! built_with_use dev-util/subversion python ; then
- eerror "Your Subversion has been built without Python bindings"
- die "Emerge dev-util/subversion with USE=\"python\""
- fi
-}
-
-src_unpack() {
- unpack ${A} && cd ${S}
-
- python_version
- local LIB_DIR="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
- local CONF_PATH="/usr/share/webapps/${PN}/viewvc.conf"
- find bin -type f |
- xargs sed -ie " s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"${LIB_DIR}\"|g
- s,\(^CONF_PATHNAME\)\(.*\$\),\1 = \"${CONF_PATH}\",g"
- sed -i "s|template_dir = templates|template_dir = /usr/share/webapps/${PN}/templates|" \
- viewvc.conf.dist
-}
-
-src_install() {
- python_version
-
- dodir /usr/share/webapps/${PN} /usr/share/webapps/${PN}/cgi-bin \
- /usr/share/webapps/${PN}/mod_python /usr/share/webapps/${PN}/bin \
- /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-
- exeinto /usr/share/webapps/${PN}/cgi-bin
- doexe bin/cgi/viewvc.cgi
-
- if use mysql ; then
- exeinto /usr/share/webapps/${PN}/cgi-bin
- doexe bin/cgi/query.cgi
- fi
-
- if use mod_python ; then
- insinto /usr/share/webapps/${PN}/mod_python
- doins bin/mod_python/viewvc.py
- doins bin/mod_python/handler.py
- doins bin/mod_python/.htaccess
-
- if use mysql ; then
- insinto /usr/share/webapps/${PN}/mod_python
- doins bin/mod_python/query.py
- fi
- fi
-
- cp -p bin/ ${D}/usr/share/webapps/${PN}/bin
- cp -rp templates ${D}/usr/share/webapps/${PN}
- cp -rp lib/* ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-
- insinto /usr/share/webapps/${PN}
- doins viewvc.conf.dist cvsgraph.conf.dist
-
- dodoc CHANGES COMMITTERS INSTALL README TODO
- dohtml -r viewvc.org/*
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-
- elog "Now read /usr/share/doc/${P}/INSTALL.gz to configure ${PN}"
-}
-
-pkg_postrm() {
- python_version
- python_mod_cleanup
-}
diff --git a/www-apps/viewvc/viewvc-1.0.4-r1.ebuild b/www-apps/viewvc/viewvc-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..26d0b6ed648f
--- /dev/null
+++ b/www-apps/viewvc/viewvc-1.0.4-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.0.4-r1.ebuild,v 1.1 2008/02/20 13:04:17 hollow Exp $
+
+inherit confutils webapp python eutils
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
+HOMEPAGE="http://viewvc.org/"
+SRC_URI="http://viewvc.tigris.org/files/documents/3330/37319/${P}.tar.gz"
+
+LICENSE="viewcvs"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cvs cvsgraph enscript highlight mod_python mysql subversion"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="
+ cvs? (
+ >=dev-lang/python-1.5.2
+ app-text/rcs
+ )
+
+ subversion? (
+ >=dev-lang/python-2.0
+ >=dev-util/subversion-1.2.0
+ )
+
+ mod_python? ( www-apache/mod_python )
+ !mod_python? ( virtual/httpd-cgi )
+
+ cvsgraph? ( >=dev-util/cvsgraph-1.5.0 )
+ enscript? ( app-text/enscript )
+ highlight? ( >=app-text/highlight-2.2.10 )
+ mysql? ( >=dev-python/mysql-python-0.9.0 )
+"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ confutils_require_any cvs subversion
+ confutils_use_depend_built_with_all subversion dev-util/subversion python
+
+ python_version
+ MOD_PATH=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ find bin/ -type f -print0 | xargs -0 sed -i \
+ -e "s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"${MOD_PATH}\"|g" \
+ -e "s|\(^CONF_PATHNAME\)\(.*\$\)|\1 = \"../conf/viewvc.conf\"|g"
+
+ sed -i -e "s|\(self\.options\.template_dir\)\(.*\$\)|\1 = \"${MY_APPDIR}/templates\"|" \
+ lib/config.py
+
+ sed -i -e "s|^template_dir.*|#&|" viewvc.conf.dist
+ mv viewvc.conf{.dist,}
+ mv cvsgraph.conf{.dist,}
+}
+
+src_install() {
+ webapp_src_preinst
+ python_version
+
+ dodoc CHANGES COMMITTERS INSTALL README TODO
+ dohtml -r viewvc.org/*
+
+ insinto "${MOD_PATH}"
+ doins -r lib/
+
+ insinto "${MY_APPDIR}"/templates
+ doins -r templates/
+
+ if use mysql; then
+ insinto "${MY_HOSTROOTDIR}"/bin
+ dobin bin/{*dbadmin,make-database,loginfo-handler}
+ fi
+
+ insinto "${MY_HOSTROOTDIR}"/conf
+ doins {viewvc,cvsgraph}.conf
+
+ if use mod_python; then
+ insinto "${MY_HTDOCSDIR}"
+ doins bin/mod_python/viewvc.py
+ doins bin/mod_python/handler.py
+ doins bin/mod_python/.htaccess
+ use mysql && doins bin/mod_python/query.py
+ else
+ exeinto "${MY_CGIBINDIR}"
+ doexe bin/cgi/viewvc.cgi
+ use mysql && doexe bin/cgi/query.cgi
+ fi
+
+ webapp_configfile "${MY_HOSTROOTDIR}"/conf/{viewvc,cvsgraph}.conf
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ python_version
+ python_mod_optimize "${ROOT}${MOD_PATH}"
+ elog "Now read INSTALL in /usr/share/doc/${PF} to configure ${PN}"
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}
diff --git a/www-apps/viewvc/viewvc-1.0.4.ebuild b/www-apps/viewvc/viewvc-1.0.4.ebuild
index 5b4c43c36ad5..c44e76de795c 100644
--- a/www-apps/viewvc/viewvc-1.0.4.ebuild
+++ b/www-apps/viewvc/viewvc-1.0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.0.4.ebuild,v 1.9 2007/10/26 16:13:20 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.0.4.ebuild,v 1.10 2008/02/20 13:04:17 hollow Exp $
inherit python eutils
@@ -42,7 +42,7 @@ pkg_setup() {
}
src_unpack() {
- unpack "${A}" && cd "${S}"
+ unpack ${A} && cd "${S}"
python_version
local LIB_DIR="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"