summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-05-08 11:24:31 +0000
committerRoy Marples <uberlord@gentoo.org>2006-05-08 11:24:31 +0000
commit8449891fd425120401e5158d7a78c375a1154b96 (patch)
treef2df191c899a1bf47fe20e4466f7728d36084ac2 /www-apps
parentFix broken digests (diff)
downloadgentoo-2-8449891fd425120401e5158d7a78c375a1154b96.tar.gz
gentoo-2-8449891fd425120401e5158d7a78c375a1154b96.tar.bz2
gentoo-2-8449891fd425120401e5158d7a78c375a1154b96.zip
New upstream release.
(Portage version: 2.1_pre10-r4)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/websvn/ChangeLog10
-rw-r--r--www-apps/websvn/files/digest-websvn-2.0_rc13
-rw-r--r--www-apps/websvn/files/websvn-2.0_rc1-pathinfo.patch11
-rw-r--r--www-apps/websvn/websvn-2.0_rc1.ebuild54
4 files changed, 76 insertions, 2 deletions
diff --git a/www-apps/websvn/ChangeLog b/www-apps/websvn/ChangeLog
index 283263da03fb..7cbdd01ae6e8 100644
--- a/www-apps/websvn/ChangeLog
+++ b/www-apps/websvn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/websvn
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.10 2005/10/20 19:38:39 uberlord Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.11 2006/05/08 11:24:31 uberlord Exp $
+
+*websvn-2.0_rc1 (08 May 2006)
+
+ 08 May 2006; Roy Marples <uberlord@gentoo.org>
+ +files/websvn-2.0_rc1-pathinfo.patch, +websvn-2.0_rc1.ebuild:
+ New upstream release.
*websvn-1.70_beta1 (20 Oct 2005)
diff --git a/www-apps/websvn/files/digest-websvn-2.0_rc1 b/www-apps/websvn/files/digest-websvn-2.0_rc1
new file mode 100644
index 000000000000..7c16a47c009a
--- /dev/null
+++ b/www-apps/websvn/files/digest-websvn-2.0_rc1
@@ -0,0 +1,3 @@
+MD5 c7007e333c83bafc38dc18fc9748547b WebSVN_2.0rc1.tar.gz 115073
+RMD160 740439dddeb4d9b00a82f1fafce217d08b6ef051 WebSVN_2.0rc1.tar.gz 115073
+SHA256 9cc30925274203b9a254c96a5996cb9a461515ddeaefa9df37fc9c32dbff7918 WebSVN_2.0rc1.tar.gz 115073
diff --git a/www-apps/websvn/files/websvn-2.0_rc1-pathinfo.patch b/www-apps/websvn/files/websvn-2.0_rc1-pathinfo.patch
new file mode 100644
index 000000000000..9275ea79c10a
--- /dev/null
+++ b/www-apps/websvn/files/websvn-2.0_rc1-pathinfo.patch
@@ -0,0 +1,11 @@
+--- websvn/wsvn.php 2006-05-08 10:28:13.000000000 +0100
++++ websvn/wsvn.php 2006-05-08 12:12:45.000000000 +0100
+@@ -59,7 +59,7 @@
+ exit;
+ }
+
+- $path = @$_SERVER["PATH_INFO"];
++ $path = trim(empty($_SERVER['PATH_INFO']) ? $_SERVER['ORIG_PATH_INFO'] : $_SERVER['PATH_INFO']);
+
+ // Remove initial slash
+ $path = substr($path, 1);
diff --git a/www-apps/websvn/websvn-2.0_rc1.ebuild b/www-apps/websvn/websvn-2.0_rc1.ebuild
new file mode 100644
index 000000000000..0b449fc06d4b
--- /dev/null
+++ b/www-apps/websvn/websvn-2.0_rc1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-2.0_rc1.ebuild,v 1.1 2006/05/08 11:24:31 uberlord Exp $
+
+inherit eutils webapp
+
+MY_PV="${PV//_/}"
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://websvn.tigris.org/"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/31740/WebSVN_${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="virtual/php
+ dev-util/subversion
+ sys-apps/sed
+ enscript? ( app-text/enscript )"
+
+S="${WORKDIR}/WebSVN-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}"-pathinfo.patch
+}
+
+src_compile() {
+ mv "${S}"/include/distconfig.inc "${S}"/include/config.inc
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc docs="changes.txt templates.txt"
+
+ dodoc ${docs}
+ for doc in ${docs} install.txt ; do
+ rm -f "${doc}"
+ done
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+ webapp_configfile "${MY_HTDOCSDIR}"/include/config.inc
+
+ # This is the multiview config file
+ webapp_configfile "${MY_HTDOCSDIR}"/wsvn.php
+
+ # The cache directory needs to be writeable
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+
+ webapp_src_install
+}