summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-09-10 18:41:34 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-09-10 18:41:34 +0000
commit817922866dd1fe18b945ede5e1ae5c2a0929c517 (patch)
treef8d580d5908b18b82977658507f7565a0c50e233 /www-apps
parentversion bump, fixes bugs 480604, 483392 (diff)
downloadgentoo-2-817922866dd1fe18b945ede5e1ae5c2a0929c517.tar.gz
gentoo-2-817922866dd1fe18b945ede5e1ae5c2a0929c517.tar.bz2
gentoo-2-817922866dd1fe18b945ede5e1ae5c2a0929c517.zip
Remove vulnerable versions, bug #484492
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/moodle/ChangeLog6
-rw-r--r--www-apps/moodle/moodle-2.3.8.ebuild128
-rw-r--r--www-apps/moodle/moodle-2.4.5.ebuild128
-rw-r--r--www-apps/moodle/moodle-2.5.1.ebuild128
4 files changed, 5 insertions, 385 deletions
diff --git a/www-apps/moodle/ChangeLog b/www-apps/moodle/ChangeLog
index ce7d1325b122..cc720058f721 100644
--- a/www-apps/moodle/ChangeLog
+++ b/www-apps/moodle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/moodle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.47 2013/09/08 16:43:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.48 2013/09/10 18:41:34 blueness Exp $
+
+ 10 Sep 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.3.8.ebuild,
+ -moodle-2.4.5.ebuild, -moodle-2.5.1.ebuild:
+ Remove vulnerable versions, bug #484492
*moodle-2.3.9 (08 Sep 2013)
*moodle-2.5.2 (08 Sep 2013)
diff --git a/www-apps/moodle/moodle-2.3.8.ebuild b/www-apps/moodle/moodle-2.3.8.ebuild
deleted file mode 100644
index 25e2a9126126..000000000000
--- a/www-apps/moodle/moodle-2.3.8.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.3.8.ebuild,v 1.1 2013/07/07 17:38:17 blueness Exp $
-
-EAPI="4"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS_53="ctype,curl,iconv,json,session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS_53="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS_53="${PHP_REQUIRED_FLAGS_53},${PHP_OPTIONAL_FLAGS_53}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-REQUIRED_USE="|| ( ${DB_TYPES} )"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="
- =dev-lang/php-5.3*[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS_53}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
- #if [[ ${DB_COUNT} -eq 0 ]]; then
- # eerror
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror "No database selected in your USE flags,"
- # eerror "You must select at least one."
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror
- # die
- #fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- # Moodle expect postgres7, not postgres
- MYDB=${MYDB/postgres/postgres7}
-
- # Moodle expects mysql, not mysqli
- MYDB=${MYDB/mysqli/mysql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
-}
diff --git a/www-apps/moodle/moodle-2.4.5.ebuild b/www-apps/moodle/moodle-2.4.5.ebuild
deleted file mode 100644
index d9c58a9380c6..000000000000
--- a/www-apps/moodle/moodle-2.4.5.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.4.5.ebuild,v 1.1 2013/07/07 17:38:17 blueness Exp $
-
-EAPI="5"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS="ctype,curl,iconv,json,session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-REQUIRED_USE="|| ( ${DB_TYPES} )"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="
- =dev-lang/php-5.3*[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
- #if [[ ${DB_COUNT} -eq 0 ]]; then
- # eerror
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror "No database selected in your USE flags,"
- # eerror "You must select at least one."
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror
- # die
- #fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- # Moodle expect postgres7, not postgres
- MYDB=${MYDB/postgres/postgres7}
-
- # Moodle expects mysql, not mysqli
- MYDB=${MYDB/mysqli/mysql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
-}
diff --git a/www-apps/moodle/moodle-2.5.1.ebuild b/www-apps/moodle/moodle-2.5.1.ebuild
deleted file mode 100644
index da712b424738..000000000000
--- a/www-apps/moodle/moodle-2.5.1.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.5.1.ebuild,v 1.2 2013/07/28 23:56:01 blueness Exp $
-
-EAPI="5"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS="ctype,curl,iconv,json,session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-REQUIRED_USE="|| ( ${DB_TYPES} )"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="
- >=dev-lang/php-5.3.3[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
- #if [[ ${DB_COUNT} -eq 0 ]]; then
- # eerror
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror "No database selected in your USE flags,"
- # eerror "You must select at least one."
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror
- # die
- #fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- # Moodle expect postgres7, not postgres
- MYDB=${MYDB/postgres/postgres7}
-
- # Moodle expects mysql, not mysqli
- MYDB=${MYDB/mysqli/mysql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
-}