summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-06-20 23:40:42 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-06-20 23:40:42 +0000
commit7fd67c289f9136d0f1cba649b8228074d72c1328 (patch)
treee797a9669b11d1eee5a2fe83c15b97353e5be0ae /www-apps
parentadd new version due to #473858 (diff)
downloadgentoo-2-7fd67c289f9136d0f1cba649b8228074d72c1328.tar.gz
gentoo-2-7fd67c289f9136d0f1cba649b8228074d72c1328.tar.bz2
gentoo-2-7fd67c289f9136d0f1cba649b8228074d72c1328.zip
add new version due to #473858
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitit/ChangeLog9
-rw-r--r--www-apps/gitit/gitit-0.10.3.1.ebuild73
-rw-r--r--www-apps/gitit/metadata.xml43
3 files changed, 125 insertions, 0 deletions
diff --git a/www-apps/gitit/ChangeLog b/www-apps/gitit/ChangeLog
new file mode 100644
index 000000000000..d99203c5c1fd
--- /dev/null
+++ b/www-apps/gitit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for www-apps/gitit
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitit/ChangeLog,v 1.1 2013/06/20 23:40:42 qnikst Exp $
+
+*gitit-0.10.3.1 (20 Jun 2013)
+
+ 20 Jun 2013; Alexander Vershilov <qnikst@gentoo.org> +gitit-0.10.3.1.ebuild,
+ +metadata.xml:
+ add new version due to #473858
diff --git a/www-apps/gitit/gitit-0.10.3.1.ebuild b/www-apps/gitit/gitit-0.10.3.1.ebuild
new file mode 100644
index 000000000000..4d1d54415fd1
--- /dev/null
+++ b/www-apps/gitit/gitit-0.10.3.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitit/gitit-0.10.3.1.ebuild,v 1.1 2013/06/20 23:40:42 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Wiki using happstack, git or darcs, and pandoc."
+HOMEPAGE="http://gitit.net"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins"
+
+RDEPEND=">=app-text/pandoc-1.10.0.5:=[profile?]
+ <app-text/pandoc-1.12:=[profile?]
+ >=dev-haskell/base64-bytestring-0.1:=[profile?]
+ <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-html-0.4:=[profile?]
+ <dev-haskell/blaze-html-0.7:=[profile?]
+ dev-haskell/cgi:=[profile?]
+ >=dev-haskell/configfile-1:=[profile?]
+ <dev-haskell/configfile-1.2:=[profile?]
+ >=dev-haskell/feed-0.3.6:=[profile?]
+ <dev-haskell/feed-0.4:=[profile?]
+ =dev-haskell/filestore-0.6*:=[profile?]
+ >=dev-haskell/happstack-server-7.0:=[profile?]
+ <dev-haskell/happstack-server-7.2:=[profile?]
+ >=dev-haskell/highlighting-kate-0.5.0.1:=[profile?]
+ <dev-haskell/highlighting-kate-0.6:=[profile?]
+ >=dev-haskell/hslogger-1:=[profile?]
+ <dev-haskell/hslogger-1.3:=[profile?]
+ >=dev-haskell/hstringtemplate-0.6:=[profile?]
+ <dev-haskell/hstringtemplate-0.8:=[profile?]
+ >=dev-haskell/http-4000.0:=[profile?]
+ <dev-haskell/http-4000.3:=[profile?]
+ >=dev-haskell/json-0.4:=[profile?]
+ <dev-haskell/json-0.8:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/network-2.1.0.0:=[profile?]
+ <dev-haskell/network-2.5:=[profile?]
+ =dev-haskell/pandoc-types-1.10*:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/recaptcha-0.1:=[profile?]
+ dev-haskell/safe:=[profile?]
+ >dev-haskell/sha-1:=[profile?]
+ <dev-haskell/sha-1.7:=[profile?]
+ dev-haskell/syb:=[profile?]
+ =dev-haskell/tagsoup-0.12*:=[profile?]
+ dev-haskell/text:=[profile?]
+ =dev-haskell/url-2.1*:=[profile?]
+ =dev-haskell/utf8-string-0.3*:=[profile?]
+ dev-haskell/xhtml:=[profile?]
+ >=dev-haskell/xml-1.3.5:=[profile?]
+ =dev-haskell/xss-sanitize-0.3*:=[profile?]
+ =dev-haskell/zlib-0.5*:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ plugins? ( dev-haskell/ghc-paths:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag plugins plugins)
+}
diff --git a/www-apps/gitit/metadata.xml b/www-apps/gitit/metadata.xml
new file mode 100644
index 000000000000..dea82ac45d89
--- /dev/null
+++ b/www-apps/gitit/metadata.xml
@@ -0,0 +1,43 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Gitit is a wiki backed by a git, darcs, or mercurial
+ filestore. Pages and uploaded files can be modified either
+ directly via the VCS&#39;s command-line tools or through
+ the wiki&#39;s web interface. Pandoc is used for markup
+ processing, so pages may be written in
+ (extended) markdown, reStructuredText, LaTeX, HTML,
+ or literate Haskell, and exported in ten different
+ formats, including LaTeX, ConTeXt, DocBook, RTF,
+ OpenOffice ODT, and MediaWiki markup.
+
+ Notable features include
+
+ * plugins: dynamically loaded page
+ transformations written in Haskell (see
+ &quot;Network.Gitit.Interface&quot;)
+
+ * conversion of TeX math to MathML for display in
+ web browsers
+
+ * syntax highlighting of source code
+ files and code snippets
+
+ * Atom feeds (site-wide and per-page)
+
+ * a library, &quot;Network.Gitit&quot;, that makes it simple
+ to include a gitit wiki in any happstack application
+
+ You can see a running demo at &lt;http://gitit.net&gt;.
+
+ For usage information: @gitit --help@
+ </longdescription>
+ <use>
+ <flag name="plugins">enables optional plugin runtime loader</flag>
+ </use>
+</pkgmetadata>