summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-09 19:04:10 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-09 19:04:10 +0000
commit7ef56e7a7b0109c86df077e2db00dc97996d4c89 (patch)
treef125cc824877a043cf20f37ba7dfa5f9434e5dd9 /www-apps
parentFix bug #382143 - Build failure for gpg due to wrong mutt interface call (diff)
downloadgentoo-2-7ef56e7a7b0109c86df077e2db00dc97996d4c89.tar.gz
gentoo-2-7ef56e7a7b0109c86df077e2db00dc97996d4c89.tar.bz2
gentoo-2-7ef56e7a7b0109c86df077e2db00dc97996d4c89.zip
Version bump (bug #301194 by Tom Hendrikx).
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/dspam-web/ChangeLog9
-rw-r--r--www-apps/dspam-web/dspam-web-3.10.1.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/www-apps/dspam-web/ChangeLog b/www-apps/dspam-web/ChangeLog
index 2d38d2f187ab..43183c7610f9 100644
--- a/www-apps/dspam-web/ChangeLog
+++ b/www-apps/dspam-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/dspam-web
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.41 2009/03/07 20:49:50 betelgeuse Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.42 2011/09/09 19:04:10 radhermit Exp $
+
+*dspam-web-3.10.1 (09 Sep 2011)
+
+ 09 Sep 2011; Tim Harder <radhermit@gentoo.org> +dspam-web-3.10.1.ebuild:
+ Version bump (bug #301194 by Tom Hendrikx).
07 Mar 2009; Petteri Räty <betelgeuse@gentoo.org>
dspam-web-3.8.0-r1.ebuild:
diff --git a/www-apps/dspam-web/dspam-web-3.10.1.ebuild b/www-apps/dspam-web/dspam-web-3.10.1.ebuild
new file mode 100644
index 000000000000..559c5343726e
--- /dev/null
+++ b/www-apps/dspam-web/dspam-web-3.10.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.10.1.ebuild,v 1.1 2011/09/09 19:04:10 radhermit Exp $
+
+EAPI="4"
+
+inherit webapp
+
+DESCRIPTION="Web based administration and user controls for dspam"
+HOMEPAGE="http://dspam.nuclearelephant.com/"
+SRC_URI="http://dspam.nuclearelephant.com/sources/dspam-${PV}.tar.gz"
+
+LICENSE="AGPL-3"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=mail-filter/dspam-${PV}[-user-homedirs]
+ dev-perl/GD[png]
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+
+need_httpd_cgi
+
+# some FHS-like structure
+HOMEDIR="/var/spool/dspam"
+CONFDIR="/etc/mail/dspam"
+
+S="${WORKDIR}/dspam-${PV}"
+
+src_configure() {
+ econf \
+ --with-dspam-home=${HOMEDIR} \
+ --sysconfdir=${CONFDIR}
+}
+
+src_compile() {
+ cd webui
+ default
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd webui
+ insinto "${MY_HTDOCSDIR}"
+ insopts -m644
+ doins htdocs/*.{css,gif}
+ insinto "${MY_CGIBINDIR}/templates"
+ doins cgi-bin/templates/*.html
+ insinto "${MY_CGIBINDIR}"
+ doins cgi-bin/{admins,configure.pl,default.prefs,rgb.txt,*.cgi}
+
+ webapp_configfile "${MY_CGIBINDIR}"/{admins,configure.pl,default.prefs,rgb.txt}
+
+ webapp_hook_script "${FILESDIR}/setperms"
+ webapp_postinst_txt en "${FILESDIR}/postinst-en.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "If you're using apache dspam-web's config requires the scripts in the cgi-bin"
+ ewarn "to be run as dspam:dspam. You will have to put a global SuexecUserGroup"
+ ewarn "declaration in the main server config which will force everything in cgi-bin"
+ ewarn "to run as dspam:dspam."
+ ewarn "You should use a dedicated virtual host for this application or at least"
+ ewarn "one that don't have any other cgi scripts."
+ ewarn
+ webapp_pkg_postinst
+}