summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-12 21:44:22 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-12 21:44:22 +0000
commit729d7024da7a19ecae2b5de730f14f8e826ea9a8 (patch)
tree6b527f3e46a86a621763529983f69480bf59e47d /www-apps
parentMinor cleanup: call python-single-r1_pkg_setup only if USE=test is used. Add ... (diff)
downloadgentoo-2-729d7024da7a19ecae2b5de730f14f8e826ea9a8.tar.gz
gentoo-2-729d7024da7a19ecae2b5de730f14f8e826ea9a8.tar.bz2
gentoo-2-729d7024da7a19ecae2b5de730f14f8e826ea9a8.zip
Security bump wrt bug 325575.
(Portage version: 2.2.3/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/lxr/ChangeLog12
-rw-r--r--www-apps/lxr/files/initdb-mysql.patch13
-rw-r--r--www-apps/lxr/files/lxr-0.9.8-initdb-mysql.patch13
-rw-r--r--www-apps/lxr/lxr-0.9.8.ebuild (renamed from www-apps/lxr/lxr-0.9.5.ebuild)10
4 files changed, 27 insertions, 21 deletions
diff --git a/www-apps/lxr/ChangeLog b/www-apps/lxr/ChangeLog
index a008a30d2f40..e180a1efe9db 100644
--- a/www-apps/lxr/ChangeLog
+++ b/www-apps/lxr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/lxr
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/ChangeLog,v 1.20 2012/09/18 04:17:13 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/ChangeLog,v 1.21 2013/09/12 21:44:22 creffett Exp $
+
+*lxr-0.9.8 (12 Sep 2013)
+
+ 12 Sep 2013; Chris Reffett <creffett@gentoo.org>
+ +files/lxr-0.9.8-initdb-mysql.patch, +lxr-0.9.8.ebuild,
+ -files/initdb-mysql.patch, -lxr-0.9.5.ebuild:
+ Security bump wrt bug 325575.
18 Sep 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove redundant maintainer from metadata.
@@ -102,4 +109,3 @@
23 Apr 2004; Stuart Herbert <stuart@gentoo.org> lxr-0.3.1.ebuild,
metadata.xml:
Initial import; thanks to Josh Glover <gentoo@jmglov.net>; see bug #48459
-
diff --git a/www-apps/lxr/files/initdb-mysql.patch b/www-apps/lxr/files/initdb-mysql.patch
deleted file mode 100644
index 8c35593017b8..000000000000
--- a/www-apps/lxr/files/initdb-mysql.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- initdb-mysql 2004-07-20 11:31:24.000000000 -0400
-+++ initdb-mysql.patched 2006-01-26 15:41:43.000000000 -0500
-@@ -34,8 +34,8 @@ create table lxr_indexes (
-
- create table lxr_releases
- (fileid int not null references lxr_files,
-- release char(255) binary not null,
-- primary key (fileid,release)
-+ `release` char(255) binary not null,
-+ primary key (fileid,`release`)
- );
-
- create table lxr_useage
diff --git a/www-apps/lxr/files/lxr-0.9.8-initdb-mysql.patch b/www-apps/lxr/files/lxr-0.9.8-initdb-mysql.patch
new file mode 100644
index 000000000000..f28604683781
--- /dev/null
+++ b/www-apps/lxr/files/lxr-0.9.8-initdb-mysql.patch
@@ -0,0 +1,13 @@
+--- initdb-mysql 2004-07-20 11:31:24.000000000 -0400
++++ initdb-mysql.patched 2006-01-26 15:41:43.000000000 -0500
+@@ -34,8 +34,8 @@ create table lxr_indexes (
+
+ create table lxr_releases
+ (fileid int not null references lxr_files,
+- releaseid char(255) binary not null,
+- primary key (fileid,releaseid)
++ `releaseid` char(255) binary not null,
++ primary key (fileid,`releaseid`)
+ );
+
+ create table lxr_usage
diff --git a/www-apps/lxr/lxr-0.9.5.ebuild b/www-apps/lxr/lxr-0.9.8.ebuild
index 4c6ea2021411..aaff4f9d2a73 100644
--- a/www-apps/lxr/lxr-0.9.5.ebuild
+++ b/www-apps/lxr/lxr-0.9.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/lxr-0.9.5.ebuild,v 1.7 2010/03/05 07:37:15 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/lxr-0.9.8.ebuild,v 1.1 2013/09/12 21:44:22 creffett Exp $
inherit perl-module webapp multilib eutils depend.apache
@@ -32,7 +32,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/initdb-mysql.patch
+ epatch "${FILESDIR}/${PN}-0.9.8-initdb-mysql.patch"
sed -i \
-e 's|/usr/local/bin/swish-e|/usr/bin/swish-e|' \
@@ -42,7 +42,7 @@ src_unpack() {
templates/lxr.conf
sed -i \
-e 's|Apache::Registry|ModPerl::PerlRun|' \
- .htaccess
+ .htaccess-apache1
sed -i \
-e 's|require Local;|require LXR::Local;|' \
-e 's|use Local;|use LXR::Local;|' \
@@ -69,7 +69,7 @@ src_install() {
insinto "${MY_HTDOCSDIR}"
doins .htaccess* templates/* || die
- webapp_configfile "${MY_HTDOCSDIR}"/lxr.conf "${MY_HTDOCSDIR}"/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/lxr.conf "${MY_HTDOCSDIR}"/.htaccess-apache1
webapp_sqlscript mysql initdb-mysql
webapp_sqlscript postgresql initdb-postgres
webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt