summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-09-07 07:26:44 +0000
committerPeter Volkov <pva@gentoo.org>2011-09-07 07:26:44 +0000
commit70506f6298d200fff507ac87c00237b9b8fde21e (patch)
treeb4e02510581118a081b5eb288533b74a65698d52 /www-apps
parentversion bump (diff)
downloadgentoo-2-70506f6298d200fff507ac87c00237b9b8fde21e.tar.gz
gentoo-2-70506f6298d200fff507ac87c00237b9b8fde21e.tar.bz2
gentoo-2-70506f6298d200fff507ac87c00237b9b8fde21e.zip
Version bump, fixes security issues reported in bug #381785 by Tim Sammut. Thank David Hicks for upstream updates on this issue.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog8
-rw-r--r--www-apps/mantisbt/mantisbt-1.2.8.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index ad01e6163770..c572e1518c4b 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.111 2011/09/04 07:31:57 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.112 2011/09/07 07:26:44 pva Exp $
+
+*mantisbt-1.2.8 (07 Sep 2011)
+
+ 07 Sep 2011; Peter Volkov <pva@gentoo.org> +mantisbt-1.2.8.ebuild:
+ Version bump, fixes security issues reported in bug #381785 by Tim Sammut.
+ Thank David Hicks for upstream updates on this issue.
04 Sep 2011; Peter Volkov <pva@gentoo.org> -mantisbt-1.2.4.ebuild,
-mantisbt-1.2.5.ebuild, -mantisbt-1.2.6.ebuild, -mantisbt-1.2.7.ebuild,
diff --git a/www-apps/mantisbt/mantisbt-1.2.8.ebuild b/www-apps/mantisbt/mantisbt-1.2.8.ebuild
new file mode 100644
index 000000000000..fb397927407b
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.2.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.2.8.ebuild,v 1.1 2011/09/07 07:26:44 pva Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ >=dev-php5/ezc-Base-1.8
+ >=dev-php5/ezc-Graph-1.5
+ >=dev-php/adodb-5.10"
+
+src_prepare() {
+ # Drop external libraries
+ rm -r "${S}/library/adodb/"
+ rm -r "${S}/library/ezc/"{Base,Graph}
+ sed -e 's:ezc/Base/src/base.php:ezc/Base/base.php:' \
+ -i "${S}"/plugins/MantisGraph/{core/graph_api.php,pages/summary_graph_cumulative_bydate2.php} \
+ || die
+ # Fix incorrect filename
+ sed -e 's:config_default_inc.php:config_defaults_inc.php:' \
+ -i "${S}/lang/strings_russian.txt" || die
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/{CREDITS,CUSTOMIZATION,RELEASE} doc/en/*
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+
+ webapp_configfile "${MY_HTDOCSDIR}/config_inc.php"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.0.0.txt"
+ webapp_src_install
+}