summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-06-18 00:27:17 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-06-18 00:27:17 +0000
commit5247be119ab5bef24660afea1155269f090d2478 (patch)
tree22cde23ac365192728f8bbe2d2f890fb65aafac7 /www-apps
parentbug 137128, new dep for rt (diff)
downloadgentoo-2-5247be119ab5bef24660afea1155269f090d2478.tar.gz
gentoo-2-5247be119ab5bef24660afea1155269f090d2478.tar.bz2
gentoo-2-5247be119ab5bef24660afea1155269f090d2478.zip
Version bump, security bug #136723.
(Portage version: 2.1)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/tikiwiki/ChangeLog7
-rw-r--r--www-apps/tikiwiki/files/digest-tikiwiki-1.9.43
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.4.ebuild83
3 files changed, 92 insertions, 1 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 6d838cc96588..b00e2045c161 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.29 2006/06/10 08:04:43 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.30 2006/06/18 00:27:16 rl03 Exp $
+
+*tikiwiki-1.9.4 (18 Jun 2006)
+
+ 18 Jun 2006; Renat Lumpau <rl03@gentoo.org> +tikiwiki-1.9.4.ebuild:
+ Version bump, security bug #136723.
10 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org>
-tikiwiki-1.9.1.1.ebuild, tikiwiki-1.9.3.2.ebuild:
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.4 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.4
new file mode 100644
index 000000000000..059d57338b9b
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.4
@@ -0,0 +1,3 @@
+MD5 8657096dba9738fb4e27df53e5999442 tikiwiki-1.9.4.tar.bz2 6562916
+RMD160 670580fba1268737724825e5da50a93a59d61cd1 tikiwiki-1.9.4.tar.bz2 6562916
+SHA256 6e361e3a6d738851fa2a0e72890f8cadc9d0a1518af95cbd49fbe8562014d754 tikiwiki-1.9.4.tar.bz2 6562916
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.4.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.4.ebuild
new file mode 100644
index 000000000000..85248ee65c9f
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.4.ebuild,v 1.1 2006/06/18 00:27:16 rl03 Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/php
+ mysql? ( >=dev-db/mysql-4 )
+ postgres? ( dev-db/postgresql )
+ graphviz? ( media-gfx/graphviz )
+"
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local DIR
+ local DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Ensure that directories exist, some don't.
+ # (part of setup.sh)
+ for DIR in ${DIRS}; do
+ mkdir -p ${DIR}
+ done
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ # Install the minimal doc (points to web page)
+ #
+ dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+ # The bulk goes into htdocs
+ # but don't copy INSTALL and README
+ cp -pPR [[:lower:]]* ${D}/${MY_HTDOCSDIR}
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+ #
+ webapp_serverowned ${MY_HTDOCSDIR}
+ for DIR in ${DIRS}; do
+ find ${DIR} | while read DIRENTRY; do
+ webapp_serverowned ${MY_HTDOCSDIR}/${DIRENTRY}
+ done
+ done
+ webapp_serverowned ${MY_HTDOCSDIR}/tiki-install.php
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}
+
+pkg_config() {
+ einfo "Type in your MySQL root password to create an empty tiki database:"
+ mysqladmin -u root -p create tikiwiki
+}
+
+pkg_postinst() {
+ einfo "To setup a MySQL database, run:"
+ einfo "\"emerge --config =${PF}\""
+ einfo "If you are using PostgreSQL, consult your documentation"
+ webapp_pkg_postinst
+}