summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-12-03 20:12:36 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-12-03 20:12:36 +0000
commit50dba33a22e579ee285b3699bc057c833ef1709e (patch)
tree871109de26638af343edc49e1e7db3a9be131bc4 /www-apps
parentx86 stable (diff)
downloadgentoo-2-50dba33a22e579ee285b3699bc057c833ef1709e.tar.gz
gentoo-2-50dba33a22e579ee285b3699bc057c833ef1709e.tar.bz2
gentoo-2-50dba33a22e579ee285b3699bc057c833ef1709e.zip
Added www-apps/websvn-2.1.0 in response to sec issue #243852.
(Portage version: 2.1.4.5)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/websvn/ChangeLog7
-rw-r--r--www-apps/websvn/websvn-2.1.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/www-apps/websvn/ChangeLog b/www-apps/websvn/ChangeLog
index 6a6dda57b0fb..b1720be46e08 100644
--- a/www-apps/websvn/ChangeLog
+++ b/www-apps/websvn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/websvn
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.24 2008/11/26 20:09:41 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.25 2008/12/03 20:12:36 wrobel Exp $
+
+*websvn-2.1.0 (03 Dec 2008)
+
+ 03 Dec 2008; Gunnar Wrobel <wrobel@gentoo.org> +websvn-2.1.0.ebuild:
+ Added www-apps/websvn-2.1.0 in response to sec issue #243852.
26 Nov 2008; Brent Baude <ranger@gentoo.org> websvn-2.0.ebuild:
Added ~ppc and ~ppc64
diff --git a/www-apps/websvn/websvn-2.1.0.ebuild b/www-apps/websvn/websvn-2.1.0.ebuild
new file mode 100644
index 000000000000..61b7de65533b
--- /dev/null
+++ b/www-apps/websvn/websvn-2.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-2.1.0.ebuild,v 1.1 2008/12/03 20:12:36 wrobel Exp $
+
+inherit depend.php eutils webapp
+
+MY_PV="${PV//_/}"
+
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://websvn.tigris.org/"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/44451/websvn-${MY_PV}.tar.gz"
+
+RESTRICT="mirror"
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-util/subversion
+ enscript? ( app-text/enscript )"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/websvn-${MY_PV}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use expat
+ else
+ require_php_with_use xml
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ mv include/{dist,}config.php
+
+ dodoc changes.txt doc/templates.txt
+ dohtml doc/*
+ rm -rf license.txt changes.txt doc/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/include/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/wsvn.php
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+
+ webapp_src_install
+}