summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-07 23:28:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-07 23:28:54 +0000
commit40de6d7a460ab19bfd21463ffdacfa7cf42a0265 (patch)
tree82ff91a9e525f86a84a902227175563a54451661 /www-apps
parentold (diff)
downloadgentoo-2-40de6d7a460ab19bfd21463ffdacfa7cf42a0265.tar.gz
gentoo-2-40de6d7a460ab19bfd21463ffdacfa7cf42a0265.tar.bz2
gentoo-2-40de6d7a460ab19bfd21463ffdacfa7cf42a0265.zip
Add patch from upstream to fix Free/Busy information #89227 by Jeffrey Crawford.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/horde/ChangeLog9
-rw-r--r--www-apps/horde/files/digest-horde-3.0.4-r11
-rw-r--r--www-apps/horde/files/horde-3.0.4-freebusy.patch16
-rw-r--r--www-apps/horde/horde-3.0.4-r1.ebuild39
4 files changed, 64 insertions, 1 deletions
diff --git a/www-apps/horde/ChangeLog b/www-apps/horde/ChangeLog
index 7d4c317dc6dc..2106eaf440ef 100644
--- a/www-apps/horde/ChangeLog
+++ b/www-apps/horde/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/horde
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/ChangeLog,v 1.10 2005/04/26 02:52:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/ChangeLog,v 1.11 2005/05/07 23:28:54 vapier Exp $
+
+*horde-3.0.4-r1 (07 May 2005)
+
+ 07 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/horde-3.0.4-freebusy.patch, +horde-3.0.4-r1.ebuild:
+ Add patch from upstream to fix Free/Busy information #89227 by Jeffrey
+ Crawford.
*horde-2.2.8 (26 Apr 2005)
diff --git a/www-apps/horde/files/digest-horde-3.0.4-r1 b/www-apps/horde/files/digest-horde-3.0.4-r1
new file mode 100644
index 000000000000..387de93d489d
--- /dev/null
+++ b/www-apps/horde/files/digest-horde-3.0.4-r1
@@ -0,0 +1 @@
+MD5 e2221d409ba1c8841ce4ecee981d7b61 horde-3.0.4.tar.gz 3378143
diff --git a/www-apps/horde/files/horde-3.0.4-freebusy.patch b/www-apps/horde/files/horde-3.0.4-freebusy.patch
new file mode 100644
index 000000000000..876e5a069fb2
--- /dev/null
+++ b/www-apps/horde/files/horde-3.0.4-freebusy.patch
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /horde/cvs/framework/iCalendar/iCalendar/vfreebusy.php,v
+retrieving revision 1.19
+retrieving revision 1.20
+diff -p --unified=3 -r1.19 -r1.20
+--- lib/Horde/iCalendar/vfreebusy.php 2005/04/08 14:08:47 1.19
++++ lib/Horde/iCalendar/vfreebusy.php 2005/04/08 16:52:25 1.20
+@@ -34,7 +34,7 @@ class Horde_iCalendar_vfreebusy extends
+ // Do something with all the busy periods.
+ foreach ($this->_attributes as $key => $attribute) {
+ if ($attribute['name'] == 'FREEBUSY') {
+- foreach ($attribute['value'] as $value) {
++ foreach ($attribute['values'] as $value) {
+ if (array_key_exists('duration', $attribute['value'])) {
+ $this->addBusyPeriod('BUSY', $value['start'], null, $value['duration']);
+ } else {
diff --git a/www-apps/horde/horde-3.0.4-r1.ebuild b/www-apps/horde/horde-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..b4d54433a543
--- /dev/null
+++ b/www-apps/horde/horde-3.0.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/horde-3.0.4-r1.ebuild,v 1.1 2005/05/07 23:28:54 vapier Exp $
+
+inherit horde
+
+DESCRIPTION="Horde Application Framework"
+HOMEPAGE="http://www.horde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="mysql"
+
+DEPEND=""
+RDEPEND=">=dev-php/mod_php-4.1.0
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21
+ >=www-apps/horde-pear-1.3
+ dev-php/PEAR-Log
+ dev-php/PEAR-Mail_Mime
+ mysql? ( dev-php/PEAR-DB )"
+
+EHORDE_PATCHES="${FILESDIR}/horde-3.0.4-freebusy.patch"
+
+pkg_setup() {
+ has_version '>=dev-php/mod_php-5' \
+ && HORDE_PHP_FEATURES="nls session xml2" \
+ || HORDE_PHP_FEATURES="nls"
+ horde_pkg_setup
+}
+
+pkg_postinst() {
+ horde_pkg_postinst
+ echo
+ einfo "Horde requires PHP to have:"
+ einfo " ==> 'short_open_tag enabled = On'"
+ einfo " ==> 'magic_quotes_runtime set = Off'"
+ einfo " ==> 'file_uploads enabled = On'"
+ einfo "Please edit /etc/php/apache2-php4/php.ini"
+}