summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-09-10 23:27:13 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-09-10 23:27:13 +0000
commit1d62607ea3bb0e0df9602394c82393d09df99333 (patch)
tree76bbf91040d0680cc44d58a06c5722d6829bb2f7 /www-apps
parentUpdate to 6.3.025. (Manifest recommit) (diff)
downloadgentoo-2-1d62607ea3bb0e0df9602394c82393d09df99333.tar.gz
gentoo-2-1d62607ea3bb0e0df9602394c82393d09df99333.tar.bz2
gentoo-2-1d62607ea3bb0e0df9602394c82393d09df99333.zip
webapp support
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mythweb/ChangeLog6
-rw-r--r--www-apps/mythweb/files/postinstall-en.txt4
-rw-r--r--www-apps/mythweb/mythweb-0.16.ebuild38
3 files changed, 27 insertions, 21 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 26d760f906a9..85f1b34620b8 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.3 2004/09/10 20:47:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.4 2004/09/10 23:27:13 aliz Exp $
+
+ 10 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mythweb-0.16.ebuild:
+ + Webapp-config support, closing #58382.
+ + Added checks and warning about php5.
*mythweb-0.16 (10 Sep 2004)
diff --git a/www-apps/mythweb/files/postinstall-en.txt b/www-apps/mythweb/files/postinstall-en.txt
new file mode 100644
index 000000000000..a0ab6b6526b7
--- /dev/null
+++ b/www-apps/mythweb/files/postinstall-en.txt
@@ -0,0 +1,4 @@
+You should modify ${MY_INSTALLDIR}/config/conf.php to fit your needs.
+
+If you are using php5 you may experience bugs, please report these to
+either Gentoo or MythTV bugzilla.
diff --git a/www-apps/mythweb/mythweb-0.16.ebuild b/www-apps/mythweb/mythweb-0.16.ebuild
index 2c6b6d32a626..ae8be9a40657 100644
--- a/www-apps/mythweb/mythweb-0.16.ebuild
+++ b/www-apps/mythweb/mythweb-0.16.ebuild
@@ -1,42 +1,40 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.16.ebuild,v 1.1 2004/09/10 20:47:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.16.ebuild,v 1.2 2004/09/10 23:27:13 aliz Exp $
-inherit webapp-apache
+inherit webapp
DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
HOMEPAGE="http://www.mythtv.org/"
SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
IUSE=""
LICENSE="GPL-2"
-SLOT="0"
KEYWORDS="~x86 ~amd64"
RDEPEND=">=dev-php/mod_php-4.2"
pkg_setup() {
- webapp-detect || NO_WEBSERVER=1
- einfo "Installing ${PN} into ${HTTPD_ROOT}"
+ if has_version \>=dev-php/mod_php-5 ; then
+ local modphp_use="$(</var/db/pkg/`best_version =dev-php/mod_php`/USE)"
+ if ! has session ${modphp_use} ; then
+ eerror "mod_php is missing session support. Please add"
+ eerror "'session' to your USE flags, and re-emerge mod_php and php."
+ die "mod_php needs session support"
+ fi
+ fi
+
+ webapp_pkg_setup
}
src_install() {
- webapp-mkdirs
+ webapp_src_preinst
- dodoc README TODO ; rm -f README TODO
+ dodoc README TODO
- dodir "${HTTPD_ROOT}"
- cp -R "${S}" "${D}${HTTPD_ROOT}/${PN}"
+ cp -R [[:lower:]]* ${D}/${MY_HTDOCSDIR}
- keepdir "${HTTPD_ROOT}/${PN}/"{php_sessions,image_cache}
- fowners "${HTTPD_USER}:${HTTPD_GROUP}" "${HTTPD_ROOT}/${PN}/"{php_sessions,image_cache}
+ webapp_configfile ${MY_HTDOCSDIR}/config/conf.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
- # protect configfiles
- echo "CONFIG_PROTECT=${HTTPD_ROOT}/${PN}/config" > ${T}/27mythweb
- insinto /etc/env.d ; doins ${T}/27mythweb
-}
-
-pkg_postinst() {
- einfo "You should modify ${HTTPD_ROOT}/${PN}/config/conf.php"
- einfo "to fit your needs."
- echo
+ webapp_src_install
}