summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-02-03 20:36:11 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-02-03 20:36:11 +0000
commit19eb937b438f5a7e4f6ea533ba324682279ce9af (patch)
tree207557c416ae8eeb2024463b08c8dead29192e04 /www-apps
parentVersion bump. Convert to distutils-r1. (diff)
downloadgentoo-2-19eb937b438f5a7e4f6ea533ba324682279ce9af.tar.gz
gentoo-2-19eb937b438f5a7e4f6ea533ba324682279ce9af.tar.bz2
gentoo-2-19eb937b438f5a7e4f6ea533ba324682279ce9af.zip
Fix test failure (upstream issue #11045).
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/trac/ChangeLog6
-rw-r--r--www-apps/trac/files/1.0.1-git-identity.patch36
-rw-r--r--www-apps/trac/trac-1.0.1.ebuild8
3 files changed, 47 insertions, 3 deletions
diff --git a/www-apps/trac/ChangeLog b/www-apps/trac/ChangeLog
index 90ea802b388d..97432e3aacd7 100644
--- a/www-apps/trac/ChangeLog
+++ b/www-apps/trac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/trac
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.135 2013/02/03 15:17:31 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.136 2013/02/03 20:36:11 djc Exp $
+
+ 03 Feb 2013; Dirkjan Ochtman <djc@gentoo.org> +files/1.0.1-git-identity.patch,
+ trac-1.0.1.ebuild:
+ Fix test failure (upstream issue #11045).
*trac-1.0.1 (03 Feb 2013)
diff --git a/www-apps/trac/files/1.0.1-git-identity.patch b/www-apps/trac/files/1.0.1-git-identity.patch
new file mode 100644
index 000000000000..703a2dbc67d5
--- /dev/null
+++ b/www-apps/trac/files/1.0.1-git-identity.patch
@@ -0,0 +1,36 @@
+http://trac.edgewall.org/changeset/11675
+
+Index: /branches/1.0-stable/tracopt/versioncontrol/git/tests/PyGIT.py
+===================================================================
+--- /branches/1.0-stable/tracopt/versioncontrol/git/tests/PyGIT.py (revision 11674)
++++ /branches/1.0-stable/tracopt/versioncontrol/git/tests/PyGIT.py (revision 11675)
+@@ -153,4 +153,6 @@
+ # create git repository and master branch
+ self._git('init', self.repos_path)
++ self._git('config', 'user.name', u"Joé")
++ self._git('config', 'user.email', "joe@example.com")
+ create_file(os.path.join(self.repos_path, '.gitignore'))
+ self._git('add', '.gitignore')
+@@ -166,5 +168,5 @@
+ cwd=self.repos_path)
+ proc.wait()
+- assert proc.returncode == 0
++ assert proc.returncode == 0, proc.stderr.read()
+ return proc
+
+@@ -181,5 +183,6 @@
+ create_file(os.path.join(self.repos_path, 'tickét.txt'))
+ self._git('add', 'tickét.txt')
+- self._git('commit', '-m', 'unicode-filename')
++ self._git('commit', '-m', 'unicode-filename',
++ '--date', 'Sun Feb 3 18:30 2013 +0100')
+ storage = self._storage()
+ filenames = sorted(fname for mode, type, sha, size, fname
+@@ -189,4 +192,7 @@
+ self.assertEquals(u'.gitignore', filenames[0])
+ self.assertEquals(u'tickét.txt', filenames[1])
++ # check commit author, for good measure
++ self.assertEquals(u'Joé <joe@example.com> 1359912600 +0100',
++ storage.read_commit(storage.head())[1]['author'][0])
+
+ def test_unicode_branches(self):
diff --git a/www-apps/trac/trac-1.0.1.ebuild b/www-apps/trac/trac-1.0.1.ebuild
index f6771ad3c359..912d8b65504e 100644
--- a/www-apps/trac/trac-1.0.1.ebuild
+++ b/www-apps/trac/trac-1.0.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/trac-1.0.1.ebuild,v 1.1 2013/02/03 15:17:31 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/trac-1.0.1.ebuild,v 1.2 2013/02/03 20:36:11 djc Exp $
EAPI="4"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit distutils user webapp
+inherit distutils eutils user webapp
MY_PV=${PV/_beta/b}
MY_P=Trac-${MY_PV}
@@ -53,6 +53,10 @@ pkg_setup() {
enewuser tracd -1 -1 -1 tracd
}
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-git-identity.patch"
+}
+
src_test() {
testing() {
PYTHONPATH=. "$(PYTHON)" trac/test.py