summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-11-16 12:37:10 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-11-16 12:37:10 +0000
commit0346151ca0b895e26bc6d02401fbe454f4ffd550 (patch)
treef8301c6a9c65c63eb3f6b63caf7f592ca6e5d94e /www-apps
parentDon't use --env switch in init script. (diff)
downloadgentoo-2-0346151ca0b895e26bc6d02401fbe454f4ffd550.tar.gz
gentoo-2-0346151ca0b895e26bc6d02401fbe454f4ffd550.tar.bz2
gentoo-2-0346151ca0b895e26bc6d02401fbe454f4ffd550.zip
New upstream version. Remove 1.4.3.5
(Portage version: 2.1.1-r1)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitweb/ChangeLog8
-rw-r--r--www-apps/gitweb/files/README.gentoo22
-rw-r--r--www-apps/gitweb/files/apache.htaccess3
-rw-r--r--www-apps/gitweb/files/digest-gitweb-1.4.43
-rw-r--r--www-apps/gitweb/gitweb-1.4.4.ebuild42
5 files changed, 63 insertions, 15 deletions
diff --git a/www-apps/gitweb/ChangeLog b/www-apps/gitweb/ChangeLog
index 1dc6b7e8e101..4050b5b4aa71 100644
--- a/www-apps/gitweb/ChangeLog
+++ b/www-apps/gitweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/gitweb
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/ChangeLog,v 1.15 2006/11/14 10:44:02 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/ChangeLog,v 1.16 2006/11/16 12:37:10 ferdy Exp $
+
+*gitweb-1.4.4 (16 Nov 2006)
+
+ 16 Nov 2006; Fernando J. Pereda <ferdy@gentoo.org> files/README.gentoo,
+ +files/apache.htaccess, -gitweb-1.4.3.5.ebuild, +gitweb-1.4.4.ebuild:
+ New upstream version. Remove 1.4.3.5
14 Nov 2006; Luca Barbato <lu_zero@gentoo.org> gitweb-1.4.3.5.ebuild:
Marked ~ppc and ~ppc64
diff --git a/www-apps/gitweb/files/README.gentoo b/www-apps/gitweb/files/README.gentoo
index 2c530203887d..890075c0bb41 100644
--- a/www-apps/gitweb/files/README.gentoo
+++ b/www-apps/gitweb/files/README.gentoo
@@ -12,29 +12,23 @@ public repositories in ``/var/git/``.
gitweb.cgi configuration
------------------------
-In the directory where gitweb is installed you have to create at least
-one file named ``index/index.aux``. This file defines the repositories
-gitweb should show. The example below defines a project located in
-``/var/git/test-project.git`` owned by ``Some Project Developer``.
-
- test-project.git Some+Project+Developer
-
-( Note the use of the plus sign (``+``) )
+All git repositories under ``/var/git/`` will be listed by gitweb.
Also you may want to create the file ``indextext.html``. This file will
be included in the header of the project listing page in gitweb.
+If they exist, ``header.html`` and ``footer.html`` files will be
+included as the header and footer of every gitweb page respectively.
+
Webserver configuration
-----------------------
-If you use apache you may want to add the following to a ``.htaccess``
-file in the directory where gitweb is installed.
-
- DirectoryIndex gitweb.cgi
-
-In lighttpd you may want to add ``gitweb.cgi`` to your indexfiles in
+Under lighttpd you may want to add ``gitweb.cgi`` to your indexfiles in
your ``lighttpd.conf`` as follows:
server.indexfiles += ("gitweb.cgi")
+We already provide a ``.htaccess`` file that should have everything
+needed to run gitweb.
+
.. vim: set tw=72 sw=4 et ft=glep : ..
diff --git a/www-apps/gitweb/files/apache.htaccess b/www-apps/gitweb/files/apache.htaccess
new file mode 100644
index 000000000000..52526a6f7afb
--- /dev/null
+++ b/www-apps/gitweb/files/apache.htaccess
@@ -0,0 +1,3 @@
+Options +ExecCGI -Indexes
+SetHandler cgi-script
+DirectoryIndex gitweb.cgi
diff --git a/www-apps/gitweb/files/digest-gitweb-1.4.4 b/www-apps/gitweb/files/digest-gitweb-1.4.4
new file mode 100644
index 000000000000..018f60cd4153
--- /dev/null
+++ b/www-apps/gitweb/files/digest-gitweb-1.4.4
@@ -0,0 +1,3 @@
+MD5 3bf19bd4c5746c5dc74f19cf167f4eb1 git-1.4.4.tar.bz2 886549
+RMD160 99352e32da5b79928d85e3176cc5abe5013ba474 git-1.4.4.tar.bz2 886549
+SHA256 ae878e93dbade210601b47fe56a7a36c84ae8a28457c5f415626f829e511fe17 git-1.4.4.tar.bz2 886549
diff --git a/www-apps/gitweb/gitweb-1.4.4.ebuild b/www-apps/gitweb/gitweb-1.4.4.ebuild
new file mode 100644
index 000000000000..f3252d4cc2a4
--- /dev/null
+++ b/www-apps/gitweb/gitweb-1.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/gitweb-1.4.4.ebuild,v 1.1 2006/11/16 12:37:10 ferdy Exp $
+
+inherit webapp
+
+GIT_VERSION="${PV}"
+
+DESCRIPTION="Web interface to GIT repositories"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+>=dev-util/git-${PV}"
+
+S="${WORKDIR}"/git-${GIT_VERSION}/gitweb
+
+src_compile() {
+ sed -i \
+ -e 's~^\(GITWEB_PROJECTROOT =\).*$~\1 /var/git~g' \
+ -e 's~^\(GITWEB_SITE_HEADER =\).*$~\1 header.html~g' \
+ -e 's~^\(GITWEB_SITE_FOOTER =\).*$~\1 footer.html~g' \
+ ../Makefile || die "failed to sed Makefile"
+ emake -C .. prefix=/usr gitweb/gitweb.cgi || die "emake failed"
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc README "${FILESDIR}"/README.gentoo
+ rm -f README
+
+ cp gitweb.{cgi,css} git-{favicon,logo}.png "${D}/${MY_HTDOCSDIR}"
+ cp "${FILESDIR}"/apache.htaccess "${D}/${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}