summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Kulbe <superlag@gentoo.org>2006-11-07 15:16:59 +0000
committerAaron Kulbe <superlag@gentoo.org>2006-11-07 15:16:59 +0000
commit539d2c3cd085e299e0f1f710acf925cc9ac8ce2f (patch)
treeae41c6b71bc9eec8f7c536c1090b7cf533601d88 /www-apps/wordpress
parentVersion bump. Thanks to Daniel Webert. Bug #143844 (diff)
downloadgentoo-2-539d2c3cd085e299e0f1f710acf925cc9ac8ce2f.tar.gz
gentoo-2-539d2c3cd085e299e0f1f710acf925cc9ac8ce2f.tar.bz2
gentoo-2-539d2c3cd085e299e0f1f710acf925cc9ac8ce2f.zip
Version bump. #153303
(Portage version: 2.1.2_rc1-r4)
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/ChangeLog7
-rw-r--r--www-apps/wordpress/files/digest-wordpress-2.0.53
-rw-r--r--www-apps/wordpress/wordpress-2.0.5.ebuild96
3 files changed, 105 insertions, 1 deletions
diff --git a/www-apps/wordpress/ChangeLog b/www-apps/wordpress/ChangeLog
index d8f3f4cc7e1e..ac45680d692c 100644
--- a/www-apps/wordpress/ChangeLog
+++ b/www-apps/wordpress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/wordpress
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.58 2006/08/02 17:38:01 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.59 2006/11/07 15:16:59 superlag Exp $
+
+*wordpress-2.0.5 (07 Nov 2006)
+
+ 07 Nov 2006; <aaron@gentoo.org> +wordpress-2.0.5.ebuild:
+ Version bump. Bug #153303
02 Aug 2006; Gustavo Zacarias <gustavoz@gentoo.org>
wordpress-2.0.4.ebuild:
diff --git a/www-apps/wordpress/files/digest-wordpress-2.0.5 b/www-apps/wordpress/files/digest-wordpress-2.0.5
new file mode 100644
index 000000000000..a64b1f4054c8
--- /dev/null
+++ b/www-apps/wordpress/files/digest-wordpress-2.0.5
@@ -0,0 +1,3 @@
+MD5 f16ffc47e22ba3540a1e4f32354fae0e wordpress-2.0.5.tar.gz 517574
+RMD160 dcf6d225c25d74a659717b682827d32ddbfdf939 wordpress-2.0.5.tar.gz 517574
+SHA256 e4bb49dabc68e10e973a23ea86dd5748594f226ddb9298bab823e7dcc3c859cf wordpress-2.0.5.tar.gz 517574
diff --git a/www-apps/wordpress/wordpress-2.0.5.ebuild b/www-apps/wordpress/wordpress-2.0.5.ebuild
new file mode 100644
index 000000000000..0a7fcb4d9fe5
--- /dev/null
+++ b/www-apps/wordpress/wordpress-2.0.5.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/wordpress-2.0.5.ebuild,v 1.1 2006/11/07 15:16:59 superlag Exp $
+
+inherit webapp eutils
+
+#Wordpress releases have a release name tagged on the end of the version on the tar.gz files
+#MY_EXT="mingus"
+
+DESCRIPTION="Wordpress php and mysql based CMS system."
+HOMEPAGE="http://wordpress.org/"
+#Latest version is only available in the format!
+#Download is renamed by HTTP Header as wordpress-<version number>.tar.gz
+SRC_URI=mirror://gentoo/${P}.tar.gz
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+RDEPEND="virtual/httpd-php
+ >=dev-db/mysql-3.23.23"
+
+DEPEND="${DEPEND} ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+# no patch needed anymore
+# epatch ${FILESDIR}/${PV}/login-patch.diff
+}
+
+src_install() {
+ local docs="license.txt readme.html"
+
+ webapp_src_preinst
+
+ einfo "Installing main files"
+ cp wp-config-sample.php wp-config.php
+ cp -r * ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ ewarn
+ ewarn Please make sure you have register_globals = off set in your /etc/apache2/php.ini file
+ ewarn If this is not an option for your web server and you NEED it set to on, then insert the following in your WordPress .htaccess file:
+ ewarn php_flag register_globals off
+ ewarn
+
+ ewarn
+ ewarn You will need to create a table for your WordPress database. This
+ ewarn assumes you have some knowledge of MySQL, and already have it
+ ewarn installed and configured. If not, please refer to
+ ewarn the Gentoo MySQL guide at the following URL:
+ ewarn http://www.gentoo.org/doc/en/mysql-howto.xml
+ ewarn Log in to MySQL, and create a new database called
+ ewarn "wordpress". From this point, you will need to edit
+ ewarn your wp-config.php file in $DocumentRoot/wordpress/
+ ewarn and point to your database. Once this is done, you can log in to
+ ewarn WordPress at http://localhost/wordpress
+ ewarn
+
+ ewarn
+ ewarn If you are upgrading from a previous version BACK UP your
+ ewarn database. Once you are done with that, browse to
+ ewarn http://localhost/wordpress/wp-admin/upgrade.php and follow
+ ewarn the instructions on the screen.
+ ewarn
+
+ # handle documentation files
+ #
+ # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+ # get installed per vhost!
+
+ dodoc ${docs}
+ for doc in ${docs} INSTALL; do
+ rm -f ${doc}
+ done
+
+ # Identify the configuration files that this app uses
+ # User can want to make changes to these!
+ webapp_serverowned ${MY_HTDOCSDIR}/index.php
+ #webapp_serverowned ${MY_HTDOCSDIR}/wp-layout.css
+ webapp_serverowned ${MY_HTDOCSDIR}/wp-admin/menu.php
+ webapp_serverowned ${MY_HTDOCSDIR}
+ webapp_configfile ${MY_HTDOCSDIR}/wp-config.php
+ # Identify any script files that need #! headers adding to run under
+ # a CGI script (such as PHP/CGI)
+ #
+ # for wordpress, we *assume* that all .php files need to have CGI/BIN
+ # support added
+
+ # post-install instructions
+ #webapp_postinst_txt en ${FILESDIR}/1.2/postinstall-en.txt
+
+ # now strut stuff
+ webapp_src_install
+
+}