summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-18 20:04:32 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-18 20:04:32 +0000
commit10751c48d6845d2c1c172ab54116ca0049e13f9c (patch)
tree52de325982be95809a2844b51077f23c565dc770 /www-apps/viewvc
parentRemove pyxml dependency (diff)
downloadgentoo-2-10751c48d6845d2c1c172ab54116ca0049e13f9c.tar.gz
gentoo-2-10751c48d6845d2c1c172ab54116ca0049e13f9c.tar.bz2
gentoo-2-10751c48d6845d2c1c172ab54116ca0049e13f9c.zip
Version bump.
(Portage version: 2.2.0_alpha34_p1/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/viewvc')
-rw-r--r--www-apps/viewvc/ChangeLog8
-rw-r--r--www-apps/viewvc/viewvc-1.1.11.ebuild115
2 files changed, 122 insertions, 1 deletions
diff --git a/www-apps/viewvc/ChangeLog b/www-apps/viewvc/ChangeLog
index ce5bda3d8292..00bf922c2021 100644
--- a/www-apps/viewvc/ChangeLog
+++ b/www-apps/viewvc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/viewvc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.72 2011/03/26 20:53:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.73 2011/05/18 20:04:32 arfrever Exp $
+
+*viewvc-1.1.11 (18 May 2011)
+
+ 18 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +viewvc-1.1.11.ebuild:
+ Version bump.
*viewvc-1.1.10 (26 Mar 2011)
diff --git a/www-apps/viewvc/viewvc-1.1.11.ebuild b/www-apps/viewvc/viewvc-1.1.11.ebuild
new file mode 100644
index 000000000000..2183dca65596
--- /dev/null
+++ b/www-apps/viewvc/viewvc-1.1.11.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.1.11.ebuild,v 1.1 2011/05/18 20:04:32 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit confutils eutils python webapp
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
+HOMEPAGE="http://viewvc.org/"
+DOWNLOAD_NUMBER="49022"
+SRC_URI="http://viewvc.tigris.org/files/documents/3330/${DOWNLOAD_NUMBER}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cvs cvsgraph mod_python mod_wsgi mysql pygments +subversion"
+
+DEPEND=""
+RDEPEND="
+ cvs? ( dev-vcs/rcs )
+ subversion? ( >=dev-vcs/subversion-1.3.1[python] )
+
+ mod_python? ( www-apache/mod_python )
+ mod_wsgi? ( www-apache/mod_wsgi )
+ !mod_python? ( !mod_wsgi? ( virtual/httpd-cgi ) )
+
+ cvsgraph? ( >=dev-vcs/cvsgraph-1.5.0 )
+ mysql? ( >=dev-python/mysql-python-0.9.0 )
+ pygments? ( dev-python/pygments )
+"
+
+pkg_setup() {
+ python_pkg_setup
+ webapp_pkg_setup
+
+ confutils_require_any cvs subversion
+}
+
+src_prepare() {
+ find bin/ -type f -print0 | xargs -0 sed -i \
+ -e "s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"$(python_get_sitedir -f)/${PN}\"|g" \
+ -e "s|\(^CONF_PATHNAME\)\(.*\$\)|\1 = \"../conf/viewvc.conf\"|g"
+
+ sed -i -e "s|\(self\.options\.template_dir\)\(.*\$\)|\1 = \"${MY_APPDIR}/templates\"|" \
+ lib/config.py
+
+ sed -i -e "s|^template_dir.*|#&|" conf/viewvc.conf.dist
+ mv conf/viewvc.conf{.dist,}
+ mv conf/cvsgraph.conf{.dist,}
+ mv conf/mimetypes.conf{.dist,}
+
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ webapp_src_preinst
+
+ newbin bin/standalone.py viewvc-standalone-server || die "newbin failed"
+
+ dodoc CHANGES COMMITTERS INSTALL README || die "dodoc failed"
+
+ installation() {
+ insinto $(python_get_sitedir)/${PN}
+ doins -r lib/*
+ }
+ python_execute_function installation
+
+ insinto "${MY_APPDIR}"
+ doins -r templates/ || die "doins failed"
+ doins -r templates-contrib/ || die "doins failed"
+
+ if use mysql; then
+ exeinto "${MY_HOSTROOTDIR}/bin"
+ doexe bin/{*dbadmin,make-database,loginfo-handler} || die "doexe failed"
+ fi
+
+ insinto "${MY_HOSTROOTDIR}/conf"
+ doins conf/{viewvc,cvsgraph,mimetypes}.conf
+
+ if use mod_python; then
+ insinto "${MY_HTDOCSDIR}"
+ doins bin/mod_python/viewvc.py || die "doins failed"
+ doins bin/mod_python/handler.py || die "doins failed"
+ doins bin/mod_python/.htaccess || die "doins failed"
+ if use mysql; then
+ doins bin/mod_python/query.py || die "doins failed"
+ fi
+ else
+ exeinto "${MY_CGIBINDIR}"
+ doexe bin/cgi/viewvc.cgi || die "doexe failed"
+ if use mysql; then
+ doexe bin/cgi/query.cgi || die "doexe failed"
+ fi
+ fi
+
+ webapp_configfile "${MY_HOSTROOTDIR}/conf/"{viewvc,cvsgraph}.conf
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ python_mod_optimize viewvc
+ webapp_pkg_postinst
+ elog "Now read INSTALL in /usr/share/doc/${PF} to configure ${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup viewvc
+}