summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-22 18:35:17 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-22 18:35:17 +0000
commitbf95765238f8fca36c879d8015157c95f62f2d8e (patch)
tree213101a775f35ff905196c937a62685cd5a7e1dd /www-apps/trac
parentFix last commit. (diff)
downloadgentoo-2-bf95765238f8fca36c879d8015157c95f62f2d8e.tar.gz
gentoo-2-bf95765238f8fca36c879d8015157c95f62f2d8e.tar.bz2
gentoo-2-bf95765238f8fca36c879d8015157c95f62f2d8e.zip
Convert to distutils-r1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'www-apps/trac')
-rw-r--r--www-apps/trac/ChangeLog9
-rw-r--r--www-apps/trac/trac-1.0.1-r1.ebuild115
2 files changed, 122 insertions, 2 deletions
diff --git a/www-apps/trac/ChangeLog b/www-apps/trac/ChangeLog
index 2c278dc64f0b..de4d8d1885ba 100644
--- a/www-apps/trac/ChangeLog
+++ b/www-apps/trac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/trac
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.139 2013/05/03 13:30:51 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.140 2014/04/22 18:35:17 mgorny Exp $
+
+*trac-1.0.1-r1 (22 Apr 2014)
+
+ 22 Apr 2014; Michał Górny <mgorny@gentoo.org> +trac-1.0.1-r1.ebuild:
+ Convert to distutils-r1.
03 May 2013; Agostino Sarubbo <ago@gentoo.org> trac-1.0.1.ebuild:
Stable for ppc, wrt bug #468372
diff --git a/www-apps/trac/trac-1.0.1-r1.ebuild b/www-apps/trac/trac-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..b9d5d54aeca2
--- /dev/null
+++ b/www-apps/trac/trac-1.0.1-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/trac-1.0.1-r1.ebuild,v 1.1 2014/04/22 18:35:17 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE='sqlite?'
+
+inherit distutils-r1 eutils user webapp
+
+MY_PV=${PV/_beta/b}
+MY_P=Trac-${MY_PV}
+
+DESCRIPTION="Trac is a minimalistic web-based project management, wiki and bug/issue tracking system"
+HOMEPAGE="http://trac.edgewall.com/ http://pypi.python.org/pypi/Trac"
+SRC_URI="http://ftp.edgewall.com/pub/trac/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="cgi fastcgi i18n mysql postgres +sqlite subversion test"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/genshi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ i18n? ( >=dev-python/Babel-0.9.5[${PYTHON_USEDEP}] )
+ cgi? ( virtual/httpd-cgi )
+ fastcgi? ( virtual/httpd-fastcgi )
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/psycopg-2[${PYTHON_USEDEP}] )
+ sqlite? (
+ >=dev-db/sqlite-3.3.4
+ )
+ subversion? ( dev-vcs/subversion[python,${PYTHON_USEDEP}] )
+ "
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ enewgroup tracd
+ enewuser tracd -1 -1 -1 tracd
+}
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PV}-git-identity.patch"
+ )
+
+# use test && python_copy_sources
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" trac/test.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_test_all() {
+ if use i18n; then
+ make check
+ fi
+}
+
+# the default src_compile just calls setup.py build
+# currently, this switches i18n catalog compilation based on presence of Babel
+
+src_install() {
+ webapp_src_preinst
+ distutils-r1_src_install
+
+ # project environments might go in here
+ keepdir /var/lib/trac
+
+ # Use this as the egg-cache for tracd
+ dodir /var/lib/trac/egg-cache
+ keepdir /var/lib/trac/egg-cache
+ fowners tracd:tracd /var/lib/trac/egg-cache
+
+ # documentation
+ dodoc -r contrib
+
+ # tracd init script
+ newconfd "${FILESDIR}"/tracd.confd tracd
+ newinitd "${FILESDIR}"/tracd.initd tracd
+
+ if use cgi; then
+ cp contrib/cgi-bin/trac.cgi "${ED}${MY_CGIBINDIR}" || die
+ fi
+ if use fastcgi; then
+ cp contrib/cgi-bin/trac.fcgi "${ED}${MY_CGIBINDIR}" || die
+ fi
+
+ for lang in en; do
+ webapp_postinst_txt ${lang} "${FILESDIR}"/postinst-${lang}.txt
+ webapp_postupgrade_txt ${lang} "${FILESDIR}"/postupgrade-${lang}.txt
+ done
+
+ webapp_src_install
+}