summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-12-08 17:33:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-12-08 17:33:25 +0000
commit3f57d490487e6eba50bc37ab0ef060d82422fdfc (patch)
tree65821b27211fa99fb2d33ad78ca0d8568249cf9e /www-apps/rutorrent
parentDelete dev-python/csv. (diff)
downloadgentoo-2-3f57d490487e6eba50bc37ab0ef060d82422fdfc.tar.gz
gentoo-2-3f57d490487e6eba50bc37ab0ef060d82422fdfc.tar.bz2
gentoo-2-3f57d490487e6eba50bc37ab0ef060d82422fdfc.zip
[www-apps/rutorrent] Initial import
(Portage version: 2.2.0_alpha7_p1/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/ChangeLog10
-rw-r--r--www-apps/rutorrent/metadata.xml9
-rw-r--r--www-apps/rutorrent/rutorrent-3.2.ebuild54
3 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/rutorrent/ChangeLog b/www-apps/rutorrent/ChangeLog
new file mode 100644
index 000000000000..37dfbcd378e6
--- /dev/null
+++ b/www-apps/rutorrent/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apps/rutorrent
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rutorrent/ChangeLog,v 1.1 2010/12/08 17:33:25 alexxy Exp $
+
+*rutorrent-3.2 (08 Dec 2010)
+
+ 08 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org> +rutorrent-3.2.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/www-apps/rutorrent/metadata.xml b/www-apps/rutorrent/metadata.xml
new file mode 100644
index 000000000000..d4665e9e1a54
--- /dev/null
+++ b/www-apps/rutorrent/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-apps/rutorrent/rutorrent-3.2.ebuild b/www-apps/rutorrent/rutorrent-3.2.ebuild
new file mode 100644
index 000000000000..fe33e3a0245d
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rutorrent/rutorrent-3.2.ebuild,v 1.1 2010/12/08 17:33:25 alexxy Exp $
+
+inherit webapp eutils depend.php
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="http://code.google.com/p/rutorrent/"
+SRC_URI="
+ http://rutorrent.googlecode.com/files/${P}.tar.gz
+ http://rutorrent.googlecode.com/files/plugins-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ local flags="expat"
+ else
+ local flags="xml"
+ fi
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ mv plugins rutorrent
+ cd rutorrent
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/share
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/settings
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/torrents
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/users
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}