summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-08-25 13:01:01 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-08-25 13:01:01 +0000
commitee775c3a0edaf9a9be16f77f8fbc478b199ac315 (patch)
tree8e3e5f1982672c697a379a52248d8b6716b430f7 /www-apps/rt
parentInitial commit, fixing bug #61322 (Manifest recommit) (diff)
downloadgentoo-2-ee775c3a0edaf9a9be16f77f8fbc478b199ac315.tar.gz
gentoo-2-ee775c3a0edaf9a9be16f77f8fbc478b199ac315.tar.bz2
gentoo-2-ee775c3a0edaf9a9be16f77f8fbc478b199ac315.zip
Initial ebuild. Closes #54764
Diffstat (limited to 'www-apps/rt')
-rw-r--r--www-apps/rt/ChangeLog12
-rw-r--r--www-apps/rt/Manifest6
-rw-r--r--www-apps/rt/files/digest-rt-3.2.11
-rw-r--r--www-apps/rt/files/postinstall-en.txt39
-rw-r--r--www-apps/rt/files/reconfig26
-rw-r--r--www-apps/rt/metadata.xml8
-rw-r--r--www-apps/rt/rt-3.2.1.ebuild143
7 files changed, 235 insertions, 0 deletions
diff --git a/www-apps/rt/ChangeLog b/www-apps/rt/ChangeLog
new file mode 100644
index 000000000000..e4da416f1d8b
--- /dev/null
+++ b/www-apps/rt/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for www-apps/rt
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.1 2004/08/25 13:01:01 rl03 Exp $
+
+*rt-3.2.1 (25 Aug 2004)
+
+ 25 Aug 2004; Renat Lumpau <rl03@gentoo.org> +metadata.xml,
+ +files/postinstall-en.txt, +files/reconfig, +rt-3.2.1.ebuild:
+ Initial ebuild (bug #54764). Many thanks to Josiah Ritchie
+ <jritchie@bible.edu>, steveb, mphilips, and others who did a lot of the
+ groundwork and wrote ebuilds.
+
diff --git a/www-apps/rt/Manifest b/www-apps/rt/Manifest
new file mode 100644
index 000000000000..a36ab8c1567e
--- /dev/null
+++ b/www-apps/rt/Manifest
@@ -0,0 +1,6 @@
+MD5 d7ebfa86fdc6018ed994013a2123281a rt-3.2.1.ebuild 4100
+MD5 71d26c2d378bae4e6cc8488b05fb6b5a ChangeLog 430
+MD5 224c312cc23d02aa06c26a4da3cc1f90 metadata.xml 221
+MD5 6737ba4198d78323c15c8b23da1dd323 files/postinstall-en.txt 1559
+MD5 5f5c3f76ea4676e743612e38341780fe files/digest-rt-3.2.1 61
+MD5 7350a2201d6605b8e399a1fe3ce59652 files/reconfig 847
diff --git a/www-apps/rt/files/digest-rt-3.2.1 b/www-apps/rt/files/digest-rt-3.2.1
new file mode 100644
index 000000000000..0b9257c86db4
--- /dev/null
+++ b/www-apps/rt/files/digest-rt-3.2.1
@@ -0,0 +1 @@
+MD5 adf0c77827c8f84829bb44e28752a1d8 rt-3.2.1.tar.gz 1201592
diff --git a/www-apps/rt/files/postinstall-en.txt b/www-apps/rt/files/postinstall-en.txt
new file mode 100644
index 000000000000..c5c9ea4d099b
--- /dev/null
+++ b/www-apps/rt/files/postinstall-en.txt
@@ -0,0 +1,39 @@
+
+***********************************************************
+You now need to edit your local config files,
+which will be located in ${VHOST_ROOT}/rt-config/RT_Config.pm and RT_SiteConfig.pm
+
+BE SURE TO READ /usr/share/doc/${P}/README.gz , especially if
+you'd prefer to use an alias, or if you want to setup RT's e-mail gateway
+
+RT documentation can be found at http://www.bestpractical.com/rt/docs.html
+If you need more help, consider searching the mailing list (Google site:lists.fsck.com )
+
+***********************************************************
+1. If this is a new install, you now need to initialize RT's database.
+
+For MySQL:
+rt-setup-database --action init --dba root --prompt-for-dba-password
+For PostgreSQL:
+rt-setup-database --action init --dba postgres --prompt-for-dba-password
+
+For this to work, PostgreSQL needs to listen on TCP 5432:
+In your postgresql.conf, set tcpip_socket = true, port = 5432
+
+***********************************************************
+2. Read the README to configure your webserver for RT. For the impatient:
+put this in ${MY_INSTALLDIR}/.htaccess
+AddDefaultCharset UTF-8
+
+PerlModule Apache::DBI
+PerlRequire /usr/bin/webmux.pl
+
+SetHandler perl-script
+PerlHandler RT::Mason
+
+***********************************************************
+3. Restart your webserver (e.g., for Apache: /etc/init.d/apache restart )
+
+***********************************************************
+4. Note that the default login is 'root', and the password is 'password'. It is
+a Good Idea(TM) to change the defaults to something more secure.
diff --git a/www-apps/rt/files/reconfig b/www-apps/rt/files/reconfig
new file mode 100644
index 000000000000..cf56d1857ce8
--- /dev/null
+++ b/www-apps/rt/files/reconfig
@@ -0,0 +1,26 @@
+#!/bin/bash
+if [ $1 = "start" -o $1 = "install" ]; then
+ # fix location
+ sed -i "s|${MY_HOSTROOTDIR}|${VHOST_ROOT}|g" /usr/bin/standalone_httpd /usr/bin/rt-crontool /usr/bin/webmux.pl /usr/lib/RT.pm
+ sed -i "s|${MY_HOSTROOTDIR}|\/usr|" /usr/bin/mason_handler.scgi
+ sed -i "s|${MY_HTDOCSDIR}|${MY_INSTALLDIR}|" /usr/lib/RT.pm /usr/bin/rt-mailgate
+
+ # fix permissions
+ chown -R ${VHOST_SERVER_GID}:${VHOST_SERVER_UID} /var/rt
+
+ # check for upgrades
+ cd ${MY_HOSTROOTDIR}/rt-config/upgrade
+ for a in *; do
+ if test ${a} '>' ${PV}; then
+ echo "It looks like you need to upgrade your database."
+ echo "To do that, execute"
+ echo "cd ${MY_HOSTROOTDIR}/rt-config/upgrade"
+ echo "rt-setup-database --action schema --datadir ${a}"
+ echo "DO NOT DO THIS without reading /usr/share/doc/${P}/README.gz first"
+ break
+ fi
+ done
+
+else
+ echo $1
+fi
diff --git a/www-apps/rt/metadata.xml b/www-apps/rt/metadata.xml
new file mode 100644
index 000000000000..43819e102566
--- /dev/null
+++ b/www-apps/rt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+<maintainer>
+ <email>rl03@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/www-apps/rt/rt-3.2.1.ebuild b/www-apps/rt/rt-3.2.1.ebuild
new file mode 100644
index 000000000000..004db1201351
--- /dev/null
+++ b/www-apps/rt/rt-3.2.1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.2.1.ebuild,v 1.1 2004/08/25 13:01:01 rl03 Exp $
+
+inherit webapp eutils
+
+IUSE="mysql postgres fastcgi apache2"
+
+DESCRIPTION="RT is an industrial-grade ticketing system"
+HOMEPAGE="http://www.bestpractical.com/rt/"
+SRC_URI="http://www.fsck.com/pub/${PN}/release/${P}.tar.gz
+ ftp://ftp.eu.uu.net/pub/unix/ticketing/${PN}/release/${P}.tar.gz
+ ftp://rhinst.ece.cmu.edu/${PN}/release/${P}.tar.gz"
+
+KEYWORDS="~x86"
+
+DEPEND="
+ >=dev-lang/perl-5.8.3
+ >=dev-perl/Params-Validate-0.02
+ dev-perl/Cache-Cache
+ >=dev-perl/Exception-Class-1.14
+ >=dev-perl/HTML-Mason-1.23
+ dev-perl/MLDBM
+ dev-perl/FreezeThaw
+ >=dev-perl/Apache-Session-1.53
+ dev-perl/XML-RSS
+ dev-perl/HTML-Tree
+ dev-perl/HTML-Format
+ dev-perl/libwww-perl
+ >=dev-perl/Apache-DBI-0.92
+ >=dev-perl/DBI-1.37
+ dev-perl/Test-Inline
+ >=dev-perl/class-returnvalue-0.40
+ >=dev-perl/dbix-searchbuilder-1.01
+ dev-perl/text-template
+ dev-perl/HTML-Parser
+ >=dev-perl/HTML-Scrubber-0.08
+ >=dev-perl/log-dispatch-2.0
+ >=dev-perl/locale-maketext-lexicon-0.32
+ dev-perl/locale-maketext-fuzzy
+ >=dev-perl/MIME-tools-5.411a-r2
+ >=dev-perl/MailTools-1.60
+ dev-perl/text-wrapper
+ dev-perl/Time-modules
+ dev-perl/TermReadKey
+ dev-perl/text-autoformat
+ >=dev-perl/Text-Quoted-1.3
+ >=dev-perl/Tree-Simple-1.04
+ dev-perl/Module-Versions-Report
+ dev-perl/regexp-common
+ dev-perl/WWW-Mechanize
+
+ dev-perl/Font-AFM
+ dev-perl/text-autoformat
+ dev-perl/text-reform
+"
+
+RDEPEND="
+ ${DEPEND}
+ virtual/mta
+ mysql? ( >=dev-db/mysql-4.0.13 >=dev-perl/DBD-mysql-2.0416 )
+ postgres? ( >=dev-db/postgresql-7.4.2-r1 dev-perl/DBD-Pg )
+ fastcgi? ( dev-perl/FCGI net-www/mod_fastcgi )
+ apache2? ( >=net-www/apache-2 dev-perl/FCGI net-www/mod_fastcgi )
+ !apache2? ( =net-www/apache-1* =dev-perl/libapreq-1* )
+"
+# apache2? ( >=net-www/apache-2 >=dev-perl/mod_perl-1.99.11 >=dev-perl/libapreq-2 ) : ( =net-www/apache-1* dev-perl/libapreq-1* )
+
+LICENSE="GPL-2"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use apache2; then
+ ewarn "mod_perl2 isn't ready for prime time, fastcgi will be used instead"
+ ewarn "If you really want mod_perl2, you can edit the ebuild and uncomment a few lines"
+ ewarn "but if your RT breaks, you get to keep the pieces."
+ ewarn
+ fi
+ ewarn
+ ewarn "If you are upgrading from an existing _RT2_ installation,"
+ ewarn "stop this ebuild (Ctrl-C now), download the upgrade tool,"
+ ewarn "http://bestpractical.com/pub/rt/devel/rt2-to-rt3.tar.gz"
+ ewarn "and follow the included instructions."
+ ewarn
+ enewgroup rt >/dev/null
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s|/opt/rt3/bin/rt-mailgate|/usr/bin/rt-mailgate|g" -i README
+}
+
+src_compile() {
+ # capture the list of files from configure to patch later on
+ files=`./configure --prefix=${D}/usr \
+ --with-web-user=apache \
+ --with-web-group=apache | grep creating | cut -d':' -f2 | cut -d' ' -f3`
+ # ./configure doesn't accept locations, so patch these files directly
+ sed -i "s|/usr/etc|${MY_HOSTROOTDIR}/rt-config|
+ s|/usr/man|/usr/share/man|
+ s|/usr/var|/var|
+ s|/var/mason_data|/var/rt/mason_data|
+ s|/var/session_data|/var/rt/session_data|
+ s|/var/log|/var/log/rt|
+ s|/usr/local/html|${MY_HTDOCSDIR}|
+ s|/usr/share/html|${MY_HTDOCSDIR}|
+ s|/usr/local|${MY_HOSTROOTDIR}/rt|
+ " ${files}
+
+ # check for missing deps and ask to report if something is broken
+ if `make testdeps | grep "MISSING"`; then
+ ewarn "Missing Perl dependency, please file a bug in the Gentoo Bugzilla with the information above"
+ ewarn "and assign it to rl03@gentoo.org"
+ die "Missing dependencies"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README Changelog
+ rm -f COPYING README Changelog
+
+ make install
+
+ # copy upgrade schemas
+ cd etc
+ cp -R upgrade ${D}/${MY_HOSTROOTDIR}/rt-config
+
+ # delete RT_SiteConfig.pm so we don't accidentally overwrite existing
+ # configuration
+ rm -f ${D}/${MY_HOSTROOTDIR}/rt-config/RT_SiteConfig.pm
+
+ cd ${D}
+ grep -Rl "${D}" * | xargs dosed
+ chmod +r ${D}/${MY_HOSTROOTDIR}/rt-config/RT*
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script ${FILESDIR}/reconfig
+ webapp_src_install
+}