summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-30 07:49:34 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-30 07:49:34 +0000
commitb72d7046d9e964ee8b6c820d753f33827cefe643 (patch)
treefef08453f3528cc615f7e0d2593dac35bc175fa3 /www-apps/roundup
parentVersion bump. (diff)
downloadgentoo-2-b72d7046d9e964ee8b6c820d753f33827cefe643.tar.gz
gentoo-2-b72d7046d9e964ee8b6c820d753f33827cefe643.tar.bz2
gentoo-2-b72d7046d9e964ee8b6c820d753f33827cefe643.zip
Version bump, update to distutils-r1.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-apps/roundup')
-rw-r--r--www-apps/roundup/ChangeLog9
-rw-r--r--www-apps/roundup/roundup-1.4.21.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/www-apps/roundup/ChangeLog b/www-apps/roundup/ChangeLog
index 4e6abcda684a..6e1b54dfa255 100644
--- a/www-apps/roundup/ChangeLog
+++ b/www-apps/roundup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/roundup
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.61 2012/09/04 08:27:35 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.62 2013/03/30 07:49:34 radhermit Exp $
+
+*roundup-1.4.21 (30 Mar 2013)
+
+ 30 Mar 2013; Tim Harder <radhermit@gentoo.org> +roundup-1.4.21.ebuild:
+ Version bump, update to distutils-r1.
*roundup-1.4.20 (04 Sep 2012)
diff --git a/www-apps/roundup/roundup-1.4.21.ebuild b/www-apps/roundup/roundup-1.4.21.ebuild
new file mode 100644
index 000000000000..960d8aa25321
--- /dev/null
+++ b/www-apps/roundup/roundup-1.4.21.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/roundup-1.4.21.ebuild,v 1.1 2013/03/30 07:49:34 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces."
+HOMEPAGE="http://roundup.sourceforge.net http://pypi.python.org/pypi/roundup"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=sys-libs/db-3.2.9"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+python_install_all() {
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+ dohtml -r doc/*
+}
+
+pkg_postinst() {
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.ini file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}