summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-12 21:17:31 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-12 21:17:31 +0000
commit3b234dab3ed085565ef2384512bd76d04c9fdd8f (patch)
tree3eaef44c5e1e9b876c5fad893d6a26c7ca222c5f /www-apps/roundup
parentDelete older ebuild. (diff)
downloadgentoo-2-3b234dab3ed085565ef2384512bd76d04c9fdd8f.tar.gz
gentoo-2-3b234dab3ed085565ef2384512bd76d04c9fdd8f.tar.bz2
gentoo-2-3b234dab3ed085565ef2384512bd76d04c9fdd8f.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/roundup')
-rw-r--r--www-apps/roundup/ChangeLog8
-rw-r--r--www-apps/roundup/roundup-1.4.15.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/www-apps/roundup/ChangeLog b/www-apps/roundup/ChangeLog
index 2de0bf9a4c5c..7bdd86179c32 100644
--- a/www-apps/roundup/ChangeLog
+++ b/www-apps/roundup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/roundup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.47 2010/07/04 08:41:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.48 2010/07/12 21:17:31 arfrever Exp $
+
+*roundup-1.4.15 (12 Jul 2010)
+
+ 12 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -roundup-1.4.11.ebuild, +roundup-1.4.15.ebuild:
+ Version bump.
04 Jul 2010; Markos Chandras <hwoarang@gentoo.org> roundup-1.4.14.ebuild:
Stable on amd64 wrt bug #326395
diff --git a/www-apps/roundup/roundup-1.4.15.ebuild b/www-apps/roundup/roundup-1.4.15.ebuild
new file mode 100644
index 000000000000..29db07945574
--- /dev/null
+++ b/www-apps/roundup/roundup-1.4.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/roundup-1.4.15.ebuild,v 1.1 2010/07/12 21:17:31 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces."
+HOMEPAGE="http://roundup.sourceforge.net http://pypi.python.org/pypi/roundup"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/db-3.2.9"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils_src_install
+
+ dodoc CHANGES.txt doc/*.txt
+ dohtml doc/*.html
+ dobin "${FILESDIR}/roundup" || die "dobin failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.ini file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}