summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-09-03 00:01:09 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-09-03 00:01:09 +0000
commitf99a12772450293ffc084ad441da055c06c0e6a5 (patch)
tree2ed05f52792ff01d02d0692eb2cf8b1857badfe8 /www-apps/phprojekt
parentStable on ia64. (diff)
downloadgentoo-2-f99a12772450293ffc084ad441da055c06c0e6a5.tar.gz
gentoo-2-f99a12772450293ffc084ad441da055c06c0e6a5.tar.bz2
gentoo-2-f99a12772450293ffc084ad441da055c06c0e6a5.zip
Version bump
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'www-apps/phprojekt')
-rw-r--r--www-apps/phprojekt/ChangeLog8
-rw-r--r--www-apps/phprojekt/files/digest-phprojekt-5.1.13
-rw-r--r--www-apps/phprojekt/phprojekt-5.1.1.ebuild40
3 files changed, 50 insertions, 1 deletions
diff --git a/www-apps/phprojekt/ChangeLog b/www-apps/phprojekt/ChangeLog
index 467eaf7adce7..a7e8e4609a5b 100644
--- a/www-apps/phprojekt/ChangeLog
+++ b/www-apps/phprojekt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/phprojekt
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/ChangeLog,v 1.19 2006/07/09 21:03:33 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/ChangeLog,v 1.20 2006/09/03 00:01:09 rl03 Exp $
+
+*phprojekt-5.1.1 (03 Sep 2006)
+
+ 03 Sep 2006; Renat Lumpau <rl03@gentoo.org> -phprojekt-5.0.1.ebuild,
+ +phprojekt-5.1.1.ebuild:
+ Version bump
09 Jul 2006; Renat Lumpau <rl03@gentoo.org> phprojekt-4.2.3.ebuild,
phprojekt-5.0.1.ebuild:
diff --git a/www-apps/phprojekt/files/digest-phprojekt-5.1.1 b/www-apps/phprojekt/files/digest-phprojekt-5.1.1
new file mode 100644
index 000000000000..ae5965440258
--- /dev/null
+++ b/www-apps/phprojekt/files/digest-phprojekt-5.1.1
@@ -0,0 +1,3 @@
+MD5 96969381357344ac5f55ba78c38fef9c phprojekt-5.1.1.zip 2102860
+RMD160 586500e21ceafa558fda603520d48df4c35afbad phprojekt-5.1.1.zip 2102860
+SHA256 faf276fa140f1872098acfec6edc2e967262def119eaf0078209ab5e790eb068 phprojekt-5.1.1.zip 2102860
diff --git a/www-apps/phprojekt/phprojekt-5.1.1.ebuild b/www-apps/phprojekt/phprojekt-5.1.1.ebuild
new file mode 100644
index 000000000000..79bef445015e
--- /dev/null
+++ b/www-apps/phprojekt/phprojekt-5.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/phprojekt-5.1.1.ebuild,v 1.1 2006/09/03 00:01:09 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="Project management and coordination system"
+HOMEPAGE="http://www.phprojekt.com/"
+#SRC_URI="http://phprojekt.com/releases/${PN}/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+IUSE="postgres mysql"
+
+S=${WORKDIR}/${PN}${PV}
+
+DEPEND="app-arch/unzip"
+RDEPEND="net-www/apache
+ postgres? ( dev-db/postgresql )
+ mysql? ( dev-db/mysql )
+ virtual/php"
+
+pkg_setup () {
+ webapp_pkg_setup
+ elog "Please make sure that your PHP is compiled with support for IMAP and your database of choice"
+}
+
+src_install() {
+ webapp_src_preinst
+ local file
+
+ cp -R . ${D}/${MY_HTDOCSDIR}
+ for file in attach chat; do
+ webapp_serverowned ${MY_HTDOCSDIR}/${file}
+ done
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}