summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-06-25 19:03:47 +0000
committerMatti Bickel <mabi@gentoo.org>2012-06-25 19:03:47 +0000
commit6b2fa0e0d90803e9bd3fbc29da35eb585f5d181e (patch)
tree0d53094a5af9180b2fcf8869cb3cb5044cf88af0 /www-apps/phprojekt
parentsorta fixes for bug #423265 (diff)
downloadgentoo-2-6b2fa0e0d90803e9bd3fbc29da35eb585f5d181e.tar.gz
gentoo-2-6b2fa0e0d90803e9bd3fbc29da35eb585f5d181e.tar.bz2
gentoo-2-6b2fa0e0d90803e9bd3fbc29da35eb585f5d181e.zip
version bump. note that version 6 is a rewrite, but can import your version 5 configuration/data at the end of setup.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/phprojekt')
-rw-r--r--www-apps/phprojekt/ChangeLog11
-rw-r--r--www-apps/phprojekt/files/postinstall-6-en.txt9
-rw-r--r--www-apps/phprojekt/phprojekt-6.1.2.ebuild41
3 files changed, 59 insertions, 2 deletions
diff --git a/www-apps/phprojekt/ChangeLog b/www-apps/phprojekt/ChangeLog
index 5aa81d946dd2..cf87c06037f0 100644
--- a/www-apps/phprojekt/ChangeLog
+++ b/www-apps/phprojekt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/phprojekt
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/ChangeLog,v 1.28 2007/06/03 19:39:49 rl03 Exp $
+# Copyright 2002-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/ChangeLog,v 1.29 2012/06/25 19:03:47 mabi Exp $
+
+*phprojekt-6.1.2 (25 Jun 2012)
+
+ 25 Jun 2012; Matti Bickel <mabi@gentoo.org> +files/postinstall-6-en.txt,
+ +phprojekt-6.1.2.ebuild:
+ version bump. note that version 6 is a rewrite, but can import your version 5
+ configuration/data at the end of setup.
03 Jun 2007; Renat Lumpau <rl03@gentoo.org>
-files/phprojekt-4.2.3-fix-chat-vuln.diff, -phprojekt-4.2.3.ebuild:
diff --git a/www-apps/phprojekt/files/postinstall-6-en.txt b/www-apps/phprojekt/files/postinstall-6-en.txt
new file mode 100644
index 000000000000..488d5dfd561e
--- /dev/null
+++ b/www-apps/phprojekt/files/postinstall-6-en.txt
@@ -0,0 +1,9 @@
+You are almost done!
+
+ 1. You will need to create a blank database for phprojekt to use. Consult
+ your database manual.
+
+ 2. Complete the installation by logging on to
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/index.html
+
+ Enjoy!
diff --git a/www-apps/phprojekt/phprojekt-6.1.2.ebuild b/www-apps/phprojekt/phprojekt-6.1.2.ebuild
new file mode 100644
index 000000000000..3a72b5983eef
--- /dev/null
+++ b/www-apps/phprojekt/phprojekt-6.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/phprojekt-6.1.2.ebuild,v 1.1 2012/06/25 19:03:46 mabi Exp $
+
+EAPI=4
+
+inherit vcs-snapshot webapp
+
+MY_PN="PHProjekt"
+
+DESCRIPTION="Project management and coordination system"
+HOMEPAGE="http://www.phprojekt.com/"
+SRC_URI="https://github.com/Mayflower/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="postgres mysql"
+
+RDEPEND="virtual/httpd-php
+ dev-lang/php[gd,imap,mysql?,pdo,postgres?,session,zlib]"
+
+# need at least one option for a database
+REQUIRED_USE="|| ( mysql postgres )"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc phprojekt/INSTALL phprojekt/UPDATE phprojekt/README
+ dodoc phprojekt/configuration.php-dist
+
+ cp -R phprojekt/* "${D}/${MY_HTDOCSDIR}"
+ cp phprojekt/.htaccess "${D}/${MY_HTDOCSDIR}"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"
+
+ dodir "${MY_HOSTROOTDIR}/phprojekt_private"
+ webapp_serverowned "${MY_HOSTROOTDIR}/phprojekt_private"
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-6-en.txt
+ webapp_src_install
+}