summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-03-01 15:00:31 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-03-01 15:00:31 +0000
commitcce1bc3a08685050d48b38e97e9130e9042aa577 (patch)
tree5d9393513aee55da430644713830170f05b2f99d /www-apps/phpBB/phpBB-2.0.13.ebuild
parentApplied patch for unicode support; see Bug #28369. There are some rdep-issue... (diff)
downloadgentoo-2-cce1bc3a08685050d48b38e97e9130e9042aa577.tar.gz
gentoo-2-cce1bc3a08685050d48b38e97e9130e9042aa577.tar.bz2
gentoo-2-cce1bc3a08685050d48b38e97e9130e9042aa577.zip
Version bump for security bug 82955.
(Portage version: 2.0.51.18)
Diffstat (limited to 'www-apps/phpBB/phpBB-2.0.13.ebuild')
-rw-r--r--www-apps/phpBB/phpBB-2.0.13.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-apps/phpBB/phpBB-2.0.13.ebuild b/www-apps/phpBB/phpBB-2.0.13.ebuild
new file mode 100644
index 000000000000..a94530f212aa
--- /dev/null
+++ b/www-apps/phpBB/phpBB-2.0.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/phpBB-2.0.13.ebuild,v 1.1 2005/03/01 15:00:31 ka0ttic Exp $
+
+inherit webapp
+
+DESCRIPTION="phpBB is an open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="mirror://sourceforge/phpbb/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+
+RDEPEND="virtual/php"
+
+S=${WORKDIR}/${PN}2
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ${S}/docs/*
+ rm -rf ${S}/docs/
+
+ cp -a * "${D}/${MY_HTDOCSDIR}"
+
+ echo "<?php trigger_error('Please use install/install.php to configure phpBB for your system!', E_USER_ERROR); ?>" > "${D}/${MY_HTDOCSDIR}/config.php"
+ webapp_serverowned "${MY_HTDOCSDIR}/config.php"
+
+ webapp_postinst_txt en ${FILESDIR}/2.0.10-postinstall-en.txt
+
+ webapp_src_install
+}