summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-09-18 12:29:04 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-09-18 12:29:04 +0000
commit099960fa48aa183abf85d6d5692c0bf41052370b (patch)
treed9a55e8b5a9c56d8eac83bd183868c92aee7d8b3 /www-apps/otrs
parentnew josm url (diff)
downloadgentoo-2-099960fa48aa183abf85d6d5692c0bf41052370b.tar.gz
gentoo-2-099960fa48aa183abf85d6d5692c0bf41052370b.tar.bz2
gentoo-2-099960fa48aa183abf85d6d5692c0bf41052370b.zip
Added otrs 2.2.3 to the tree.
(Portage version: 2.1.2.12)
Diffstat (limited to 'www-apps/otrs')
-rw-r--r--www-apps/otrs/ChangeLog7
-rw-r--r--www-apps/otrs/files/digest-otrs-2.2.33
-rw-r--r--www-apps/otrs/otrs-2.2.3.ebuild118
3 files changed, 127 insertions, 1 deletions
diff --git a/www-apps/otrs/ChangeLog b/www-apps/otrs/ChangeLog
index dccc63c3dac4..2f3ef67ec697 100644
--- a/www-apps/otrs/ChangeLog
+++ b/www-apps/otrs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/otrs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/ChangeLog,v 1.37 2007/09/16 05:38:02 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/ChangeLog,v 1.38 2007/09/18 12:29:04 wrobel Exp $
+
+*otrs-2.2.3 (18 Sep 2007)
+
+ 18 Sep 2007; <wrobel@gentoo.org> +otrs-2.2.3.ebuild:
+ Added otrs 2.2.3 to the tree.
16 Sep 2007; <wrobel@gentoo.org> otrs-2.2.2.ebuild:
Fixed ebuild type (see #192202).
diff --git a/www-apps/otrs/files/digest-otrs-2.2.3 b/www-apps/otrs/files/digest-otrs-2.2.3
new file mode 100644
index 000000000000..5a59fb4c8131
--- /dev/null
+++ b/www-apps/otrs/files/digest-otrs-2.2.3
@@ -0,0 +1,3 @@
+MD5 897de4925eb444f689b56165cd35ce8c otrs-2.2.3.tar.bz2 10281102
+RMD160 ebfcd5083836d07e8e817168ed82e1e795b04433 otrs-2.2.3.tar.bz2 10281102
+SHA256 d175b8f48f43acd376b1a40477add6e413a03d31209a95a49d30654d7e91b42f otrs-2.2.3.tar.bz2 10281102
diff --git a/www-apps/otrs/otrs-2.2.3.ebuild b/www-apps/otrs/otrs-2.2.3.ebuild
new file mode 100644
index 000000000000..8005da1f360e
--- /dev/null
+++ b/www-apps/otrs/otrs-2.2.3.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/otrs-2.2.3.ebuild,v 1.1 2007/09/18 12:29:04 wrobel Exp $
+
+inherit webapp eutils depend.apache
+
+IUSE="mysql postgres fastcgi ldap gd pdf"
+
+DESCRIPTION="OTRS is an Open source Ticket Request System"
+HOMEPAGE="http://otrs.org/"
+SRC_URI="ftp://ftp.otrs.org/pub/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ ${DEPEND}
+ =dev-lang/perl-5*
+ dev-perl/Date-Pcalc
+ dev-perl/TimeDate
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/DBI
+ virtual/perl-CGI
+ virtual/perl-Digest-MD5
+ dev-perl/libwww-perl
+ dev-perl/IO-stringy
+ virtual/perl-MIME-Base64
+ dev-perl/MIME-tools
+ dev-perl/MailTools
+ dev-perl/Net-DNS
+ virtual/perl-libnet
+ dev-perl/Authen-SASL
+ dev-perl/XML-Parser
+ virtual/mta
+ pdf? ( dev-perl/PDF-API2 )
+ ldap? ( dev-perl/perl-ldap net-nds/openldap )
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ fastcgi? ( dev-perl/FCGI )
+ apache2? ( =www-apache/libapreq2-2* )
+ gd? ( dev-perl/GD dev-perl/GDTextUtil dev-perl/GDGraph )
+"
+
+want_apache
+
+LICENSE="GPL-2"
+
+pkg_setup() {
+ webapp_pkg_setup
+ if use apache2; then
+ enewuser otrs -1 -1 /dev/null apache
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cp ${S}/Kernel/Config.pm.dist ${S}/Kernel/Config.pm
+
+ # http://bugs.otrs.org/show_bug.cgi?id=1231
+ cd ${S}
+ epatch ${FILESDIR}/dbi_finish.patch
+
+ cd ${S}/Kernel/Config/
+ for foo in *.dist; do cp ${foo} $(basename ${foo} .dist); done
+
+ cd ${S}/scripts
+ rm -rf auto_* redhat* suse*
+
+ if use fastcgi; then
+ epatch ${FILESDIR}/apache2.patch
+ sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache2-httpd.include.conf
+ sed -e "s|index.pl|index.fpl|" -i ${S}/var/httpd/htdocs/index.html
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+ dodir ${MY_HOSTROOTDIR}/${PF}
+
+ # install documentation
+ dodoc CHANGES CREDITS INSTALL README* TODO UPGRADING \
+ doc/otrs-database.dia doc/test-* doc/X-OTRS-Headers.txt \
+ .fetchmailrc.dist .mailfilter.dist .procmailrc.dist
+ dohtml doc/manual/{en,de}/html/*
+
+ # copy main files
+ cp -R .fetchmailrc.dist .mailfilter.dist .procmailrc.dist RELEASE Kernel bin scripts var ${D}/${MY_HOSTROOTDIR}/${PF}
+ mv ${D}/${MY_HOSTROOTDIR}/${PF}/var/httpd/htdocs/* ${D}/${MY_HTDOCSDIR}
+
+ # remove stuff from ${D} that shouldn't be there
+ rm -rf ${D}/${MY_HOSTROOTDIR}/${PF}/var/httpd
+
+ # keep some empty dirs
+ local a
+ local d="article log pics/images pics/stats pics sessions spool tmp"
+ for a in ${d}; do
+ keepdir ${MY_HOSTROOTDIR}/${PF}/var/${a}
+ done
+
+ # helpers
+ webapp_configfile ${MY_HOSTROOTDIR}/${PF}/Kernel/Config.pm
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-2.txt
+ webapp_hook_script ${FILESDIR}/reconfig-2
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "webapp-config will not be run automatically"
+ ewarn "That messes up Apache configs"
+ ewarn "Don't run webapp-config with -d otrs. Instead, try"
+ ewarn "webapp-config -I -h <host> -d ot ${PN} ${PVR}"
+ ewarn
+ if ! use apache2; then
+ ewarn "You did not activate the USE-flag apache2 which means you"
+ ewarn "will need to create the otrs user yourself. Make this user"
+ ewarn "a member of your webserver group."
+ fi
+ # webapp_pkg_postinst
+}