summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-02 04:55:56 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-02 04:55:56 +0000
commit72cbb88983ecfac498d7d5358443c96ccf93fd15 (patch)
tree75b6ea62a005afcd5f0f87a23500e0c8765f5912 /www-apps/nanoblogger
parentVersion bump. (diff)
downloadgentoo-2-72cbb88983ecfac498d7d5358443c96ccf93fd15.tar.gz
gentoo-2-72cbb88983ecfac498d7d5358443c96ccf93fd15.tar.bz2
gentoo-2-72cbb88983ecfac498d7d5358443c96ccf93fd15.zip
Version bump.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/nanoblogger')
-rw-r--r--www-apps/nanoblogger/ChangeLog7
-rw-r--r--www-apps/nanoblogger/nanoblogger-3.4.2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/www-apps/nanoblogger/ChangeLog b/www-apps/nanoblogger/ChangeLog
index 581aaed611e2..4ec454da4b02 100644
--- a/www-apps/nanoblogger/ChangeLog
+++ b/www-apps/nanoblogger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/nanoblogger
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/nanoblogger/ChangeLog,v 1.25 2011/02/06 10:48:33 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nanoblogger/ChangeLog,v 1.26 2011/10/02 04:55:56 radhermit Exp $
+
+*nanoblogger-3.4.2 (02 Oct 2011)
+
+ 02 Oct 2011; Tim Harder <radhermit@gentoo.org> +nanoblogger-3.4.2.ebuild:
+ Version bump.
06 Feb 2011; Mart Raudsepp <leio@gentoo.org> nanoblogger-3.2.3.ebuild:
Drop to ~mips
diff --git a/www-apps/nanoblogger/nanoblogger-3.4.2.ebuild b/www-apps/nanoblogger/nanoblogger-3.4.2.ebuild
new file mode 100644
index 000000000000..6e14e095d6ab
--- /dev/null
+++ b/www-apps/nanoblogger/nanoblogger-3.4.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nanoblogger/nanoblogger-3.4.2.ebuild,v 1.1 2011/10/02 04:55:56 radhermit Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Small and simple weblog engine written in Bash for the command-line"
+HOMEPAGE="http://nanoblogger.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash"
+
+src_prepare() {
+ sed -i \
+ -e 's|^\(NB_BASE_DIR=\).*$|\1"/usr/share/nanoblogger"|' \
+ -e 's|^\(NB_CFG_DIR=\).*$|\1"/etc"|' \
+ -e "s|\$NB_BASE_DIR.*\(nano.*html\)|/usr/share/doc/${PF}/html/\1|" \
+ nb || die "sed nb failed"
+}
+
+src_install() {
+ dobin nb
+ insinto /usr/share/nanoblogger
+ doins -r default moods plugins lib lang docs welcome-to-nb.txt
+ insinto /etc
+ doins nb.conf
+ dodoc ChangeLog
+ dohtml docs/nanoblogger.html
+ dobashcomp "${FILESDIR}"/nb.bashcomp
+}
+
+pkg_postinst() {
+ elog
+ elog "Documentation for getting started with nanoblogger may be found at"
+ elog "/usr/share/doc/${PF}/html/nanoblogger.html or by running 'nb --manual;."
+ elog
+ elog "To create and configure a new weblog, run the following as your user:"
+ elog " nb -b /some/dir -a"
+ elog "where /some/dir is a directory that DOES NOT exist."
+ elog
+ elog "To prevent having to specify your blog directory every time you use"
+ elog "nanoblogger (with the -b switch), you can set a default value in your"
+ elog "~/.nb.conf. For example:"
+ elog ' BLOG_DIR="$HOME/public_html/blog"'
+ elog
+ elog "If you are upgrading nanoblogger from a previous version, follow"
+ elog "these directions (as stated in the manual):"
+ elog " 1. create a new weblog directory using nanoblogger (skip configuration):"
+ elog " nb [-b blog_dir] -a"
+ elog " 2. copy old data directry to new weblog:"
+ elog " cp -r [old_blog_dir]/data [newblog_dir]"
+ elog " 3. edit new blog.conf to your liking and rebuild weblog:"
+ elog " nb [-b blog_dir] --configure -u all"
+ elog
+ elog "You also should remove your [newblog_dir]/data/cat_1.db and run:"
+ elog " nb -u all"
+ elog "after copying your old entries from [oldblog_dir]/data to"
+ elog "[newblog_dir]/data."
+ elog
+ bash-completion_pkg_postinst
+}