summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-08-24 00:56:29 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-08-24 00:56:29 +0000
commit53fe103091c82a9cb7b2b63b03fe6ee24edc2fe4 (patch)
tree653099fe7ae929b76a1c3c2c13d106224c3860f2 /www-apps/mythweb
parentupstream fixes for imdb.pl (diff)
downloadgentoo-2-53fe103091c82a9cb7b2b63b03fe6ee24edc2fe4.tar.gz
gentoo-2-53fe103091c82a9cb7b2b63b03fe6ee24edc2fe4.tar.bz2
gentoo-2-53fe103091c82a9cb7b2b63b03fe6ee24edc2fe4.zip
upstream fix for bug #183770
(Portage version: 2.1.3.6)
Diffstat (limited to 'www-apps/mythweb')
-rw-r--r--www-apps/mythweb/ChangeLog8
-rw-r--r--www-apps/mythweb/files/digest-mythweb-0.20.1_p142690
-rw-r--r--www-apps/mythweb/mythweb-0.20.1_p14269.ebuild54
3 files changed, 61 insertions, 1 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index d5357f94bed3..efdcd642253b 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.42 2007/08/15 13:43:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.43 2007/08/24 00:56:29 cardoe Exp $
+
+*mythweb-0.20.1_p14269 (24 Aug 2007)
+
+ 24 Aug 2007; Doug Goldstein <cardoe@gentoo.org>
+ +mythweb-0.20.1_p14269.ebuild:
+ upstream fix for bug #183770
15 Aug 2007; Doug Goldstein <cardoe@gentoo.org>
mythweb-0.21_pre14151.ebuild:
diff --git a/www-apps/mythweb/files/digest-mythweb-0.20.1_p14269 b/www-apps/mythweb/files/digest-mythweb-0.20.1_p14269
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/www-apps/mythweb/files/digest-mythweb-0.20.1_p14269
diff --git a/www-apps/mythweb/mythweb-0.20.1_p14269.ebuild b/www-apps/mythweb/mythweb-0.20.1_p14269.ebuild
new file mode 100644
index 000000000000..424f611551a5
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.20.1_p14269.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.20.1_p14269.ebuild,v 1.1 2007/08/24 00:56:29 cardoe Exp $
+
+inherit mythtv webapp depend.php subversion
+
+ESVN_PROJECT="mythplugins"
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="virtual/httpd-php
+ dev-perl/DBI
+ dev-perl/DBD-mysql"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if has_version 'dev-lang/php' ; then
+ require_php_with_use session mysql pcre posix
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}/.."
+ mythtv-fixes_patch
+ cd "${S}"
+}
+
+src_compile() {
+ echo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd "${S}/mythweb"
+ dodoc README TODO
+
+ dodir ${MY_HTDOCSDIR}/data
+
+ cp -R [[:lower:]]* .htaccess ${D}${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/data
+ webapp_serverowned ${MY_HTDOCSDIR}/.htaccess
+
+ webapp_configfile ${MY_HTDOCSDIR}/.htaccess
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-0.20.txt
+
+ webapp_src_install
+}