summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-07-28 23:52:43 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-07-28 23:52:43 +0000
commit05e4f6d904b914ea7667f4b76931361203a13552 (patch)
treeff17c4119155d7d6d433bec7b55739394d68bb01 /www-apps/moodle
parentRemove old (diff)
downloadgentoo-2-05e4f6d904b914ea7667f4b76931361203a13552.tar.gz
gentoo-2-05e4f6d904b914ea7667f4b76931361203a13552.tar.bz2
gentoo-2-05e4f6d904b914ea7667f4b76931361203a13552.zip
Remove older vulnerable versions
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-apps/moodle')
-rw-r--r--www-apps/moodle/ChangeLog6
-rw-r--r--www-apps/moodle/moodle-2.2.10.ebuild128
-rw-r--r--www-apps/moodle/moodle-2.3.7.ebuild128
-rw-r--r--www-apps/moodle/moodle-2.4.4.ebuild128
-rw-r--r--www-apps/moodle/moodle-2.5.ebuild128
5 files changed, 5 insertions, 513 deletions
diff --git a/www-apps/moodle/ChangeLog b/www-apps/moodle/ChangeLog
index 2c4e9f10ec87..7b55e531803f 100644
--- a/www-apps/moodle/ChangeLog
+++ b/www-apps/moodle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/moodle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.44 2013/07/07 17:38:17 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.45 2013/07/28 23:52:43 blueness Exp $
+
+ 28 Jul 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.10.ebuild,
+ -moodle-2.3.7.ebuild, -moodle-2.4.4.ebuild, -moodle-2.5.ebuild:
+ Remove older vulnerable versions
*moodle-2.3.8 (07 Jul 2013)
*moodle-2.4.5 (07 Jul 2013)
diff --git a/www-apps/moodle/moodle-2.2.10.ebuild b/www-apps/moodle/moodle-2.2.10.ebuild
deleted file mode 100644
index 8b0840e1044c..000000000000
--- a/www-apps/moodle/moodle-2.2.10.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.2.10.ebuild,v 1.1 2013/05/14 19:53:38 blueness Exp $
-
-EAPI="4"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS_53="ctype,curl,iconv,json,session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS_53="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS_53="${PHP_REQUIRED_FLAGS_53},${PHP_OPTIONAL_FLAGS_53}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-REQUIRED_USE="|| ( ${DB_TYPES} )"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="
- =dev-lang/php-5.3*[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS_53}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
- #if [[ ${DB_COUNT} -eq 0 ]]; then
- # eerror
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror "No database selected in your USE flags,"
- # eerror "You must select at least one."
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror
- # die
- #fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- # Moodle expect postgres7, not postgres
- MYDB=${MYDB/postgres/postgres7}
-
- # Moodle expects mysql, not mysqli
- MYDB=${MYDB/mysqli/mysql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
-}
diff --git a/www-apps/moodle/moodle-2.3.7.ebuild b/www-apps/moodle/moodle-2.3.7.ebuild
deleted file mode 100644
index 186a8cc1f206..000000000000
--- a/www-apps/moodle/moodle-2.3.7.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.3.7.ebuild,v 1.1 2013/05/14 19:53:38 blueness Exp $
-
-EAPI="4"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS_53="ctype,curl,iconv,json,session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS_53="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS_53="${PHP_REQUIRED_FLAGS_53},${PHP_OPTIONAL_FLAGS_53}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-REQUIRED_USE="|| ( ${DB_TYPES} )"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="
- =dev-lang/php-5.3*[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS_53}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
- #if [[ ${DB_COUNT} -eq 0 ]]; then
- # eerror
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror "No database selected in your USE flags,"
- # eerror "You must select at least one."
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror
- # die
- #fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- # Moodle expect postgres7, not postgres
- MYDB=${MYDB/postgres/postgres7}
-
- # Moodle expects mysql, not mysqli
- MYDB=${MYDB/mysqli/mysql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
-}
diff --git a/www-apps/moodle/moodle-2.4.4.ebuild b/www-apps/moodle/moodle-2.4.4.ebuild
deleted file mode 100644
index 78256b054d71..000000000000
--- a/www-apps/moodle/moodle-2.4.4.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.4.4.ebuild,v 1.1 2013/05/14 19:53:38 blueness Exp $
-
-EAPI="5"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS="ctype,curl,iconv,json,session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-REQUIRED_USE="|| ( ${DB_TYPES} )"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="
- =dev-lang/php-5.3*[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
- #if [[ ${DB_COUNT} -eq 0 ]]; then
- # eerror
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror "No database selected in your USE flags,"
- # eerror "You must select at least one."
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror
- # die
- #fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- # Moodle expect postgres7, not postgres
- MYDB=${MYDB/postgres/postgres7}
-
- # Moodle expects mysql, not mysqli
- MYDB=${MYDB/mysqli/mysql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
-}
diff --git a/www-apps/moodle/moodle-2.5.ebuild b/www-apps/moodle/moodle-2.5.ebuild
deleted file mode 100644
index 63894e205be1..000000000000
--- a/www-apps/moodle/moodle-2.5.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.5.ebuild,v 1.1 2013/05/14 19:53:38 blueness Exp $
-
-EAPI="5"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS="ctype,curl,iconv,json,session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-REQUIRED_USE="|| ( ${DB_TYPES} )"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="
- =dev-lang/php-5.3*[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
- #if [[ ${DB_COUNT} -eq 0 ]]; then
- # eerror
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror "No database selected in your USE flags,"
- # eerror "You must select at least one."
- # eerror "\033[1;31m**************************************************\033[00m"
- # eerror
- # die
- #fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- # Moodle expect postgres7, not postgres
- MYDB=${MYDB/postgres/postgres7}
-
- # Moodle expects mysql, not mysqli
- MYDB=${MYDB/mysqli/mysql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[00m"
- einfo
-}