summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-03 17:04:57 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-03 17:04:57 +0000
commit5754c36710f55b32e786e8b142f92d070cf60bb6 (patch)
tree9660387493e67f500a02934f1e0b243290fb14c0 /www-apps/lxr
parentdev-libs/libIDL: bump to 0.8.10 (fixes the glib-2.15 bug, G_STRFUNC patch no ... (diff)
downloadgentoo-2-5754c36710f55b32e786e8b142f92d070cf60bb6.tar.gz
gentoo-2-5754c36710f55b32e786e8b142f92d070cf60bb6.tar.bz2
gentoo-2-5754c36710f55b32e786e8b142f92d070cf60bb6.zip
merge from webapps overlay wrt #208584
(Portage version: 2.1.4)
Diffstat (limited to 'www-apps/lxr')
-rw-r--r--www-apps/lxr/ChangeLog14
-rw-r--r--www-apps/lxr/lxr-0.9.5.ebuild25
2 files changed, 32 insertions, 7 deletions
diff --git a/www-apps/lxr/ChangeLog b/www-apps/lxr/ChangeLog
index 43485fa22c3b..3a0c68b5393c 100644
--- a/www-apps/lxr/ChangeLog
+++ b/www-apps/lxr/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-apps/lxr
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/ChangeLog,v 1.14 2007/07/29 17:28:37 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/ChangeLog,v 1.15 2008/02/03 17:04:57 hollow Exp $
+
+ 03 Feb 2008; Benedikt Böhm <hollow@gentoo.org> lxr-0.9.5.ebuild:
+ merge from webapps overlay wrt #208584
+
+ 02 Feb 2008; Jakub Moc <jakub@gentoo.org> lxr-0.9.5.ebuild:
+ Fix apache dependency wrt Bug 208584. Remove incorrect dependency on
+ dev-db/postgresql. Set WEBAPP_MANUAL_SLOT since otherwise this will
+ obviously collide on the perl modules stuff. Call webapp eclass
+ functions explicitely so that this does not get messed up by
+ perl-module exported functions.
29 Jul 2007; Christian Heim <phreak@gentoo.org> lxr-0.9.5.ebuild:
Fixing the DEPEND/RDEPEND for the move of net-www/apache to
diff --git a/www-apps/lxr/lxr-0.9.5.ebuild b/www-apps/lxr/lxr-0.9.5.ebuild
index 76762367644d..a2e33b968f99 100644
--- a/www-apps/lxr/lxr-0.9.5.ebuild
+++ b/www-apps/lxr/lxr-0.9.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/lxr-0.9.5.ebuild,v 1.4 2007/07/29 17:28:37 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/lxr-0.9.5.ebuild,v 1.5 2008/02/03 17:04:57 hollow Exp $
-inherit perl-module webapp multilib eutils
+inherit perl-module webapp multilib eutils depend.apache
DESCRIPTION="general purpose source code indexer and cross-referener with a web-based frontend"
HOMEPAGE="http://sourceforge.net/projects/lxr"
@@ -11,17 +11,24 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="cvs freetext mysql postgres"
+WEBAPP_MANUAL_SLOT="yes"
+SLOT="0"
RDEPEND="dev-util/ctags
- www-servers/apache
freetext? ( >=www-apps/swish-e-2.1 )
dev-lang/perl
dev-perl/DBI
dev-perl/File-MMagic
cvs? ( app-text/rcs )
- postgres? ( dev-db/postgresql dev-perl/DBD-Pg )
+ postgres? ( dev-perl/DBD-Pg )
mysql? ( dev-perl/DBD-mysql )"
+need_apache2
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -69,3 +76,11 @@ src_install() {
webapp_hook_script "${FILESDIR}"/reconfig
webapp_src_install
}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}
+
+pkg_prerm() {
+ webapp_pkg_prerm
+}