summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-09-29 07:38:27 +0000
committerPeter Volkov <pva@gentoo.org>2008-09-29 07:38:27 +0000
commitf1b800eba408eb1ab14252e54f64ae14653a1b1c (patch)
treed136a7c91fa44307bda6773103b079c78630503f /www-apps/gallery
parentPushing fixes from svn, should fix security issue #238570, thank Robert Buchh... (diff)
downloadgentoo-2-f1b800eba408eb1ab14252e54f64ae14653a1b1c.tar.gz
gentoo-2-f1b800eba408eb1ab14252e54f64ae14653a1b1c.tar.bz2
gentoo-2-f1b800eba408eb1ab14252e54f64ae14653a1b1c.zip
Version bump, fixes security issues, bug #238113, thank Robert Buchholz for report.
(Portage version: 2.2_rc9/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'www-apps/gallery')
-rw-r--r--www-apps/gallery/ChangeLog10
-rw-r--r--www-apps/gallery/gallery-1.5.9.ebuild47
-rw-r--r--www-apps/gallery/gallery-2.2.6.ebuild71
3 files changed, 127 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index eca23db21098..5a79d252cd4f 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/gallery
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.153 2008/09/19 18:50:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.154 2008/09/29 07:38:27 pva Exp $
+
+*gallery-2.2.6 (29 Sep 2008)
+*gallery-1.5.9 (29 Sep 2008)
+
+ 29 Sep 2008; Peter Volkov <pva@gentoo.org> +gallery-1.5.9.ebuild,
+ +gallery-2.2.6.ebuild:
+ Version bump, fixes security issues, bug #238113, thank Robert Buchholz for
+ report.
19 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
gallery-1.5.8.ebuild:
diff --git a/www-apps/gallery/gallery-1.5.9.ebuild b/www-apps/gallery/gallery-1.5.9.ebuild
new file mode 100644
index 000000000000..6cf2b1d1b7a4
--- /dev/null
+++ b/www-apps/gallery/gallery-1.5.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.9.ebuild,v 1.1 2008/09/29 07:38:27 pva Exp $
+
+inherit webapp depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="imagemagick netpbm unzip zip"
+
+RDEPEND="media-libs/jpeg
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )"
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any imagemagick netpbm
+ require_php_with_use pcre session
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ gunzip ChangeLog.archive.gz
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc AUTHORS ChangeLog ChangeLog.archive README
+ dohtml docs/*
+
+ cp -r . "${D}/${MY_HTDOCSDIR}"
+ rm -rf "${D}/${MY_HTDOCSDIR}"/{AUTHORS,ChangeLog,ChangeLog.archive,README,LICENSE.txt,docs/}
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/gallery/gallery-2.2.6.ebuild b/www-apps/gallery/gallery-2.2.6.ebuild
new file mode 100644
index 000000000000..6bf8e2bfe69b
--- /dev/null
+++ b/www-apps/gallery/gallery-2.2.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.2.6.ebuild,v 1.1 2008/09/29 07:38:27 pva Exp $
+
+inherit webapp eutils depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg gd imagemagick mysql netpbm postgres raw unzip zip"
+
+RDEPEND="media-libs/jpeg
+ raw? ( >=media-gfx/dcraw-8.03 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )"
+
+S=${WORKDIR}/${PN}2
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any gd imagemagick netpbm
+ confutils_require_any mysql postgres
+
+ local php_flags="pcre session"
+ use mysql && php_flags="${php_flags} mysql"
+ use postgres && php_flags="${php_flags} postgres"
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags} || \
+ ( use gd && ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ) ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following USE flags enabled:"
+ eerror
+ eerror "${php_flags}"
+ eerror
+ use gd && eerror "as well as with either gd or gd-external USE flag enabled."
+ die "Re-install ${PHP_PKG}."
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dohtml README.html
+ rm README.html LICENSE MANIFEST
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en2.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading to 2.2 will make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}