summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-01-16 09:47:51 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-01-16 09:47:51 +0000
commit745250ba0f0dce3486199264c2c4688441a94e31 (patch)
tree036d5b573f639a1c06ebd164ab80a7e9e2b0d3be /www-apps/drupal
parentFix for tkinter object and typo, bug #255108, thanks Colin Macdonald (diff)
downloadgentoo-2-745250ba0f0dce3486199264c2c4688441a94e31.tar.gz
gentoo-2-745250ba0f0dce3486199264c2c4688441a94e31.tar.bz2
gentoo-2-745250ba0f0dce3486199264c2c4688441a94e31.zip
version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.22-vs2.3.0.34-gentoo x86_64)
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/ChangeLog11
-rw-r--r--www-apps/drupal/drupal-5.15.ebuild51
-rw-r--r--www-apps/drupal/drupal-6.9.ebuild56
3 files changed, 116 insertions, 2 deletions
diff --git a/www-apps/drupal/ChangeLog b/www-apps/drupal/ChangeLog
index c36fad059922..08de8d5efc5b 100644
--- a/www-apps/drupal/ChangeLog
+++ b/www-apps/drupal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/drupal
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.55 2008/12/25 18:45:23 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.56 2009/01/16 09:47:51 hollow Exp $
+
+*drupal-6.9 (16 Jan 2009)
+*drupal-5.15 (16 Jan 2009)
+
+ 16 Jan 2009; Benedikt Böhm <hollow@gentoo.org> +drupal-5.15.ebuild,
+ +drupal-6.9.ebuild:
+ version bump
*drupal-6.8 (25 Dec 2008)
*drupal-5.14 (25 Dec 2008)
diff --git a/www-apps/drupal/drupal-5.15.ebuild b/www-apps/drupal/drupal-5.15.ebuild
new file mode 100644
index 000000000000..e4d92b1b0b3e
--- /dev/null
+++ b/www-apps/drupal/drupal-5.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-5.15.ebuild,v 1.1 2009/01/16 09:47:51 hollow Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use expat
+ else
+ require_php_with_use xml
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt"
+ dodoc ${docs}
+ rm -f ${docs} INSTALL
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/drupal/drupal-6.9.ebuild b/www-apps/drupal/drupal-6.9.ebuild
new file mode 100644
index 000000000000..a3294a8ea18d
--- /dev/null
+++ b/www-apps/drupal/drupal-6.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-6.9.ebuild,v 1.1 2009/01/16 09:47:51 hollow Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ local flags="expat"
+ else
+ local flags="xml"
+ fi
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt
+
+ cp sites/default/{default.settings.php,settings.php}
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}