summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2005-08-21 17:13:35 +0000
committerRenat Lumpau <rl03@gentoo.org>2005-08-21 17:13:35 +0000
commit60f973416928c3d96e3953e372f1fc68523d2b8b (patch)
tree66b396acb883fa03cb85be27805d1a492871ffc4 /www-apps/drraw/drraw-2.1.3.ebuild
parentAdded ~sparc keyword, resolves bug #102413. (diff)
downloadgentoo-2-60f973416928c3d96e3953e372f1fc68523d2b8b.tar.gz
gentoo-2-60f973416928c3d96e3953e372f1fc68523d2b8b.tar.bz2
gentoo-2-60f973416928c3d96e3953e372f1fc68523d2b8b.zip
Version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-apps/drraw/drraw-2.1.3.ebuild')
-rw-r--r--www-apps/drraw/drraw-2.1.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/drraw/drraw-2.1.3.ebuild b/www-apps/drraw/drraw-2.1.3.ebuild
new file mode 100644
index 000000000000..76563e9c0024
--- /dev/null
+++ b/www-apps/drraw/drraw-2.1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drraw/drraw-2.1.3.ebuild,v 1.1 2005/08/21 17:13:35 rl03 Exp $
+
+inherit webapp
+
+IUSE=""
+
+DESCRIPTION="drraw is a simple web based presentation front-end for RRDtool that allows you to interactively build graphs of your own design"
+HOMEPAGE="http://web.taranis.org/drraw"
+SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
+
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="
+ >=dev-lang/perl-5.6
+ perl-core/CGI
+ >=net-analyzer/rrdtool-1.2.1
+"
+
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s|/usr/local/bin/perl|/usr/bin/perl|
+ s|/drraw.conf|/../drraw.conf|" -i drraw.cgi
+ sed -e "s|/somewhere/drraw/saved|/tmp|
+ s|/somewhere/drraw/tmp|/tmp|" -i drraw.conf
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGES INSTALL README.EVENTS WISHLIST
+ cp drraw.cgi ${D}/${MY_CGIBINDIR} && chmod +x ${D}/${MY_CGIBINDIR}/drraw.cgi
+ cp drraw.conf ${D}/${MY_HOSTROOTDIR}
+ cp icons/* ${MY_ICONSDIR}
+
+ webapp_configfile ${MY_HOSTROOTDIR}/drraw.conf
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}