summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2014-01-09 13:05:57 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2014-01-09 13:05:57 +0000
commitccf56f2c9724d3e08cc53d1afd707b5766cecefc (patch)
tree44eddc83340c4806f44d56dd039c97f71776f98c /www-apps/dokuwiki
parentVersion bump (bug #416161 by df). (diff)
downloadgentoo-2-ccf56f2c9724d3e08cc53d1afd707b5766cecefc.tar.gz
gentoo-2-ccf56f2c9724d3e08cc53d1afd707b5766cecefc.tar.bz2
gentoo-2-ccf56f2c9724d3e08cc53d1afd707b5766cecefc.zip
Version bump dokuwiki to the 2013-12-08 (Binky) release.
Update SRC_URI as the download source was changed. Update postinst file to replace the old wiki site with the new site. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key BB0E6E98)
Diffstat (limited to 'www-apps/dokuwiki')
-rw-r--r--www-apps/dokuwiki/ChangeLog12
-rw-r--r--www-apps/dokuwiki/dokuwiki-20131208.ebuild68
-rw-r--r--www-apps/dokuwiki/files/postinstall-en.txt13
-rw-r--r--www-apps/dokuwiki/metadata.xml4
4 files changed, 91 insertions, 6 deletions
diff --git a/www-apps/dokuwiki/ChangeLog b/www-apps/dokuwiki/ChangeLog
index 79e1bebf1335..9a8a231adaa0 100644
--- a/www-apps/dokuwiki/ChangeLog
+++ b/www-apps/dokuwiki/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/dokuwiki
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.63 2013/09/06 19:09:54 jmbsvicetto Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.64 2014/01/09 13:05:57 jmbsvicetto Exp $
+
+*dokuwiki-20131208 (09 Jan 2014)
+
+ 09 Jan 2014; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +dokuwiki-20131208.ebuild, files/postinstall-en.txt, metadata.xml:
+ Version bump dokuwiki to the 2013-12-08 (Binky) release. Update SRC_URI as the
+ download source was changed. Update postinst file to replace the old wiki site
+ with the new site.
*dokuwiki-20130510a (06 Sep 2013)
diff --git a/www-apps/dokuwiki/dokuwiki-20131208.ebuild b/www-apps/dokuwiki/dokuwiki-20131208.ebuild
new file mode 100644
index 000000000000..57be1f9ae79c
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20131208.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20131208.ebuild,v 1.1 2014/01/09 13:05:57 jmbsvicetto Exp $
+
+EAPI="4"
+
+inherit webapp depend.php
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+ >=dev-lang/php-5.3[xml]
+ gd? ( ||
+ (
+ dev-lang/php[gd]
+ media-gfx/imagemagick
+ )
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # create initial changes file
+ touch data/changes.log
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README
+ rm -f README COPYING
+
+ docinto scripts
+ dodoc bin/*
+ rm -rf bin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ for x in $(find data/ -not -name '.htaccess'); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+ webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+ for x in $(find conf/ -not -name 'msg'); do
+ webapp_configfile "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/dokuwiki/files/postinstall-en.txt b/www-apps/dokuwiki/files/postinstall-en.txt
index b00cd479e3a5..1816ba6bf88d 100644
--- a/www-apps/dokuwiki/files/postinstall-en.txt
+++ b/www-apps/dokuwiki/files/postinstall-en.txt
@@ -41,7 +41,12 @@ To complete installation you need to perform the following steps:
This enables apache to write to the files for editing the acl/user
creation capability.
-[1] http://wiki.splitbrain.org/wiki:config
-[2] http://wiki.splitbrain.org/wiki:dokuwiki
-[3] http://wiki.splitbrain.org/wiki:acl
-[4] http://wiki.splitbrain.org/wiki:auth_plain
+ If you're updating from an older version of Dokuwiki or want to learn about
+ other authentication methods, check the documentation about authentication
+ backends and plugins[5].
+
+[1] https://www.dokuwiki.org/config
+[2] https://www.dokuwiki.org/dokuwiki
+[3] https://www.dokuwiki.org/acl
+[4] https://www.dokuwiki.org/plugin:authplain
+[5] https://www.dokuwiki.org/auth
diff --git a/www-apps/dokuwiki/metadata.xml b/www-apps/dokuwiki/metadata.xml
index fd76697a9e48..777b49b1aa79 100644
--- a/www-apps/dokuwiki/metadata.xml
+++ b/www-apps/dokuwiki/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>web-apps</herd>
+ <maintainer>
+ <email>jmbsvicetto@gentoo.org</email>
+ <name>Jorge Manuel B. S. Vicetto</name>
+ </maintainer>
<longdescription lang="en">
DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at
creating documentation of any kind. It is targeted at developer teams,