summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2014-01-21 19:49:03 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2014-01-21 19:49:03 +0000
commita77fa352f1932626fc9f92eafdaf525b4e0ea927 (patch)
tree344811988c0a4fc891cbdbbcee3f7e0381eb037f /www-apps/cgit
parentVersion bump (diff)
downloadgentoo-2-a77fa352f1932626fc9f92eafdaf525b4e0ea927.tar.gz
gentoo-2-a77fa352f1932626fc9f92eafdaf525b4e0ea927.tar.bz2
gentoo-2-a77fa352f1932626fc9f92eafdaf525b4e0ea927.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'www-apps/cgit')
-rw-r--r--www-apps/cgit/ChangeLog10
-rw-r--r--www-apps/cgit/cgit-0.10.ebuild94
-rw-r--r--www-apps/cgit/cgit-9999.ebuild50
-rw-r--r--www-apps/cgit/metadata.xml2
4 files changed, 133 insertions, 23 deletions
diff --git a/www-apps/cgit/ChangeLog b/www-apps/cgit/ChangeLog
index 2c3cdd7685df..e6c2f466afb2 100644
--- a/www-apps/cgit/ChangeLog
+++ b/www-apps/cgit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/cgit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/ChangeLog,v 1.18 2013/10/13 10:20:55 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/ChangeLog,v 1.19 2014/01/21 19:49:03 zx2c4 Exp $
+
+*cgit-0.10 (21 Jan 2014)
+
+ 21 Jan 2014; Jason A. Donenfeld <zx2c4@gentoo.org> +cgit-0.10.ebuild,
+ cgit-9999.ebuild, metadata.xml:
+ Version bump.
13 Oct 2013; Tom Wijsman <TomWij@gentoo.org> metadata.xml:
Updated Nikoli's e-mail address for easier automatic assignment.
diff --git a/www-apps/cgit/cgit-0.10.ebuild b/www-apps/cgit/cgit-0.10.ebuild
new file mode 100644
index 000000000000..81f38d94d10b
--- /dev/null
+++ b/www-apps/cgit/cgit-0.10.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-0.10.ebuild,v 1.1 2014/01/21 19:49:03 zx2c4 Exp $
+
+EAPI="4"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+inherit webapp eutils multilib user
+
+[[ -z "${CGIT_CACHEDIR}" ]] && CGIT_CACHEDIR="/var/cache/${PN}/"
+
+GIT_V="1.8.5"
+
+DESCRIPTION="a fast web-interface for git repositories"
+HOMEPAGE="http://git.zx2c4.com/cgit/about"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_V}.tar.bz2
+ http://git.zx2c4.com/cgit/snapshot/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +highlight +lua +jit"
+
+RDEPEND="
+ dev-vcs/git
+ sys-libs/zlib
+ dev-libs/openssl
+ virtual/httpd-cgi
+ highlight? ( || ( dev-python/pygments app-text/highlight ) )
+ lua? ( jit? ( dev-lang/luajit ) !jit? ( dev-lang/lua ) )
+"
+# ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
+DEPEND="${RDEPEND}
+ !<www-apps/cgit-0.8.3.3
+ doc? ( app-text/docbook-xsl-stylesheets
+ >=app-text/asciidoc-8.5.1 )
+"
+
+pkg_setup() {
+ webapp_pkg_setup
+ enewuser "${PN}"
+}
+
+src_prepare() {
+ rmdir git || die
+ mv "${WORKDIR}"/git-"${GIT_V}" git || die
+
+ echo "prefix = ${EPREFIX}/usr" >> cgit.conf
+ echo "libdir = ${EPREFIX}/usr/$(get_libdir)" >> cgit.conf
+ echo "CGIT_SCRIPT_PATH = ${MY_CGIBINDIR}" >> cgit.conf
+ echo "CGIT_DATA_PATH = ${MY_HTDOCSDIR}" >> cgit.conf
+ echo "CACHE_ROOT = ${CGIT_CACHEDIR}" >> cgit.conf
+ echo "DESTDIR = ${D}" >> cgit.conf
+ if use lua; then
+ if use jit; then
+ echo "LUA_IMPLEMENTATION = JIT" >> cgit.conf
+ else
+ echo "LUA_IMPLEMENTATION = VANILLA" >> cgit.conf
+ fi
+ else
+ echo "NO_LUA = 1" >> cgit.conf
+ fi
+}
+
+src_compile() {
+ emake
+ use doc && emake doc-man
+}
+
+src_install() {
+ webapp_src_preinst
+
+ emake install
+
+ insinto /etc
+ doins "${FILESDIR}"/cgitrc
+
+ dodoc README
+ use doc && doman cgitrc.5
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+
+ keepdir "${CGIT_CACHEDIR}"
+ fowners ${PN}:${PN} "${CGIT_CACHEDIR}"
+ fperms 700 "${CGIT_CACHEDIR}"
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ ewarn "If you intend to run cgit using web server's user"
+ ewarn "you should change ${CGIT_CACHEDIR} permissions."
+}
diff --git a/www-apps/cgit/cgit-9999.ebuild b/www-apps/cgit/cgit-9999.ebuild
index cb29340e3ca7..5e2ca3bff908 100644
--- a/www-apps/cgit/cgit-9999.ebuild
+++ b/www-apps/cgit/cgit-9999.ebuild
@@ -1,33 +1,34 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-9999.ebuild,v 1.6 2012/11/15 01:14:11 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-9999.ebuild,v 1.7 2014/01/21 19:49:03 zx2c4 Exp $
EAPI="4"
WEBAPP_MANUAL_SLOT="yes"
-inherit webapp multilib user git-2
+inherit webapp eutils multilib user git-2
[[ -z "${CGIT_CACHEDIR}" ]] && CGIT_CACHEDIR="/var/cache/${PN}/"
-GIT_V="1.7.4"
+GIT_V="1.8.5"
DESCRIPTION="a fast web-interface for git repositories"
-HOMEPAGE="http://git.zx2c4.com/cgit/about/"
-SRC_URI="mirror://kernel/software/scm/git/git-${GIT_V}.tar.bz2"
-EGIT_REPO_URI="http://git.zx2c4.com/cgit"
+HOMEPAGE="http://git.zx2c4.com/cgit/about"
+SRC_URI=""
+EGIT_REPO_URI="git://git.zx2c4.com/cgit"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="doc highlight"
+IUSE="doc +highlight +lua +jit"
RDEPEND="
dev-vcs/git
sys-libs/zlib
dev-libs/openssl
virtual/httpd-cgi
- highlight? ( app-text/highlight )
+ highlight? ( || ( dev-python/pygments app-text/highlight ) )
+ lua? ( jit? ( dev-lang/luajit ) !jit? ( dev-lang/lua ) )
"
# ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
DEPEND="${RDEPEND}
@@ -42,12 +43,24 @@ pkg_setup() {
}
src_prepare() {
- rmdir git || die
- mv "${WORKDIR}"/git-"${GIT_V}" git || die
-
- sed -i \
- -e "/^CACHE_ROOT =/s:/var/cache/cgit:${CGIT_CACHEDIR}:" \
- Makefile || die
+ git submodule init || die
+ git submodule update || die
+
+ echo "prefix = ${EPREFIX}/usr" >> cgit.conf
+ echo "libdir = ${EPREFIX}/usr/$(get_libdir)" >> cgit.conf
+ echo "CGIT_SCRIPT_PATH = ${MY_CGIBINDIR}" >> cgit.conf
+ echo "CGIT_DATA_PATH = ${MY_HTDOCSDIR}" >> cgit.conf
+ echo "CACHE_ROOT = ${CGIT_CACHEDIR}" >> cgit.conf
+ echo "DESTDIR = ${D}" >> cgit.conf
+ if use lua; then
+ if use jit; then
+ echo "LUA_IMPLEMENTATION = JIT" >> cgit.conf
+ else
+ echo "LUA_IMPLEMENTATION = VANILLA" >> cgit.conf
+ fi
+ else
+ echo "NO_LUA = 1" >> cgit.conf
+ fi
}
src_compile() {
@@ -58,12 +71,7 @@ src_compile() {
src_install() {
webapp_src_preinst
- emake \
- prefix="${EPREFIX}"/usr \
- libdir="${EPREFIX}"/usr/$(get_libdir) \
- CGIT_SCRIPT_PATH="${MY_CGIBINDIR}" \
- CGIT_DATA_PATH="${MY_HTDOCSDIR}" \
- DESTDIR="${D}" install
+ emake install
insinto /etc
doins "${FILESDIR}"/cgitrc
diff --git a/www-apps/cgit/metadata.xml b/www-apps/cgit/metadata.xml
index 82ae1fb6196a..28667272885c 100644
--- a/www-apps/cgit/metadata.xml
+++ b/www-apps/cgit/metadata.xml
@@ -15,6 +15,8 @@
</longdescription>
<use>
<flag name="highlight">Enable source code highlighting</flag>
+ <flag name="lua">Enable support for Lua scripting</flag>
+ <flag name="jit">If the lua flag is enabled, jit uses LuaJIT instead of vanilla Lua</flag>
</use>
</pkgmetadata>