summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-08-29 09:34:27 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-08-29 09:34:27 +0000
commitead87af70bb22d9d2f0a656a44035eaeadbf94d8 (patch)
tree682f15c2a061679e42f7a33ab790886c1394ad4e /www-apps/bugzilla/bugzilla-2.22.7.ebuild
parentVersion bump. (diff)
downloadgentoo-2-ead87af70bb22d9d2f0a656a44035eaeadbf94d8.tar.gz
gentoo-2-ead87af70bb22d9d2f0a656a44035eaeadbf94d8.tar.bz2
gentoo-2-ead87af70bb22d9d2f0a656a44035eaeadbf94d8.zip
New minor version bump to 3.4.1. Bump 3.2 series to 3.2.4 and remove old.
Bump old 3.0 and 3.22 to their respective latest versions with simple renaming of the current stable version. Note: this is non-maintainer commit. (Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'www-apps/bugzilla/bugzilla-2.22.7.ebuild')
-rw-r--r--www-apps/bugzilla/bugzilla-2.22.7.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/www-apps/bugzilla/bugzilla-2.22.7.ebuild b/www-apps/bugzilla/bugzilla-2.22.7.ebuild
new file mode 100644
index 000000000000..0d8625281e01
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-2.22.7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.22.7.ebuild,v 1.1 2009/08/29 09:34:27 scarabeus Exp $
+
+inherit webapp depend.apache versionator eutils
+
+MY_PB=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="extras graphviz mysql postgres"
+
+RDEPEND="
+ virtual/httpd-cgi
+ >=dev-lang/perl-5.6.1
+
+ >=dev-perl/AppConfig-1.52
+ >=dev-perl/DBI-1.38
+ >=dev-perl/MailTools-1.67
+ dev-perl/MIME-tools
+ >=dev-perl/Template-Toolkit-2.13
+ >=virtual/perl-Text-Tabs+Wrap-2001.0131
+ >=dev-perl/TimeDate-1.16
+ >=virtual/perl-CGI-2.93
+ >=virtual/perl-File-Spec-0.84
+ virtual/perl-File-Temp
+ >=virtual/perl-MIME-Base64-3.01
+ virtual/perl-Storable
+
+ extras? (
+ >=dev-perl/Chart-2.3
+ >=dev-perl/GD-1.20
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ dev-perl/HTML-Scrubber
+ >=dev-perl/PatchReader-0.9.4
+ dev-perl/perl-ldap
+ dev-perl/Template-GD
+ dev-perl/XML-Twig
+ dev-util/patchutils
+ )
+
+ graphviz? ( media-gfx/graphviz )
+ mysql? ( >=dev-perl/DBD-mysql-3.0007 )
+ postgres? ( >=dev-perl/DBD-Pg-1.45 )
+"
+
+need_apache2
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ newins "${FILESDIR}"/${MY_PB}/apache.htaccess .htaccess
+ for f in bugzilla.cron.daily bugzilla.cron.tab; do
+ doins "${FILESDIR}"/${MY_PB}/${f}
+ done
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+}