summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-01-10 15:14:13 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-01-10 15:14:13 +0000
commite0a873cc5f663b3e2d74a9188baf6eb1d87ef3e8 (patch)
tree6ad31c9130a484ca91e6bf5ae2e9d9677a3806e5 /www-apache
parentamd64/x86 stable, bug #253054 (diff)
downloadgentoo-2-e0a873cc5f663b3e2d74a9188baf6eb1d87ef3e8.tar.gz
gentoo-2-e0a873cc5f663b3e2d74a9188baf6eb1d87ef3e8.tar.bz2
gentoo-2-e0a873cc5f663b3e2d74a9188baf6eb1d87ef3e8.zip
Version bump.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-tuxonice x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_caucho/ChangeLog9
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.1.8.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index cada7d4421d2..6f4ef17e8fb2 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_caucho
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.41 2008/06/10 21:04:55 nelchael Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.42 2009/01/10 15:14:13 nelchael Exp $
+
+*mod_caucho-3.1.8 (10 Jan 2009)
+
+ 10 Jan 2009; <nelchael@gentoo.org> +mod_caucho-3.1.8.ebuild:
+ Version bump.
*mod_caucho-3.0.26 (10 Jun 2008)
diff --git a/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild b/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild
new file mode 100644
index 000000000000..c35714ba7243
--- /dev/null
+++ b/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild,v 1.1 2009/01/10 15:14:13 nelchael Exp $
+
+inherit eutils apache-module autotools
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="mod_caucho connects Resin and Apache2."
+HOMEPAGE="http://www.caucho.com/"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
+ mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/resin-${PV}"
+
+# See apache-module.eclass for more information.
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="CAUCHO"
+
+need_apache2
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd "${S}"
+
+ for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
+ epatch "${i}"
+ done
+ epatch "${WORKDIR}/${PV}/resin-${PV}-configure.ac.patch"
+
+ eautoreconf
+ chmod 755 ./configure
+
+}
+
+src_compile() {
+
+ econf --with-apxs=${APXS} || die "econf failed"
+ emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
+
+}
+
+src_install() {
+
+ cd "${S}/modules/c/src/apache2"
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf" \
+ || die "internal ebuild error: ${APACHE2_MOD_CONF}.conf not found."
+
+}