summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-03-15 14:36:08 +0000
committerAlex Legler <a3li@gentoo.org>2009-03-15 14:36:08 +0000
commit8c13933ce7a9d2d65427eea0794e57192f4493dc (patch)
tree5ee6c8ec6509b50ee89228d7b75aaffbba74f773 /www-apache
parentAutomatic-merge: merge updates for 4.2.1 from kde-testing. (diff)
downloadgentoo-2-8c13933ce7a9d2d65427eea0794e57192f4493dc.tar.gz
gentoo-2-8c13933ce7a9d2d65427eea0794e57192f4493dc.tar.bz2
gentoo-2-8c13933ce7a9d2d65427eea0794e57192f4493dc.zip
Version bump
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/ChangeLog10
-rw-r--r--www-apache/passenger/files/2.1.2-gentoo.patch44
-rw-r--r--www-apache/passenger/passenger-2.1.2.ebuild59
3 files changed, 111 insertions, 2 deletions
diff --git a/www-apache/passenger/ChangeLog b/www-apache/passenger/ChangeLog
index e9fa8868be74..5f8e55d6494f 100644
--- a/www-apache/passenger/ChangeLog
+++ b/www-apache/passenger/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/passenger
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.6 2008/12/27 21:39:21 caleb Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.7 2009/03/15 14:36:08 a3li Exp $
+
+*passenger-2.1.2 (15 Mar 2009)
+
+ 15 Mar 2009; Alex Legler <a3li@gentoo.org> +files/2.1.2-gentoo.patch,
+ +passenger-2.1.2.ebuild:
+ Version bump
*passenger-2.0.6 (27 Dec 2008)
diff --git a/www-apache/passenger/files/2.1.2-gentoo.patch b/www-apache/passenger/files/2.1.2-gentoo.patch
new file mode 100644
index 000000000000..deec17a62620
--- /dev/null
+++ b/www-apache/passenger/files/2.1.2-gentoo.patch
@@ -0,0 +1,44 @@
+--- Rakefile.orig 2009-03-15 15:15:44.000000000 +0100
++++ Rakefile 2009-03-15 15:24:51.000000000 +0100
+@@ -39,12 +39,8 @@
+ CXX = "g++"
+ LIBEXT = PlatformInfo.library_extension
+ # _GLIBCPP__PTHREADS is for fixing Boost compilation on OpenBSD.
+-if OPTIMIZE
+- OPTIMIZATION_FLAGS = "#{PlatformInfo.debugging_cflags} -O2 -DBOOST_DISABLE_ASSERTS"
+-else
+- OPTIMIZATION_FLAGS = "#{PlatformInfo.debugging_cflags} -DPASSENGER_DEBUG -DBOOST_DISABLE_ASSERTS"
+-end
+-CXXFLAGS = "-Wall #{OPTIMIZATION_FLAGS}"
++OPTIMIZATION_FLAGS = "#{ENV['CXXFLAGS']} -DNDEBUG"
++CXXFLAGS = "#{OPTIMIZATION_FLAGS} -Wall"
+ EXTRA_LDFLAGS = ""
+
+ #### Default tasks
+@@ -540,15 +536,15 @@
+ task :fakeroot => [:apache2, :native_support, :doc] do
+ require 'rbconfig'
+ include Config
+- fakeroot = "pkg/fakeroot"
++ fakeroot = ENV['DISTDIR']
+
+ # We don't use CONFIG['archdir'] and the like because we want
+ # the files to be installed to /usr, and the Ruby interpreter
+ # on the packaging machine might be in /usr/local.
+- libdir = "#{fakeroot}/usr/lib/ruby/#{CONFIG['ruby_version']}"
++ libdir = "#{fakeroot}/#{CONFIG['sitedir']}/#{CONFIG['ruby_version']}"
+ extdir = "#{libdir}/#{CONFIG['arch']}"
+ bindir = "#{fakeroot}/usr/bin"
+- docdir = "#{fakeroot}/usr/share/doc/phusion_passenger"
++ docdir = "#{fakeroot}/usr/share/doc/passenger-#{PACKAGE_VERSION}"
+ libexecdir = "#{fakeroot}/usr/lib/phusion_passenger"
+
+ sh "rm -rf #{fakeroot}"
+@@ -567,7 +563,6 @@
+ sh "cp bin/* #{bindir}/"
+
+ sh "mkdir -p #{libexecdir}"
+- sh "cp ext/apache2/mod_passenger.so #{libexecdir}/"
+ sh "mv #{fakeroot}/usr/bin/passenger-spawn-server #{libexecdir}/"
+ sh "cp ext/apache2/ApplicationPoolServerExecutable #{libexecdir}/"
+
diff --git a/www-apache/passenger/passenger-2.1.2.ebuild b/www-apache/passenger/passenger-2.1.2.ebuild
new file mode 100644
index 000000000000..86be0398a339
--- /dev/null
+++ b/www-apache/passenger/passenger-2.1.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-2.1.2.ebuild,v 1.1 2009/03/15 14:36:08 a3li Exp $
+
+inherit apache-module flag-o-matic ruby
+
+DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
+HOMEPAGE="http://modrails.com/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+CDEPEND=">=dev-lang/ruby-1.8.5
+ >=dev-ruby/rubygems-0.9.0
+ >=dev-ruby/rake-0.8.1
+ >=dev-ruby/fastthread-1.0.1
+ >=dev-ruby/rspec-1.1.2
+ >=dev-ruby/rails-1.2.0"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
+APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
+APACHE2_MOD_DEFINE="PASSENGER"
+
+need_apache2_2
+
+pkg_setup() {
+ use debug && append-flags -DPASSENGER_DEBUG
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/2.1.2-gentoo.patch
+ rm -f bin/passenger-install-apache2-module
+ sed -i -e '473s/, :doc//' Rakefile
+}
+
+src_compile() {
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ rake apache2 native_support || die "rake failed"
+
+ if use doc; then
+ rake doc || die "rake doc failed"
+ fi
+}
+
+src_install() {
+ DISTDIR="${D}" \
+ rake fakeroot || die "rake failed"
+
+ apache-module_src_install
+}