summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-12-06 01:01:52 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-12-06 01:01:52 +0000
commit8524624dda0c17db1eac587d9425f1caa3058300 (patch)
treee626a4686add98a05a55a664473afe0e95b27c6c /www-apache
parentRemove app-misc/twin for multiple bugs. (diff)
downloadgentoo-2-8524624dda0c17db1eac587d9425f1caa3058300.tar.gz
gentoo-2-8524624dda0c17db1eac587d9425f1caa3058300.tar.bz2
gentoo-2-8524624dda0c17db1eac587d9425f1caa3058300.zip
Version bump. Thanks to Mike Weissman <mike@weisso.com>. Fixes bug #245597.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 i686)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_jk/ChangeLog8
-rw-r--r--www-apache/mod_jk/mod_jk-1.2.27.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/www-apache/mod_jk/ChangeLog b/www-apache/mod_jk/ChangeLog
index a4f8cf96f7e4..c7dd1f28bba6 100644
--- a/www-apache/mod_jk/ChangeLog
+++ b/www-apache/mod_jk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_jk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.51 2008/12/06 00:22:52 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.52 2008/12/06 01:01:52 betelgeuse Exp $
+
+*mod_jk-1.2.27 (06 Dec 2008)
+
+ 06 Dec 2008; Petteri Räty <betelgeuse@gentoo.org> +mod_jk-1.2.27.ebuild:
+ Version bump. Thanks to Mike Weissman <mike@weisso.com>. Fixes bug
+ #245597.
06 Dec 2008; Petteri Räty <betelgeuse@gentoo.org> metadata.xml:
Remove wltjr as he retired ages ago.
diff --git a/www-apache/mod_jk/mod_jk-1.2.27.ebuild b/www-apache/mod_jk/mod_jk-1.2.27.ebuild
new file mode 100644
index 000000000000..75636a14f39b
--- /dev/null
+++ b/www-apache/mod_jk/mod_jk-1.2.27.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.27.ebuild,v 1.1 2008/12/06 01:01:52 betelgeuse Exp $
+
+inherit apache-module java-pkg-2
+
+MY_P="tomcat-connectors-${PV}-src"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="JK module for connecting Tomcat and Apache using the ajp13 protocol."
+HOMEPAGE="http://tomcat.apache.org/connectors-doc/"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/jk/source/jk-${PV}/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/native"
+
+APACHE2_MOD_FILE="${S}/apache-2.0/${PN}.so"
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="JK"
+
+DOCFILES="CHANGES"
+CONF_DIR="${WORKDIR}/${MY_P}/conf"
+need_apache
+
+DEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ econf \
+ --with-apxs=${APXS} \
+ --with-apr-config=/usr/bin/apr-config \
+ || die "econf failed"
+ emake LIBTOOL="/bin/sh $(pwd)/libtool --silent" || die "emake failed"
+}
+
+src_install() {
+ # install the workers.properties file
+ insinto "${APACHE_CONFDIR}"
+ doins "${CONF_DIR}/workers.properties"
+ doins "${CONF_DIR}/uriworkermap.properties"
+
+ # call the nifty default src_install :-)
+ apache-module_src_install
+}
+
+pkg_postinst() {
+ elog "Tomcat is not a dependency of mod_jk any longer, if you intend"
+ elog "to use it with Tomcat, you have to merge www-servers/tomcat on"
+ elog "your own."
+
+ elog "Advanced Directives and Options can be found at: "
+ elog "http://tomcat.apache.org/connectors-doc/reference/workers.html"
+}