summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-06 21:02:11 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-06 21:02:11 +0000
commit658a3a09759edd604cb20c3eec5d7f3706a565d0 (patch)
tree16ce98a4d5c3ff31f7a441e0b52a6d4b42779f40 /www-apache
parentFix depends wrt #204546. Call xmkmf without -a since it's not needed. Drop fa... (diff)
downloadgentoo-2-658a3a09759edd604cb20c3eec5d7f3706a565d0.tar.gz
gentoo-2-658a3a09759edd604cb20c3eec5d7f3706a565d0.tar.bz2
gentoo-2-658a3a09759edd604cb20c3eec5d7f3706a565d0.zip
fix #182235, #199183
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_perl/ChangeLog10
-rw-r--r--www-apache/mod_perl/files/2.0.3/75_mod_perl.conf100
-rw-r--r--www-apache/mod_perl/files/digest-mod_perl-2.0.3-r23
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.3-r2.ebuild137
4 files changed, 194 insertions, 56 deletions
diff --git a/www-apache/mod_perl/ChangeLog b/www-apache/mod_perl/ChangeLog
index ed6a0cd9d27d..fb1d5346a546 100644
--- a/www-apache/mod_perl/ChangeLog
+++ b/www-apache/mod_perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_perl
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/ChangeLog,v 1.52 2007/06/13 12:49:28 chtekk Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/ChangeLog,v 1.53 2008/01/06 21:02:10 hollow Exp $
+
+*mod_perl-2.0.3-r2 (06 Jan 2008)
+
+ 06 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
+ files/2.0.3/75_mod_perl.conf, +mod_perl-2.0.3-r2.ebuild:
+ fix #182235, #199183
13 Jun 2007; Luca Longinotti <chtekk@gentoo.org>
-files/1.29/75_mod_perl.conf, -files/1.30/75_mod_perl.conf,
diff --git a/www-apache/mod_perl/files/2.0.3/75_mod_perl.conf b/www-apache/mod_perl/files/2.0.3/75_mod_perl.conf
index 96455b51e209..470bc45345ab 100644
--- a/www-apache/mod_perl/files/2.0.3/75_mod_perl.conf
+++ b/www-apache/mod_perl/files/2.0.3/75_mod_perl.conf
@@ -1,56 +1,48 @@
<IfDefine PERL>
- <IfModule !mod_perl.c>
- LoadModule perl_module modules/mod_perl.so
- </IfModule>
+LoadModule perl_module modules/mod_perl.so
+
+#PerlTrace all
+PerlRequire "/etc/apache2/modules.d/apache2-mod_perl-startup.pl"
+PerlModule ModPerl::Registry
+
+# Provide two aliases to the same cgi-bin directory, to see the effects of the
+# 2 different mod_perl modes for Apache2::Registry Mode
+Alias /perl/ /var/www/localhost/perl/
+# for Apache2::Perlrun Mode
+Alias /cgi-perl/ /var/www/localhost/perl/
+
+<Location /perl-status>
+ SetHandler perl-script
+ PerlResponseHandler Apache2::Status
+ Order deny,allow
+ Deny from all
+ Allow from 127.0.0.1
+</Location>
+
+<Directory /home/*/public_html/perl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::PerlRun
+ Options -Indexes ExecCGI
+ PerlOptions +ParseHeaders
+</Directory>
+
+# set Apache::Registry Mode for /perl Alias
+<Location /perl/*.pl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::Registry
+ Options -Indexes ExecCGI
+ PerlSendHeader On
+ Order allow,deny
+ Allow from all
+</Location>
+
+# set Apache::PerlRun Mode for /cgi-perl Alias
+<Location /cgi-perl/*.pl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::PerlRun
+ Options -Indexes ExecCGI
+ PerlSendHeader On
+ Order allow,deny
+ Allow from all
+</Location>
</IfDefine>
-
-<IfModule mod_perl.c>
- #PerlTrace all
- PerlRequire "/etc/apache2/modules.d/apache2-mod_perl-startup.pl"
-
- #Provide two aliases to the same cgi-bin directory,
- #to see the effects of the 2 different mod_perl modes
- #for Apache2::Registry Mode
- Alias /perl/ /var/www/localhost/perl/
- #for Apache2::Perlrun Mode
- Alias /cgi-perl/ /var/www/localhost/perl/
-
- <IfModule mod_access.c>
- <Location /perl-status>
- SetHandler perl-script
- PerlResponseHandler Apache2::Status
- Order deny,allow
- Deny from all
- Allow from 127.0.0.1
- </Location>
- </IfModule>
-
- <Directory /home/*/public_html/perl>
- SetHandler perl-script
- PerlResponseHandler ModPerl::PerlRun
- Options -Indexes ExecCGI
- PerlOptions +ParseHeaders
- </Directory>
-
- PerlModule ModPerl::Registry
- #set Apache::Registry Mode for /perl Alias
- # To set subdirectories to use perl set the following
- # and comment the orignial:
- # <Location ~ "^/perl/.*\.pl$">
- <Location "^/perl/*.pl>
- SetHandler perl-script
- PerlResponseHandler ModPerl::Registry
- Options -Indexes ExecCGI
- PerlSendHeader On
- </Location>
-
- #set Apache::PerlRun Mode for /cgi-perl Alias
- <Location /cgi-perl/*.pl>
- SetHandler perl-script
- PerlResponseHandler ModPerl::PerlRun
- Options -Indexes ExecCGI
- PerlSendHeader On
- </Location>
-
-</ifModule>
-
diff --git a/www-apache/mod_perl/files/digest-mod_perl-2.0.3-r2 b/www-apache/mod_perl/files/digest-mod_perl-2.0.3-r2
new file mode 100644
index 000000000000..3678f6181c60
--- /dev/null
+++ b/www-apache/mod_perl/files/digest-mod_perl-2.0.3-r2
@@ -0,0 +1,3 @@
+MD5 b40e2adf67c6be15a0041af1c67b6997 mod_perl-2.0.3.tar.gz 3714974
+RMD160 29662a131c1bef6e4adc551d4467d12931a4d919 mod_perl-2.0.3.tar.gz 3714974
+SHA256 df257f233ed6a5c9f8589d6e059563f816bf417f164fc3364a2a434de13045f2 mod_perl-2.0.3.tar.gz 3714974
diff --git a/www-apache/mod_perl/mod_perl-2.0.3-r2.ebuild b/www-apache/mod_perl/mod_perl-2.0.3-r2.ebuild
new file mode 100644
index 000000000000..c367f6829c1d
--- /dev/null
+++ b/www-apache/mod_perl/mod_perl-2.0.3-r2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/mod_perl-2.0.3-r2.ebuild,v 1.1 2008/01/06 21:02:10 hollow Exp $
+
+inherit apache-module perl-module eutils multilib
+
+DESCRIPTION="An embedded Perl interpreter for Apache2"
+SRC_URI="mirror://cpan/authors/id/P/PG/PGOLLUCCI/${P}.tar.gz"
+HOMEPAGE="http://perl.apache.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+SLOT="1"
+
+# see bug 30087 for why sudo is in here
+DEPEND=">=dev-perl/Apache-Test-1.27
+ >=virtual/perl-CGI-3.08
+ >=dev-perl/Compress-Zlib-1.09
+ app-admin/sudo"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_FILE="${S}/src/modules/perl/mod_perl.so"
+APACHE2_MOD_CONF="${PV}/75_${PN}"
+APACHE2_MOD_DEFINE="PERL"
+
+DOCFILES="Changes INSTALL LICENSE README STATUS"
+
+need_apache2
+
+pkg_setup() {
+ if built_with_use dev-lang/perl ithreads; then
+ APACHE2_SAFE_MPMS="event worker"
+ else
+ APACHE2_SAFE_MPMS="prefork itk peruser"
+ fi
+ apache-module_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # I am not entirely happy with this solution, but here's what's
+ # going on here if someone wants to take a stab at another
+ # approach. When userpriv compilation is off, then the make
+ # process drops to user "nobody" to run the test servers. This
+ # server is closed, and then the socket is rebound using
+ # SO_REUSEADDR. If the same user does this, there is no problem,
+ # and the socket may be rebound immediately. If a different user
+ # (yes, in my testing, even root) attempts to rebind, it fails.
+ # Since the "is the socket available yet" code and the
+ # second-batch bind call both run as root, this will fail.
+
+ # The upstream settings on my test machine cause the second batch
+ # of tests to fail, believing the socket to still be in use. I
+ # tried patching various parts to make them run as the user
+ # specified in $config->{vars}{user} using getpwnam, but found
+ # this patch to be fairly intrusive, because the userid must be
+ # restored and the patch must be applied to multiple places.
+
+ # For now, we will simply extend the timeout in hopes that in the
+ # non-userpriv case, the socket will clear from the kernel tables
+ # normally, and the tests will proceed.
+
+ # If anybody is still having problems, then commenting out "make
+ # test" below should allow the software to build properly.
+
+ # Robert Coie <rac@gentoo.org> 2003.05.06
+
+ sed -i -e "s/sleep \$_/sleep \$_ << 2/" "${S}"/Apache-Test/lib/Apache/TestServer.pm || die "problem editing TestServer.pm"
+
+ # i wonder if this is the same sandbox issue, but TMPDIR is not
+ # getting through via SetEnv. sneak it through here. Bug 172676
+ epatch "${FILESDIR}"/RegistryCooker.patch
+
+ # rendhalver - this got redone for 2.0.1 and seems to fix the make test problems
+ epatch "${FILESDIR}"/mod_perl-2.0.1-sneak-tmpdir.patch
+}
+
+src_compile() {
+ perl Makefile.PL \
+ PREFIX="${D}"/usr \
+ MP_TRACE=1 \
+ MP_DEBUG=1 \
+ MP_USE_DSO=1 \
+ MP_APXS=${APXS2} \
+ INSTALLDIRS=vendor </dev/null || die
+
+ # reported that parallel make is broken in bug 30257
+ emake -j1 || die
+}
+
+src_test() {
+ # make test notes whether it is running as root, and drops
+ # privileges all the way to "nobody" if so, so we must adjust
+ # write permissions accordingly in this case.
+
+ # IF YOU SUDO TO EMERGE AND HAVE !env_reset set testing will fail!
+ if [[ "$(id -u)" == "0" ]]; then
+ chown nobody:nobody "${WORKDIR}"
+ chown nobody:nobody "${T}"
+ fi
+
+ # this does not || die because of bug 21325. kudos to smark for
+ # the idea of setting HOME.
+ TMPDIR="${T}" HOME="${T}/" make test
+}
+
+src_install() {
+ apache-module_src_install
+
+ dodir "${APACHE2_MODULESDIR}"
+ make install \
+ MODPERL_AP_LIBEXECDIR="${D}${APACHE2_MODULESDIR}" \
+ MODPERL_AP_INCLUDEDIR="${D}/usr/include/apache2" \
+ MP_INST_APACHE2=1 \
+ INSTALLDIRS=vendor || die
+
+ # rendhalver - fix the perllocal.pod that gets installed
+ # it seems to me that this has been getting installed for ages
+ fixlocalpod
+
+ insinto "${APACHE2_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/${PV}/apache2-mod_perl-startup.pl
+ cp -pPR docs "${D}"/usr/share/doc/${PF}
+ cp -pPR todo "${D}"/usr/share/doc/${PF}
+
+ # this is an attempt to get @INC in line with /usr/bin/perl.
+ # there is blib garbage in the mainstream one that can only be
+ # useful during internal testing, so we wait until here and then
+ # just go with a clean slate. should be much easier to see what's
+ # happening and revert if problematic.
+ for FILE in $(grep -lr portage "${D}"/*|grep -v ".so"); do
+ sed -i -e "s:${D}:/:g" ${FILE}
+ done
+}