summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-10-18 15:25:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-10-18 15:25:02 +0000
commit50c99c29dcd9db2fe3b0735a773778650c3c510f (patch)
treec0c3631c59b611b3c1d6f4076efacab09cfe6348 /www-apache
parentChanged SRC_URI of the astaro patch to mirror://gentoo/. (Manifest recommit) (diff)
downloadgentoo-2-50c99c29dcd9db2fe3b0735a773778650c3c510f.tar.gz
gentoo-2-50c99c29dcd9db2fe3b0735a773778650c3c510f.tar.bz2
gentoo-2-50c99c29dcd9db2fe3b0735a773778650c3c510f.zip
*** empty log message ***
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_lisp/ChangeLog6
-rw-r--r--www-apache/mod_lisp/files/README.Gentoo8
-rw-r--r--www-apache/mod_lisp/files/Readme.Gentoo5
-rw-r--r--www-apache/mod_lisp/files/apache.conf24
-rw-r--r--www-apache/mod_lisp/mod_lisp-2.33.ebuild7
5 files changed, 41 insertions, 9 deletions
diff --git a/www-apache/mod_lisp/ChangeLog b/www-apache/mod_lisp/ChangeLog
index da1d4b874cc1..21a15ca9ed82 100644
--- a/www-apache/mod_lisp/ChangeLog
+++ b/www-apache/mod_lisp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_lisp
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_lisp/ChangeLog,v 1.3 2004/10/18 14:35:36 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_lisp/ChangeLog,v 1.4 2004/10/18 15:22:51 mkennedy Exp $
+
+ 18 Oct 2004; <mkennedy@gentoo.org> +files/README.Gentoo,
+ -files/Readme.Gentoo, +files/apache.conf, mod_lisp-2.33.ebuild:
+ Renamed Gentoo README to be conformant; Added basic configuration example.
18 Oct 2004; <mkennedy@gentoo.org> files/Readme.Gentoo:
Corrected formatting and typo in README.Gentoo
diff --git a/www-apache/mod_lisp/files/README.Gentoo b/www-apache/mod_lisp/files/README.Gentoo
new file mode 100644
index 000000000000..6675d8cd2eba
--- /dev/null
+++ b/www-apache/mod_lisp/files/README.Gentoo
@@ -0,0 +1,8 @@
+Go to http://lisp.t2100cdt.kippona.net/lispy/home for a tutorial on
+how to use mod_lisp.
+
+A basic Apache configuration example has been included in this port's
+documentation path.
+
+zul @ gentoo.org
+mkennedy @ gentoo.org
diff --git a/www-apache/mod_lisp/files/Readme.Gentoo b/www-apache/mod_lisp/files/Readme.Gentoo
deleted file mode 100644
index 2d0f75cc2ace..000000000000
--- a/www-apache/mod_lisp/files/Readme.Gentoo
+++ /dev/null
@@ -1,5 +0,0 @@
-Go to http://lisp.t2100cdt.kippona.net/lispy/home for a tutorial on
-how to use mod_lisp.
-
-April 26, 2003
-zul @ gentoo.org
diff --git a/www-apache/mod_lisp/files/apache.conf b/www-apache/mod_lisp/files/apache.conf
new file mode 100644
index 000000000000..5ec8f6e452f1
--- /dev/null
+++ b/www-apache/mod_lisp/files/apache.conf
@@ -0,0 +1,24 @@
+
+# This is an example configuration to get you started.
+
+<IfDefine MODLISP>
+ LoadModule lisp_module extramodules/mod_lisp.so
+</IfDefine>
+
+<IfModule mod_lisp.c>
+ LispServer 127.0.0.1 3000 "server1"
+ AddHandler lisp-handler .lsp
+</IfModule>
+
+# In the Common Lisp implementation, the initialization code
+# corresponding to the above would be:
+#
+# (require :modlisp)
+# (ml:modlisp-start :port 3000)
+#
+# Example requests:
+#
+# http://localhost/debug.lsp
+# http://localhost/fixed.lsp
+
+# Matthew Kennedy <mkennedy@gentoo.org>
diff --git a/www-apache/mod_lisp/mod_lisp-2.33.ebuild b/www-apache/mod_lisp/mod_lisp-2.33.ebuild
index 8c57a5c4c9a3..5d7c1034798f 100644
--- a/www-apache/mod_lisp/mod_lisp-2.33.ebuild
+++ b/www-apache/mod_lisp/mod_lisp-2.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_lisp/mod_lisp-2.33.ebuild,v 1.1 2004/08/15 17:19:08 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_lisp/mod_lisp-2.33.ebuild,v 1.2 2004/10/18 15:22:51 mkennedy Exp $
DESCRIPTION="mod_lisp is an Apache module to easily write web applications in Common Lisp"
HOMEPAGE="http://www.fractalconcept.com/asp/sdataQIceRsMvtN9fDM==/sdataQuvY9x3g$ecX"
@@ -25,6 +25,7 @@ src_compile() {
src_install() {
exeinto /usr/lib/apache-extramodules
doexe *.so
-
- dodoc ${FILESDIR}/Readme.Gentoo
+ dodoc ${FILESDIR}/README.Gentoo
+ docinto examples
+ dodoc ${FILESDIR}/apache.conf
}