summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-13 12:55:40 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-13 12:55:40 +0000
commit10545c7fc4148e56c6a7b70c8dba66ba0e07f06b (patch)
treedc00ee8ca275ec7c45468ad9a4f9ddf00339dde2 /www-apache
parentversion bump (diff)
downloadgentoo-2-10545c7fc4148e56c6a7b70c8dba66ba0e07f06b.tar.gz
gentoo-2-10545c7fc4148e56c6a7b70c8dba66ba0e07f06b.tar.bz2
gentoo-2-10545c7fc4148e56c6a7b70c8dba66ba0e07f06b.zip
Cleanup.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/ChangeLog6
-rw-r--r--www-apache/passenger/passenger-4.0.30.ebuild111
-rw-r--r--www-apache/passenger/passenger-4.0.33.ebuild113
3 files changed, 5 insertions, 225 deletions
diff --git a/www-apache/passenger/ChangeLog b/www-apache/passenger/ChangeLog
index 93f60faaac72..2312339344a3 100644
--- a/www-apache/passenger/ChangeLog
+++ b/www-apache/passenger/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/passenger
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.85 2014/01/29 07:12:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.86 2014/02/13 12:55:40 graaff Exp $
+
+ 13 Feb 2014; Hans de Graaff <graaff@gentoo.org> -passenger-4.0.30.ebuild,
+ -passenger-4.0.33.ebuild:
+ Cleanup.
*passenger-4.0.37 (29 Jan 2014)
diff --git a/www-apache/passenger/passenger-4.0.30.ebuild b/www-apache/passenger/passenger-4.0.30.ebuild
deleted file mode 100644
index 1ae2c3d48288..000000000000
--- a/www-apache/passenger/passenger-4.0.30.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-4.0.30.ebuild,v 1.1 2013/12/31 07:17:09 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20"
-
-inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="http://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/daemon_controller-1.1.0
- >=dev-ruby/rack-1.0.0"
-
-CDEPEND=">=dev-libs/libev-4.11 net-misc/curl[ssl]"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-4.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-need_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-4.0.21-gentoo.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "s/gcc/$(tc-getCC)/" \
- -e "s/g++/$(tc-getCXX)/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/apache2/modules/mod_passenger.so:${APACHE_MODULESDIR}/mod_passenger.so:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- lib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" ext/common/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' lib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version.
- rm -rf ext/libev || die "Unable to remove vendored libev."
-
- # Avoid building documentation to avoid a dependency on mizuho.
- #sed -i -e 's/, :doc//' build/packaging.rb || die
- touch doc/*.html || die
-
- # Use the correct arch-specific lib directory
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' build/packaging.rb || die
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/cplusplus_support.rb || die
-}
-
-all_ruby_compile() {
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- ruby -S rake apache2 || die "rake failed"
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}
-
-pkg_postint() {
- einfo "The apache module is compiled for the currently eselected ruby."
- einfo" If you eselect another ruby you must recompile passenger as well."
-}
diff --git a/www-apache/passenger/passenger-4.0.33.ebuild b/www-apache/passenger/passenger-4.0.33.ebuild
deleted file mode 100644
index ebce2f5641f3..000000000000
--- a/www-apache/passenger/passenger-4.0.33.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-4.0.33.ebuild,v 1.1 2014/01/09 06:44:06 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20"
-
-inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="http://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/daemon_controller-1.1.0
- >=dev-ruby/rack-1.0.0"
-
-CDEPEND=">=dev-libs/libev-4.11 net-misc/curl[ssl]"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-4.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-need_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-4.0.33-gentoo.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "s/gcc/$(tc-getCC)/" \
- -e "s/g++/$(tc-getCXX)/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/apache2/modules/mod_passenger.so:${APACHE_MODULESDIR}/mod_passenger.so:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- lib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" ext/common/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' lib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version.
- rm -rf ext/libev || die "Unable to remove vendored libev."
-
- # Avoid building documentation to avoid a dependency on mizuho.
- #sed -i -e 's/, :doc//' build/packaging.rb || die
- touch doc/*.html || die
-
- # Use the correct arch-specific lib directory
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' build/packaging.rb || die
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/cplusplus_support.rb || die
-}
-
-all_ruby_compile() {
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- ruby -S rake apache2 || die "rake failed"
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}
-
-pkg_postint() {
- einfo "The apache module is compiled for the currently eselected ruby."
- einfo" If you eselect another ruby you must recompile passenger as well."
-}