summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-01-15 19:28:38 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-01-15 19:28:38 +0000
commit0ab13e40f352ec71afe2b9465c07f6411a57c2aa (patch)
tree1fc3cb7592f96c326eb33725a5202b1264a13d73 /www-apache/mod_tcl/mod_tcl-1.0.1.ebuild
parentCleanup. (diff)
downloadgentoo-2-0ab13e40f352ec71afe2b9465c07f6411a57c2aa.tar.gz
gentoo-2-0ab13e40f352ec71afe2b9465c07f6411a57c2aa.tar.bz2
gentoo-2-0ab13e40f352ec71afe2b9465c07f6411a57c2aa.zip
Cleanup.
(Portage version: 2.1.2_rc4-r8)
Diffstat (limited to 'www-apache/mod_tcl/mod_tcl-1.0.1.ebuild')
-rw-r--r--www-apache/mod_tcl/mod_tcl-1.0.1.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild b/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild
index ddd3b2fca51d..26e8c6b6eeaa 100644
--- a/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild
+++ b/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild,v 1.3 2006/10/21 06:31:54 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild,v 1.4 2007/01/15 19:28:38 chtekk Exp $
-inherit eutils apache-module
+inherit apache-module
-DESCRIPTION="An Apache2 DSO providing an embedded Tcl interpreter"
+KEYWORDS="ppc x86"
+
+DESCRIPTION="An Apache2 module providing an embedded Tcl interpreter."
HOMEPAGE="http://tcl.apache.org/mod_tcl/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
LICENSE="Apache-1.1"
-KEYWORDS="ppc x86"
-IUSE=""
SLOT="0"
+IUSE=""
DEPEND="dev-lang/tcl"
RDEPEND="${DEPEND}"
APXS2_ARGS="-c -Wl,-ltcl -DHAVE_TCL_H ${PN}.c tcl_cmds.c tcl_misc.c"
-APACHE2_MOD_CONF="1.0-r1/27_mod_tcl"
+
+APACHE2_MOD_CONF="27_${PN}"
APACHE2_MOD_DEFINE="TCL"
DOCFILES="AUTHORS INSTALL NEWS README test_script.tm"
@@ -25,6 +26,6 @@ DOCFILES="AUTHORS INSTALL NEWS README test_script.tm"
need_apache2
src_compile() {
- mv tcl_core.c ${PN}.c
+ mv -f "tcl_core.c" "${PN}.c"
apache2_src_compile
}