summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-06-03 14:54:05 +0000
committerChristian Heim <phreak@gentoo.org>2007-06-03 14:54:05 +0000
commitaff96ddf718fe73db995860471424cdf780f286d (patch)
tree76b4a11ce5829760e0520448fea4fe5e1369808c /www-apache/mod_suphp
parentInitial import of ebuild for eselect-vdr, solving Bug #145573. (diff)
downloadgentoo-2-aff96ddf718fe73db995860471424cdf780f286d.tar.gz
gentoo-2-aff96ddf718fe73db995860471424cdf780f286d.tar.bz2
gentoo-2-aff96ddf718fe73db995860471424cdf780f286d.zip
Fix compilation against >=sys-devel/libtool-1.5.23b, thanks to Chris Ripp <chris at ripp.net> in #178648.
(Portage version: 2.1.2.9)
Diffstat (limited to 'www-apache/mod_suphp')
-rw-r--r--www-apache/mod_suphp/ChangeLog9
-rw-r--r--www-apache/mod_suphp/files/digest-mod_suphp-0.6.2-r13
-rw-r--r--www-apache/mod_suphp/mod_suphp-0.6.2-r1.ebuild114
3 files changed, 125 insertions, 1 deletions
diff --git a/www-apache/mod_suphp/ChangeLog b/www-apache/mod_suphp/ChangeLog
index 6539ca29c51c..57360b837103 100644
--- a/www-apache/mod_suphp/ChangeLog
+++ b/www-apache/mod_suphp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/mod_suphp
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_suphp/ChangeLog,v 1.12 2007/01/15 19:20:06 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_suphp/ChangeLog,v 1.13 2007/06/03 14:54:05 phreak Exp $
+
+*mod_suphp-0.6.2-r1 (03 Jun 2007)
+
+ 03 Jun 2007; Christian Heim <phreak@gentoo.org>
+ +mod_suphp-0.6.2-r1.ebuild:
+ Fix compilation against >=sys-devel/libtool-1.5.23b, thanks to Chris Ripp
+ <chris at ripp.net> in #178648.
15 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
-files/suphp-apache22-compat.patch, -files/suphp-mod_userdir.patch,
diff --git a/www-apache/mod_suphp/files/digest-mod_suphp-0.6.2-r1 b/www-apache/mod_suphp/files/digest-mod_suphp-0.6.2-r1
new file mode 100644
index 000000000000..4090dfae7750
--- /dev/null
+++ b/www-apache/mod_suphp/files/digest-mod_suphp-0.6.2-r1
@@ -0,0 +1,3 @@
+MD5 06ca9e592a5c6dd3dcb9360c958369c1 suphp-0.6.2.tar.gz 372228
+RMD160 6cafc7ef9bb261ee34bed08976a5e4a929f25a73 suphp-0.6.2.tar.gz 372228
+SHA256 1bb9c6af84bb901c8a39611354e49e5bcd79185eb37b02878dc0840facf0ccfc suphp-0.6.2.tar.gz 372228
diff --git a/www-apache/mod_suphp/mod_suphp-0.6.2-r1.ebuild b/www-apache/mod_suphp/mod_suphp-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..0449c5882fe9
--- /dev/null
+++ b/www-apache/mod_suphp/mod_suphp-0.6.2-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_suphp/mod_suphp-0.6.2-r1.ebuild,v 1.1 2007/06/03 14:54:05 phreak Exp $
+
+inherit apache-module autotools
+
+MY_P="${P/mod_/}"
+
+SETIDMODES="mode-force mode-owner mode-paranoid"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="A PHP wrapper for Apache2."
+HOMEPAGE="http://www.suphp.org/"
+SRC_URI="http://www.suphp.org/download/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="checkpath ${SETIDMODES}"
+
+S="${WORKDIR}/${MY_P}"
+
+APXS2_S="${S}/src/apache2"
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="SUPHP"
+
+need_apache2
+
+pkg_setup() {
+ modecnt=0
+ for mode in ${SETIDMODES} ; do
+ if use ${mode} ; then
+ if [[ ${modecnt} -eq 0 ]] ; then
+ SUPHP_SETIDMODE=${mode/mode-}
+ let modecnt++
+ elif [[ ${modecnt} -ge 1 ]] ; then
+ die "You can only select ONE mode in your USE flags!"
+ fi
+ fi
+ done
+
+ if [[ ${modecnt} -eq 0 ]] ; then
+ ewarn
+ ewarn "No mode selected, defaulting to paranoid!"
+ ewarn
+ ewarn "If you want to choose another mode, put mode-force OR mode-owner"
+ ewarn "into your USE flags and run emerge again."
+ ewarn
+ SUPHP_SETIDMODE=paranoid
+ fi
+
+ elog
+ elog "Using ${SUPHP_SETIDMODE/mode-} mode"
+ elog
+ elog "You can manipulate several configure options of this"
+ elog "ebuild through environment variables:"
+ elog
+ elog "SUPHP_MINUID: Minimum UID, which is allowed to run scripts (default: 1000)"
+ elog "SUPHP_MINGID: Minimum GID, which is allowed to run scripts (default: 100)"
+ elog "SUPHP_APACHEUSER: Name of the user Apache is running as (default: apache)"
+ elog "SUPHP_LOGFILE: Path to suPHP logfile (default: /var/log/apache2/suphp_log)"
+ elog
+
+ apache-module_pkg_setup
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ local myargs=""
+ use checkpath || myargs="${myargs} --disable-checkpath"
+
+ : ${SUPHP_MINUID:=1000}
+ : ${SUPHP_MINGID:=100}
+ : ${SUPHP_APACHEUSER:="apache"}
+ : ${SUPHP_LOGFILE:="/var/log/apache2/suphp_log"}
+
+ myargs="${myargs} \
+ --with-setid-mode=${SUPHP_SETIDMODE} \
+ --with-min-uid=${SUPHP_MINUID} \
+ --with-min-gid=${SUPHP_MINGID} \
+ --with-apache-user=${SUPHP_APACHEUSER} \
+ --with-logfile=${SUPHP_LOGFILE} \
+ --with-apxs=${APXS2} \
+ --with-apr=/usr"
+ econf ${myargs} || die "econf failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ apache-module_src_install
+ dosbin src/suphp
+ fperms 4755 /usr/sbin/suphp
+
+ dodoc ChangeLog doc/CONFIG
+
+ docinto apache
+ dodoc doc/apache/CONFIG doc/apache/INSTALL
+
+ insinto /etc
+ doins "${FILESDIR}/suphp.conf"
+}
+
+pkg_postinst() {
+ # Make sure the suphp binary is set setuid
+ chmod 4755 "${ROOT}"/usr/sbin/suphp
+
+ apache-module_pkg_postinst
+}