summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-14 17:09:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-14 17:09:30 +0000
commit27bbc5d6c15f5e6a8ec27a9330fc05b4fb365198 (patch)
tree12e7552b091bfe6621bfaaf6ff01d670d06177c8 /www-apache/mod_security/files
parentVersion bump (diff)
downloadgentoo-2-27bbc5d6c15f5e6a8ec27a9330fc05b4fb365198.tar.gz
gentoo-2-27bbc5d6c15f5e6a8ec27a9330fc05b4fb365198.tar.bz2
gentoo-2-27bbc5d6c15f5e6a8ec27a9330fc05b4fb365198.zip
Add patch to properly build with --as-needed (thanks to Christian Ruppert in bug #276272 — this required an extra fix to the autotools); add a perl USE flag to disable the update script and add the libwww-perl dependency (thanks again to Christian in bug #275864), and add a notice about the draconic command injection rule (bug #223815 reported by David Sommerseth.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_security/files')
-rw-r--r--www-apache/mod_security/files/mod_security-2.5.9-as-needed.patch26
-rw-r--r--www-apache/mod_security/files/mod_security-2.5.9-broken-autotools.patch13
2 files changed, 39 insertions, 0 deletions
diff --git a/www-apache/mod_security/files/mod_security-2.5.9-as-needed.patch b/www-apache/mod_security/files/mod_security-2.5.9-as-needed.patch
new file mode 100644
index 000000000000..77d093c140cc
--- /dev/null
+++ b/www-apache/mod_security/files/mod_security-2.5.9-as-needed.patch
@@ -0,0 +1,26 @@
+diff -Naurp -Naurp modsecurity-apache_2.5.9.old/apache2/Makefile.in modsecurity-apache_2.5.9/apache2/Makefile.in
+--- modsecurity-apache_2.5.9.old/apache2/Makefile.in 2009-07-02 19:18:31.000000000 +0200
++++ modsecurity-apache_2.5.9/apache2/Makefile.in 2009-07-02 19:48:23.000000000 +0200
+@@ -52,11 +52,11 @@ APU_LIBS = @APU_LIBS@
+ APU_LINK_LD = @APU_LINK_LD@
+
+ CPPFLAGS = @CPPFLAGS@ $(PCRE_CFLAGS) $(LIBXML_CFLAGS) $(LUA_CFLAGS)
+-LIBS = @LIBS@ $(PCRE_LIBS) $(LIBXML_LIBS) $(LUA_LIBS)
++LIBS = @LIBS@ $(PCRE_LIBS) $(LIBXML_LIBS) $(LUA_LIBS) $(APXS_LIBS) $(APR_LIBS) $(APR_LINK_LD) $(APU_LIBS) $(APU_LINK_LD)
+ LDFLAGS = @LDFLAGS@
+ CFLAGS = @CFLAGS@
+
+-COMPILE_APACHE_MOD = $(APXS_WRAPPER) -c $(CPPFLAGS) $(LDFLAGS) $(LIBS)
++COMPILE_APACHE_MOD = $(APXS_WRAPPER) -c $(CPPFLAGS) $(LDFLAGS)
+
+ INSTALL_MOD_SHARED = $(APXS_WRAPPER) -i
+
+@@ -93,7 +93,7 @@ mod_security2.la: $(MOD_SECURITY2_H) *.c
+ src="$$src $$f.c"; \
+ done; \
+ rm -f msc_test msc_test.o msc_test.lo msc_test.slo; \
+- $(COMPILE_APACHE_MOD) $(APXS_EXTRA_CFLAGS) $(MODSEC_APXS_EXTRA_CFLAGS) $$src
++ $(COMPILE_APACHE_MOD) $(APXS_EXTRA_CFLAGS) $(MODSEC_APXS_EXTRA_CFLAGS) $$src $(LIBS)
+
+ ### MLogC
+ mlogc:
diff --git a/www-apache/mod_security/files/mod_security-2.5.9-broken-autotools.patch b/www-apache/mod_security/files/mod_security-2.5.9-broken-autotools.patch
index 75cbb4600f60..4ef1960d6535 100644
--- a/www-apache/mod_security/files/mod_security-2.5.9-broken-autotools.patch
+++ b/www-apache/mod_security/files/mod_security-2.5.9-broken-autotools.patch
@@ -32,3 +32,16 @@ Index: modsecurity-apache_2.5.9/apache2/build/find_apu.m4
fi
dnl # Look for the config script
+Index: modsecurity-apache_2.5.9/apache2/configure.in
+===================================================================
+--- modsecurity-apache_2.5.9.orig/apache2/configure.in
++++ modsecurity-apache_2.5.9/apache2/configure.in
+@@ -247,7 +247,7 @@ VERSION_OK
+ if test "$verbose_output" -eq 1; then AC_MSG_NOTICE(apxs LIBDIR: $APXS_LIBDIR); fi
+ # Make sure the lib dir is used
+ if test -n "$APXS_LIBDIR"; then
+- APXS_LIBS="-L{$APXS_LIBDIR} `$APXS -q LIBS` `$APXS -q EXTRA_LIBS`"
++ APXS_LIBS="-L${APXS_LIBDIR} `$APXS -q LIBS` `$APXS -q EXTRA_LIBS`"
+ else
+ APXS_LIBS="`$APXS -q LIBS` `$APXS -q EXTRA_LIBS`"
+ fi